11.2 Installation Problem (mkinitrd & grub)

Guys & Dolls,

I finally got round to updating oS11.1 to os11.2 last night and hit a very peculiar problem.

The installation sailed through without a hiccup until it came to the final section where it had to update the grub settings, where it failed horribly.

Firstly I started to received error messages about unable to write initrd, followed by unable to switch to new installation.

I was then presented with the option of manually creating new bootloader settings using GRUB. None of the drop down menu’s provided information about the available partitions.

When I finally rebooted, I was presented with a mixture of old and new grub settings. The background and initial grub load seemed to be that of the os11.2, but the menu options were of the old os11.1.

Choosing to load using the os11.1 grub settings failed, because the kernel versions it was trying to load was incorrect and it resulted in displaying message about waiting for my drive to come online.

Bit of a weird problem, but I re-inserted the dvd and tried to run the “repair a installation”, again, this recognised that the bootloader as not been written properly and still it failed.

Log file said for me to check the y2log, but guess what - the verification of all installation passed except y2log where it failed on trying to open the one crucial file which could have explained more as to what’s going on.

Luckily my old grub settings still worked fine by allowing me to boot into “windows”. So downloaded a tool called Ext2IFS (Ext2 IFS For Windows: Download) which allowed me to view the Ext2 partition through Windows. This showed all files and partitions were intact with the only problem being the inability to execute mknitrd, update the grub settings and swith to using the new installation.

So the questions is, as anyone else come across this scenario and help will be much appreciated, as the problem is driving me mad…