11.2 install problem

I have tried to install 11.2 (with KDE) several times on x86-64 AMD Toshiba without success.
The problem is the login where it should be ‘auto’ without password, it sets a login screen for name and password and when I enter my name and PW, login fails and the only way of getting in is to enter ‘root’ then password. The inevitable then happens when I end up with Dolphin showing a root screen with all my ‘home’ files showing and an empty ‘home’ file!
Strangely, if I hit the ‘failsafe’ I get in without any login or password screen.
I have been using SuSE from 10.3 without a problem,what am I doing
wrong in install. BTW Grub is showing the correct root drive partition.
Please help.

It looks (this is a guess) as if there is something wrong with the user login. The autologin will then fail and revert to the login screen. From where you again can not login.

BTW never, NEVER login from there with root!!!

What you could try is go to the console (Ctrl-Alt-F1) and log in there in the CLI with your user id. See if that fails also.

Thank you for the response hcw.
I have tried a login from the konsole but that didn’t work, it still wanted ‘root’ and password!
BTW, thanks for the 'heads up’to not login with root but I did it in desperation, to see if anything loaded correctly.
I have now re-installed 11.1 so that I can continue working.
I just dont have the time to ‘play around’ with it! I plan to wait about a month to see if a later download will be any better.


It looks if you messed up your user. You can try to fix that. As roott do

cat /etc/passwd

and check if your username is there in the list.
When yes, do

passwd <your-username>

and enter a password (twice).
You have now as root set the password of that user and thus can try to log in again.

It is of course allright when you want to install again in a few monthes, but a new download is of no use. The openSUSE 11.2 install media will not change. Newer versions of packages belonging to it can be installed from the repositories.

Thanks agin for a prompt and helpful response hcw.
I have now reinstalled 11.1 on my (working) laptop so I am going to try to install 11.2 on my other desktop.
You have opened up another possibility for me (I am not that familiar with the CLI operation) with the cat pw check option and although I tried several ways to install the the name, pw autologin screen, you may be right - somehow or other I messed it up!
I will try again.

Wishing you success. May be you should leave the automatic login for a bit later, when you are satiesfied that your system is OK.

I can finalize this thread with the confirmation that I have now installed, successfully logged in, using 11.2 with KDE 4.3!!
To poster hcw my thanks for your help, and any other user/member who is interested,the final attempt involved a COMPLETE format of all linux existing partitions and a new install WITH ext4 fs.
Of course, I had a complete backup of my home directory to re-install!

I do not understand why this worked, (-when the original install with my existing ext3 /home directory should have worked) - but it just did not!


I’ll tell you why:

Users do not only have a username, they have a userID as well. The userID’s on your old /home must have been different to the ones in the new install, i.e. user ‘willow’ first was 1002, now is 1000.

Logging in on the console and change the permissions of your old /home/YOURUSERNAME would have solved it.

This for your info.