11.2 install on hw raid1 with lvm2 fails


have been trying to install 11.2 on the following setup:

  • AMD Athlon™ 64 X2 Dual Core Processor 5600+
  • 4GB memory
  • 2 x 1TB Samsung HD
  • MB Asus M2N-E with nFORCE 570 series.
  • GeForce 9800 GT/PCI/SSE2

System runs well on 11.1; using hw Raid1, too but no lvm.

I start to install with the DVD, reach the gui, klick myself
through until I reach the partition/lvm setup. The default
lvm setup suggests just ~14GB total for /boot /root and /home,
so I enter to resize everything to take advantage of my 1TB disks and have the following config part1: /boot, 100MB, ext4; part2 is lvm with swap 2GB, / 20GB, /home 500GB, ~400GB are left over to asign them later as needed.

System then installs all software, reboots and then enters run level 3. What obviously happens is that the /dev/disk/by-id/ nor the /dev/mapper/nvidia_aahchfdi_part1, /dev/mapper/nvidia_aahchfdi_part2 exist and the mount of /boot fails because the device is unknown.

That’s it.

Workaround tried: I changed in /etc/fstab the device name for /boot to /dev/sda1. System then reboots nicely, but obviously later other problems happen.

Any idea how to address this?


Looks like to be this bug. Unfortunately the lvm2 version that fixes the problem did not make it into the distro. I now will have to figure out how to get it somehow intstalled and then be able to upgrade lvm2 from Factory

Ideas on this are very welcome.

I’ve the same kind of problem :frowning: I want to install from the Live-CD but the installation procedure fails (error 4004)

It seems we need lvm2-2.02.45-19.1.x86_64.rpm, which is in
current Factory tree. Now I wonder, how to I get an install
done either via Live or released DVD being able to incorporate lvm2-2.02.45-19.1.x86_64.rpm.

I’ve just installed this package (you can find it here : Index of /repositories/Base:/System/openSUSE_Factory/x86_64 ). But the installation still fails :’(

How did you manage it? I’m still wondering how I can apply this to my new install. Once I know howto install I can look into it more deeply.

I’m using the Live-CD so I can update this package before trying to install Opensuse.

Just install clean into 3 partitions. It’ll be far quicker and save you a lot of trouble. You can move the 11.2 system data later very easily and then update the boot process, once you no longer use 11.1.

/boot - 100 MB like you had
/ - 8GB is plenty, I have 4GB used.

Leave all your old data and your 11.1 instalation untouched. Once you have 11.2 working and can multi-boot (it really should run very well as your hardware is very similar to my desktop box) and I have found 11.2 very performant.

Then you can set up RAID & LVM. There’s known bugs in the installer, and perhaps in the main release concerning RAID & LVM, which will be easier to fix up later, step by step, rather than trying to do things in the install environment.

I installed an 11.1 clean earlier today to check a fault in 11.2 is a genuine regression, and it’s quite funny running update after and seeing how many critical bug & security fixes are STRONGLY recommended. 11.2 is much more ready for usage than 11.1 was after release, but that doesn’t mean there won’t also be 100’s of fixes arriving in the next 6 months!

I gave up on 11.2. I’ll stay with 11.1. The lvm/raid1 bug is a real stopper.
I was lucky that I planned for new disks, so that I did not touch
my 11.1 install at all.

I tried actually everything. Last thing I did was a 11.1 clean
install and then upgrading with 11.2 and Factory. But no success.
Although the bug is claimed to be fixed.

If someone has an idea to make it work, pls let me know.