11.2 install failure but 11.1 to 11.2 upgrade (partial) success

Machine is basically an ASUS mother board with an AMD64 Athlon x2 processor and Nvidia hardware RAID discs mirroring each other. It has been used as a server for about four years under various incantations of openSUSE.
After a major software corruption a couple of days ago, I decided to install 11.2 from an iso image downloaded, MD5 check-summed OK. The DVD was burnt on an iMac at the lowest speed (x8) and verified correctly.

 Installation proceeded as expected from partitioning to the installation of the GRUB loader - which failed - but only with a warning. Of course any attempt to boot came up with No Operating System! I attempted a system repair from the DVD - which glibly informed me it couldn't find the partition table and reported some weird disc names  - sde nnn!!

 Knowing that 11.1 had worked from the first day, I re-installed it with no problems, manually configured the network stuff (the machine has two Ethernet cards one for the internal, the other for the external firewall zones). I tested out everything, vigorously exercising the disc and all was rock solid. I registered the installation with Novell with no problem, did a (rather long) on-line update and again checked that everything was working as expected - it was.

 Yesterday I tried the 11.2 update - this time it happily saw the RAID as /dev/mapper/xxxx partitions and installed with only a minor hiccup (at the beginning it found a conflict between kernel-default and kernel-default-base - I selected the base option). It transferred over the original machine configuration automatically and everything works as expected after vigorous testing.

 However! When I went to configure on-line update things went pear-shaped! After selecting 'advanced' and the register option I was faced with a window requiring Manual Interaction. I clicked on Continue and there was a further window needing installation of mozilla-xulrunner190 - but the version of that installed was 191!! Accordingly, I pasted the URL and arguments manually into firefox to receive a document from Novell with some text and a continue button. Clicking on that - nothing happened! I then looked at the action along the window bottom and read "javascript:close()" - which is why nothing happened! I still cannot on-line update!

 Since there were two problems with on-line registration - one openSUSE and the other Novell I have reported them - but if anyone can give me a work-around or fix for this I should be very grateful? Please???

 Can anyone give me a fix or a work-around so that I am able to carry out an on-line update? Please??

However! When I went to configure on-line update
This is NOT necessary.
Just open a terminal, become su -
And do

zypper up

I would avoid RAID at all costs too.

asgardnz wrote:
> Can anyone give me a fix or a work-around so that I am able to
> carry out an on-line update? Please??

what is the output of any of these:

cat /etc/SuSE-release

lsb_release -sd |cut -f2 -d ""\"

cat /etc/issue

DenverD (Linux Counter 282315)
CAVEAT: http://is.gd/bpoMD
posted via NNTP w/TBird | KDE 3.5.7 | openSUSE 10.3 SMP i686
AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
CMedia 9761 AC’97 Audio

Thanks for the suggestions - results as follows -

“zypper up” - a Loading line, a Reading line and “Nothing to do” - all within half a second or so. Since 11.2 came out quite a while ago I cannot believe that there have been no updates!

“cat /etc/SuSE-release” - two lines

openSUSE 11.2 (x86_64)

“lib_release …” same as the first line above

“cat /etc/issue” - one line

Welcome to openSUSE 11.2 “Emerald” - - Kernel \r (\l).
followed by three blank lines.

These seem to confirm the relase update was OK - but I have my doubts about the no updates problem - which was where I came in!

Sorry there was no magic resolution!!

Just a quick 2c worth:
Are you sure you had 11.1 installed? openSUSE doesnt ask for confimation/registration for updates, but Suse Linux does.
Since it seems that you have a running 11.2 system, try going to yast2>software>repos and check that you have the correct 11.2 repos and that they are still not set to 11.1 (11.2 oss, non-oss and update)

Please post result of

zypper lr -d

Ah! interesting - I always thought I was using openSUSE 11.1 - it certainly says so on the start screen from the DVD boot. Anyway, The machine is definitely running openSUSE 11.2 now.

The repos check merely shows cd:///

The “zipper lr -d” check gives much the same -

1 openSUSE 11.2_0 openSUSE 11.2_0 Yes Yes 99 yast2 cd:///

/var/cache/zypp/packages, by the way, has an empty (no files in any sub-directory) directory openSUSE 11.1-0 - which might serve to confirm that I was running openSuSE 11.1 before the update to 11.2.

There are no uncommented lines in /etc/zypp/zypp.conf or /etc/zypp/zypper.conf.
/etc/zypp/repos.d/openSUSE 11.2-0.repo just has th one baseurl=cd:/// which seems consistent with the repository check above.

I remain baffled! Sorry!

You need to add the oss, non-oss and update, repositories.

become su - in a terminal
and do

zypper ar -f http://download.opensuse.org/distribution/11.2/repo/oss/ oss
zypper ar -f http://download.opensuse.org/distribution/11.2/repo/non-oss/ non-oss
zypper ar -f http://download.opensuse.org/update/11.2/ updates
zypper ref
zypper up

yes or (a) accept to licences or keys


Many thanks for the incantations! I just didn’t know where to find the URLs to do this.

All is merrily updating as I type this.

Never previously having used zypper manually, the log messages are very instructive.

Thanks again! I will crawl back into the woodwork for another few years!