11.2 install fails...

I used the command-line browser ‘links’ to navigate nvidia.com until I found the right file and downloaded it.


Here some more observations from my install. After following the instructions and getting to run level 3, I was unable to get my wireless card to connect to the internet, and I couldn’t get linux to mount my CD-ROM correctly. So, as a guess, I tried to see if I could get back to run level 5. Sure enough after typing “init 5” lo and behold I was at the login screen. I logged in as root and sure enough it worked. I installed the packages needed to install the driver, installed the driver and then ran sax2 to update my xorg11.cnf file.

Once that was done, it worked just as SurplusIguana said it would and I am writing this from openSUSE 11.2.

However, since I was able to load KDM before installing the driver, wouldn’t that imply that the problem is infact with the x11org.cnf file and not with the driver that is packaged with openSUSE 11.2? I"m still a newb to linux and openSUSE but as an engineer this seems like the logical conclusion.

Hope this helps you experts figure out exactly what went wrong.


I’m no expert, but I think the answer is “both”. I suspect that (at least in my case) the problem is that my nVidia card (which is a Quadro NVS and thus isn’t one of the standard consumer-grade graphics cards) isn’t supported by whatever driver the setup program chose to use by default in the xorg.conf.

That said, my experience was somewhat different than yours because when I did ‘init 5’ without first installing the driver, it just hung like always. Maybe your problem was somewhat different.

In any case, I’m glad my fumbling around helped you solve your problem.

There is no xorg.conf in 11.2. Not at least until you run sax2. Which I have not done.
But well done in resolving your issue

No xorg.conf file - openSUSE Forums

Where has graphics card adjustment gone in YAST? - openSUSE Forums

I have this exact same problem on a brand new HP workstation with an nVIDIA Quadro card.

The suggested fix does not work for me. I have an nvidia Quadro FX580. The nvidia drivers appear to install correctly, but sax2 crashes and burns with the following messages printed repeatedly:

ISaX: could not import file: /var/cache/sax/files/config at /usr/sbin/isax line 199.

I tried running “sax2 -r -m 0=nvidia”, “sax2”, “sax2 -a”, “sax2 -r -a” and no luck.

/var/log/SaX.log indicates that the nvidia module could not be loaded, neither could glx.

I also tried rebooting and the computer just locks up solid.

Any suggestions?

I have almost the same problem i did a clean install ,and after the first reboot and after the kernel loaded a blinking dash appears in the upper left corner of my screen and it hungs,i have an ATI X1950 graphics card.Does anyone have any suggestion?

To everyone else having the same or similar problems:

Your first step is to figure out what is going wrong. For me, I got my first clues by booting a livecd, mounting my hard drive, and looking at /var/log/messages and /var/log/Xorg.0.log.

Your second step is to fix it. If your problem is the same as mine (the graphics drivers are bogus), try following the steps I outlined in my description of my fix. If your problem is not the same as mine, try searching for the error message you’re seeing or posting a new topic.

As a suggestion to the OpenSUSE installer team, if you could provide an option for using the text-mode ncurses installer rather than the X installer, that would be great. Maybe consider this for 11.3 :slight_smile:


> As a suggestion to the OpenSUSE installer team, if you could provide an
> option for using the text-mode ncurses installer rather than the X
> installer, that would be great. Maybe consider this for 11.3 :slight_smile:

unless it was removed (which i doubt) it is there…i think on the
first green screen press F3, or maybe F1 for Help, and look around…


By ‘first green screen’ do you mean the grub bootloader? Because if that’s the one you’re thinking of I definitely looked around to see if there was an option that would help. Maybe I just stupidly overlooked it, though.


> By ‘first green screen’ do you mean the grub bootloader?

if you boot either the Live CD or the install DVD the first green
screen looks like this, i think:


down at the bottom there is a menu, i think F3 leads to a text based
install option…but, i could be wrong…i was wrong once.


Correct @palladium

> Correct @palladium
> http://tinyurl.com/yzconhd

which leads me to muse:

i wonder why it is not (yet) possible to have the live website’s path
lead to the 11.2 install guide, instead of:

http://opensuse.org/ > http://www.opensuse.org/en/ >
click “get it” >
http://software.opensuse.org/112/en >
click “Step-by-step installation guide” >
which lands on Installation/11.1 DVD Install

does anyone know if a full set of 11.2 screen shots are available,
and/or if they can just be “dropped” into the current slots and the
words surrounding still sing true?

or, maybe just the link from http://software.opensuse.org/112/en needs
to be changed to point to the existing 11.2 install guide ??? *

so, i raised that issue on the Wiki care and feeding mail list…(and
will probably become unpopular there…also)


the boot from livecd and using the command (sax2 -r -m0=ati) solution worked for me also.
after i mounted my hard disk and changed the xorg.conf file