11.2 install fails...

I installed 11.2 x64 from DVD. Everything seemed to be going fine, until I got to the point where the DVD install is done and it goes to reboot and boot from the HDD.

It goes through the initial boot process, then the screen blanks and everything seems to hang. The system does not respond to keyboard, and none of the keyboard toggle lights work.

The only “strange” thing I did on install was not create a default user (I only want a root local user; the rest will be populated by NIS).

Any suggestions?



I tried it again with specifying a local non-superuser this time, and the problem occurred again.

Does the same thing on failsafe boot too.

Not sure what to do at this point…


It sounds like the configuration is balking at something. At this point when setting up install, de-select auto-configuration:

Then try setting up devices manually

I should have mentioned…I already have auto configuration turned off (I prefer to set things up manually myself anyway).

Did you burn at the slowest possible speed? Else try an install but
disable the ‘install from image’ on the final summary screen, down the
bottom. Also create a default user and delete the account after.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 16:33, 2 users, load average: 0.26, 0.09, 0.02
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

OK, I just tried an install with the default runlevel set to 3 instead of 5…same problem.

(I realize that it has to do the post-install config before it even cares about the runlevel, but since I don’t know what to do now I’m just trying random useless ****).

Did you try auto-config

Not yet…I’m actually in the process of trying it now.

(I tried to avoid that because it adds an extra annoying step of changing the hostname and whatever else the autoconfig got wrong).

I’m using a pretty modern nVidia card…I don’t suppose that could cause a problem?

Above all, are you sure the DVD is correct? Did you check the md5 sum of the downloaded image and of the burned DVD?

Good question…I did check the md5 of the downloaded image, but I didn’t verify the DVD. If this next go doesn’t work then I’ll run the verify option on the DVD to see if it’s bogus.

There is a new setup in 11.2 and by default no xorg.conf is formed. But running sax2 is still possible and this will of course create a xorg.conf
There are one or two threads already about this new setup

So I did a ‘check installation media’ on the DVD, and it told me the checksum is wrong. I don’t have a DVD burner here, so I ran home to burn a new DVD and also burn a net install CD. I turned on the ‘verify’ option on K3B, and it verified OK.

When I got back to work and tried ‘check installation media’ on the new DVD, it told me the checksum was wrong again. So I tried the net install CD, and it told me that checksum was wrong too!

Now, it’s possible that my DVD burner is just writing duds, but the verify I did afterward checked out OK.

I tried doing an install from the new DVD anyway and I ran into the same problem.

I’m trying an install from the netinstall disc now.

If this doesn’t work I may have to give another distro a shot…usually OpenSUSE installation is pretty painless, but this time around it seems to be full of fail.


try a live CD image too if you can, but its possible that your dvd iso download is a dud too, I have had that happen so maybe a redownload is a good idea too

Just sat through an hour and a half worth of net install, and the same **** happened.

Looks to me as though some piece of the installer doesn’t work on my hardware. It can’t have been a problem with my install media, because the net install cd downloaded all the install/conf stuff from the repo.

I did some looking for those threads but didn’t see anything…could you point me to them?


I tried doing a no-GUI install (so that the configure program runs in text-only mode), and then I did an upgrade and installed X and KDE 4. Everything booted fine, but then when I did an ‘init 5’, I got the hang. This looks to me as though either the drivers that come on the DVD for my graphics hardware are busted or the default xorg.conf is very very wrong.

Interestingly, even though the box gives the appearance of being hung, maybe it isn’t, because /var/log messages has the following:

X server startup timeout, terminating
X server termination timeout, killing
X server for display :0 cannot be started, session disabled
Power button pressed, executing /sbin/shutdown -h now

So it at least realized that the power button was pressed (however, it does not respond to ctrl+alt+f1 or ctrl+alt+del, and the keyboard toggle lights don’t work)

OK, so after getting the above, I used links to download the latest nvidia drivers and install them. Now X works.

So here’s my question: is it possible to insert a step between the installation and the configuration to install the latest nvidia drivers? Or do I just have to do this roundabout way of installing in order to make it work?

Alternately, is there a way to force it to use the text-mode installer even if I’m installing X?

(I’m going to do a reinstall either way because I took some shortcuts on the install that I’m regretting now).

I have the same problem here:

My Laptop is an Compaq CQ60-419WM and trie too many times to install 11.2 without any succeed.

In fact, it just hangs an the first installation menu and en LiveCd never loads at all.

I already burn 5 cd’s in different PCs without any luck.

Can some body help me.

I run the CD in other PCs and anything with nVidia chipsets give me the hangs.

Thanks a lot.

How I fixed my problem:

  • I did an install like normal
  • When I got to the GRUB loader, I selected ‘failsafe’ and removed the vga= line from the boot params
  • As it was booting, I pressed ^C like a madman

Some combination of the last two steps seems to have worked, because instead of failing it gave me an XDM login screen.

I switched to terminal 1, logged in as root, and did ‘init 3’. Then I downloaded the latest nvidia drivers using links and installed them.

After successfully installing the nvidia drivers, I rebooted. Once it rebooted, it started the post-install config like normal and everything worked!

Hopefully in 11.3 there will be some code in the installer to fix this failure…

When you say “I downloaded them using the links and installed them” can you explain a little further what you did?

Do you mean that once you got to the command line at run level 3 you used wget to download them and then ran the installer?

I have the same problem and got all the way to logging in as root and getting to run level 3 and the command line but I am unsure what you mean when you say “downloaded the nvidia drivers from links and installed them”