11.2 Install fails - no keyboard, no mouse

I just bought a Fujitsu Esprimo P1500 computer with Windows 7 Home Premium. When I try to install OpenSuse 11.2, the keyboard works in the first screen, so I can select “Installation” with the arrow keys. But when the next screen comes up (select keyboard etc.), neither keyboard nor mouse work. Well, the CapsLock and NumLock LEDs light up, but that is all (and hitting the corresponding keys does not turn them off.) The (optical) mouse does not light up.

Correction - the mouse does light up; it just does not do anything. And it’s not the NumLock (leftmost) LED that lights up with the ShiftLock (middle) one; it’s the rightmost LED (I’m not sure of the name - ScrollLock?)

I have tried two different 11.2 Install DVD’s with the same result. Also, I have tried Safe Settings - it does not help.

I tried a USB keyboard in addition to the supplied PS2 one. It does not work, either.

I have a very silly idea … but I’ve seen this work in the past.

Is this a laptop ? If so, what happens if you plug in an external monitor ?

No, it’s a desktop - well, those usually end up on the floor, don’t they?

In any case, I finally tried “No local APIC” when booting from the install DVD and, with this, was able to have the mouse and the keyboard work and to finish the installation. Unfortunately, as a side effect, one of the processor cores seems to have been turned off. This is supposed to be a dual-core Pentium machine (E5300@2.60GHz). It is rather lame to have just one core running.

I note on another thread some users have discovered uncommenting in the /etc/X11/xorg.conf file:

"AutoAddDevices" "off" 

works for them

For the time being, I have given up on openSUSE 11.2. Namely, I succeeded in installing Fedora 12 such that both processor cores, as well as keyboard and mouse, work now. For FC12, kernel flag “noapic” sufficed.

There is no /etc/X11/xorg.conf in the FC12 installation.

Glad to read its working in FC12. I like the Fedora distribution. The “noapic” flag would worry and irritate me.