11.2 - HP probook wifi (+ sw controled wifi switch)

Opensuse 11.2 related problem:

Hello i have new HP probook 4710 and i have problem with wifi: Intel® WiFi Link 5100; Broadcom 4322AGN which was not detected by opensuse 11.2.
(Result is Knetwork manager has wireless connection category disabled)

I found 3 possible solutions and 1 statement of kernel bug which can be relevant. (solutions did not worked)

solution 1

  • installation of “ipw-firmware” package

solution 2

sudo /usr/sbin/install_bcm43xx_firmware

solution 3
installation of “broadcom-wl-kmp-<kernel_type>” package

bug statement

I think there is possible problem can be evoked by software ON/OFF wifi switch on this notebook, but i realy cant find driver for this.

Dont you anyone know solution for this?

THX!

Have you tried to add or remove b43? Check out this page and see if it helps. HCL/Network Adapters (Wireless)/Broadcom BCM43xx - openSUSE

Hello,
so i found SOLUTION and i hope this will help someone with my problems :).

Everything was fine with 2 packages from packman repo:

  • broadcom-wl
  • broadcom-wl-kmp-<kernel_type> (<kernel_type> was desktop at my laptop)

WIFI did not worked because of wrong BIOS switch position.
I switched:

  • wireless button state: enabled
  • embedded WLAN Device: enabled

Wifi was automaticaly enabled in Knetwork manager.

I found new problem, embedded WLAN Device: enabled state in BIOS cause installation freeze in loading udev just in the begining of opensuse 11.2 installation, so you will probably have it disabled during installation on HP probook… wery strange… :frowning:

After installation do switch embedded WLAN Device to enabled for funcional wifi… :idea:

just a note OS11.2 will be freezing at loading udev during boot if youll have “embedded WLAN Device: enabled” in bios until broadcom-wl packages succesfull installation