11.2 Gnome no spdif audio

I hope I’m missing something and sound isn’t broken, but I’ve had no luck getting spdif audio to work under Gnome. I did get it to work with KDE with kmix. (I also got it to work w latest Mandriva)

The pulse audio controls under Gnome are set to IEC958. Alsamixer shows the IEE958 unmuted, but level is set to 0 and cannot be changed. I did the restricted a/v formats install.

There is no sound via spdif (nor via hdmi, btw).

Motherboard is Asus M3A78-T w Realtek alc1200 audio.

Any help, greatly appreciated.

It sounds like you did some basic work, what I usually do is make sure aplay works. This usually means you choose the iec958 device listed with aplay -l, or aplay -L then pipe the content to the proper device. I also like to test with mplayer as well as you can tell it what device to output as well as test if your receiver is getting the proper lock, be it dts, or what have you.

Here is the sound howto which might be useful if you haven’t looked at it before. Also would not hurt to look at the intel-hda howto as well as that has more information about going into the kernel drivers and finding you setting so you can set up your modprobe.d sound file.

SDB:AudioTroubleshooting - openSUSE

Problem Fixed, at lest for stereo, have not had time to test passthru.


  1. Install Gmixer (really great idea to not have it by default)
  2. Select HDA ATI SB (Alsa mixer)
  3. Adjust volume sliders.

That got me as far as CD audio via Banshee.

Installed Songbird for mp3 playback. Accepted the two dependency changes, and mp3s play.

So 4 Days, numerous installs – including other distributions,
too many failed fixes to remember and I now have sound. Just like the 8 year old XP I’m desperately trying to eliminate.

Thanks to all that tried to help, here and in other forums.