[11.2] Enabling direct rendering

Dear All,

I am trying to run direct rendering on my openSUSE 11.2 with KDE 4.3.1. Some of the visualisation software I use seems to require it.

The following observations about my machine can be made


>glxinfo|grep direct
direct rendering: No


>hwinfo --gfxcard
28: PCI 100.0: 0300 VGA compatible controller (VGA)
  [Created at pci.318]
  UDI: /org/freedesktop/Hal/devices/pci_10de_640
  Unique ID: VCu0.MTuUz6HxyUE
  Parent ID: vSkL.Kc6JobdJb09
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "nVidia G96 [GeForce 9500 GT]"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x0640 "G96 [GeForce 9500 GT]"
  SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
  SubDevice: pci 0x82a5
  Revision: 0xa1
  Driver: "nvidia"
  Driver Modules: "nvidia"
  Memory Range: 0xfd000000-0xfdffffff (rw,non-prefetchable)
  Memory Range: 0xd0000000-0xdfffffff (rw,prefetchable)
  Memory Range: 0xfa000000-0xfbffffff (rw,non-prefetchable)
  I/O Ports: 0xcc00-0xcc7f (rw)
  Memory Range: 0xfe980000-0xfe9fffff (ro,prefetchable,disabled)
  IRQ: 16 (26091 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v000010DEd00000640sv00001043sd000082A5bc03sc00i00"
  Driver Info #0:
    Driver Status: nvidiafb is not active
    Driver Activation Cmd: "modprobe nvidiafb"
  Driver Info #1:
    Driver Status: nvidia is active
    Driver Activation Cmd: "modprobe nvidia"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #10 (PCI bridge)

Primary display adapter: #28

In Sax2 “Activate 3D Acceleration” is disabled (greyed out) but checked.

Desktop effects are not high on my priority list but it might be a clue that I cannot turn them on from Configure Desktop.

Let me also ask whether enabling direct rendering may harm my dual monitor setting. The latter is of paramount importance to me on my desktop and therefore I would not like to choose between these two features.

If you could please consider advising me on this issue or pointing me to some reference articles I would be be most grateful.

Do you have Load “dri” in the “Module” section of /etc/X11/xorg.conf, as well as the following section at the end of this file :

Section "DRI"
        Group   "video"
        Mode    0666
EndSection

?

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Do you install the nVidia driver from nVidia???


VampirD
No in elenath hîlar nan hâd gîn
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.12 (GNU/Linux)
Comment: Using GnuPG with SUSE - http://enigmail.mozdev.org/

iEYEARECAAYFAktgplIACgkQJQ+0ABWtaVnTNgCg3cX/qTwuLtw2z0Ep5xqwQ1m9
vdEAnAm+6AOJGy7L7EOpUM3Yq6mCq44C
=+Xbg
-----END PGP SIGNATURE-----

Thank you for your replies

@VampirD: Yes, I believe that this is the case. Here is an additional confirmation:


lsmod | grep nvidia
nvidia               9647368  28

Moreover, I have NVIDIA repository in my Software repositories with a URL ftp://download.nvidia.com/opensuse/11.2/. I had to install those drivers in order to make my monitors work in extended desktop mode.

@please_try_again: Searching through my xorg.conf file reveals no Module section nor any reference to DRI. Do you think I should add both?

On 11.2 xorg.conf is obsolete. If it’s there it’s used, often leading to instable situtions. Remove/rename xorg.conf and the system should do things for you.

After about a 100 installs, I have no machines using xorg.conf, most of them have NVIDIA’s.

Thank you Knurpht. The things you say comply with what I had been reading but unfortunately when I remove xorg.conf I loose my extended desktop upon X11 restart. When I run nvidia-settings to set it up again my changes are not enforced as long as I don’t save into xorg.conf. Could you please suggest any way around it?

whhhrrrm. Since my 24" came, I don’t have dual monitors anymore. Don’t know if the feature in KDE4’s systemsettings already works properly. But that’s where you should look.

Maybe installing nvdock, and running it (it gives about the same icon in the systray as it does on windu systems) will give more c.q. adequate info.

Thanks. It would be interesting to follow this route. Maybe I can find out more about setting Twin View with xorg.conf and then come back and post the answer here. However, even when I remove xorg.conf I still get a negative reply from glxinfo|grep direct, Desktop effects are still off and so forth.

Is there any other action, apart of removing xorg.conf, I should implement to impose direct rendering upon my system?

Nope. Installing the NVIDIA driver should arrange that. From what I see there’s something wrong with the driver install. Did you update in the meantime?
Please post output of:
uname -a

Here is the output:

uname -a
Linux soli31888c 2.6.31.8-0.1-desktop #1 SMP PREEMPT 2009-12-15 23:55:40 +0100 x86_64 x86_64 x86_64 GNU/Linux

As you mentioned it to me, I recalled that I had updated the driver through yast when I started tinkering with this issue some two or three days ago.

This means you have no NVIDIA driver at the moment !!! You installed the module for the 11.2 default kernel.

Quickly:
Install the Linux Kernel Development Pattern through the software installer. Remove the NVIDIA packages.
Open a terminal window and do, as the normal user, in your own /home/username:
wget ftp://download.nvidia.com/XFree86/Linux-x86_64/195.30/NVIDIA-Linux-x86_64-195.30-pkg2.run

Now log off, at the login screen hit Ctrl+Alt+F1. Log in with normal username and password. Do this, enter rootpassword when asked for:

su -c ‘init 3’
su -c ‘sh NVIDIA-Linux-x86_64-195.30-pkg2.run -q’

Accept the license, click OK when asked for. The installer will build the kernel driver module, and install it. It will tell you to use sax2, DON’T. When done do:

su -c ‘init 5 && exit’

This brings back the login screen. Log onto KDE4 and you should be fine.

Mind, procedure has to be repeated on each kernel-update…

Very many thanks! You were absolutely right. Installation of the driver solved the matter and I can use above mentioned software and as a benefit I got desktop effects working.

If I may impose upon you with a request of explanation. How did you figure out that I don’t have the drivers installed? hwinfo shows exactly the same information. It even says: driver: “nvidia”. lsmod also talks about nvidia.

And how come I didn’t have these drivers installed? I could swear that I used one of those one-click install. That is how I got nvidia-settings application and how I made extended mode work. It also added NVIDIA to my software repositories. It is very confusing.

I looked in the repo on my own system. Saw the kernel modules were still for 2.6.31-5, your kernel is 2.6.31-8.

The NVIDIA driver is a kernel module. The ones from the repo should have been uninstalled by dependency IMHO.

In your previous situation X finds the old driver and tries to use it. But it won’t work since the new kernel "doesn’t know it’.
A manual install (re)creates the NVIDIA kernel driver module for the running, i.e. newer, kernel, and to links for the X server. On next start of X, X finds the driver correctly linked to the running kernel’s one, and all works.

It’s technical, hope it’s clear, otherwise ask more questions.

Great! Now it seems clear. So you asked for uname -a to learn what kernel I have and make a comparison with your repositories. All right. Once again thank you kindly for assistance.

Great you got it ( & sorted). Enjoy.

Hi, i just want to add that i had a similar problem (my IDV graphics software was crashing because of rendering not enabled). By recreating the nvidia kernel following Knurpht’s instructions, all works fine now. Thanks!