11.2 destoryed my 2nd partition

I had opensuse 11.0 on a system at home. Decided to install 11.2 since I had read that 11.2 can do upgrades from then forward.
Well I fiddled with the partitioning settings, made sure that it was configured exactly like it was before - /dev/sda1 is /; /dev/sda2 is swap, /dev/sda3 is /max.

I knew I would have to do a clean install, but thought it would not touch my other partition /max. I explicitly told it to NOT format /dev/sda3.

Well when it booted, it goes into maintenance mode - says my partition is hosed. fsck tells me that maybe my /dev/sda3 is a zero length partition.

Hallelujah that I turned off my external drive.

So,for sure I will NOT be installing 11.2 on my other two systems at work.

Now that my entire machine at home is a vegetable, think I might go take a look at Debian. This is not fun.
Thought Linux would be a bit better than Windows in this respect.

Lesson learned. If it ain’t broke, don’t try to fix it.


Well, went to reinstall again thinking maybe it was a bad install.
My /dev/sda3 is 1kb in size and the partition table is hosed.
Had to delete the partition table.

Thanks again,


Something like that should not happen with any Linux distro. I would check the harddrive for failures to make sure that it doesn’t have bad sectors. Also I would take a look at the partition table to see in which order partitions are written, allthough that shouldn’t matter … but who knows! Also check in the BIOS what mode it’s using (lba, large ?) and if it’s a SATA drive, whether it is handled as IDE or SCSI. If you have the choice between legacy and AHCI, take AHCI before installing (because it might mot be possible to switch back after, and AHCI is better).

If you have nothing to lose anymore, try to install Fedora on that harddrive. I haven’t install the latest release yet. But the Fedora 11 automatically ran palimpsest, a harddrive diagnostics tools during setup. If your harddrive is not OK, it will tell you and refuse to install. I would assume that Fedora 12 would do that too.

Do NOT format sda3 ! An error in the partition table doesn’t mean a data loss at this point. Maybe the lenght of the partition is just gone and the system think it has zero size.

If you have two harddisks, have a look on the issue I described in that other thread:
OpenSUSE Install Wiped Out Other Linux Installs - openSUSE Forums

And yes, Linux is better than Windows by all means!

Testdisk is also supposed to be good for partition / data recovery. You’d be able to find liveCDs for it…

Tried a few times to recover the partition.
Got tired and installed Debian 5.0 on this system and am restoring g my data. Debian also couldn’t access that partition.

BTW, the wiped partition was an extended one, so the disk is not bad. Debian is now using the entire disk.

At work, will continue to use 11.1 openSuSe.
Too painful to risk upgrading.

Thanks all,


This is not a finger pointing post, so please do not take it that way.

The other day, I helped a friend install Windows 7 Ultimate on his PC. He was running Windows XP. We did a full backup of his PC using Acronis True Image, so he could do a full disk restore if needed. We also just backed up his data, so that he could import it into Windows 7 when we got finished.

He installed a new hard disk. He went into XP’s Disk Management and verified that the PC could see the new drive. He wanted Windows 7 to install on the new drive and keep Windows XP on the old drive. This way, he would still have his XP while he tried out 7 to see how he liked it.

He started the install. When it got to the partitioning section, I watched over his shoulder as he told Windows 7 to install on the new drive. I verified his choices and all looked good. When the install completed, Windows 7 was up and running. We went into Disk Management and low and behold, Windows 7 had installed on the old drive and wiped out XP. :open_mouth:

Even Windows 7 can do this. It’s not a SUSE thing. Any time you are dealing with partitions, you are running a risk. Luckily we had backed up his data. Wait. I take that back. There was no luck involved. We did it the right way.

He ended up liking Windows 7 so much that he just imported his data into Windows 7 and did not restore the XP partition, but we did have the disk restore option available.

I believe in a safety net when doing installs or upgrades. We are constantly telling folks to “Back Up Your Data,” because we have seen problems like this occur too many times.

As I said in the beginning, this is not to point fingers. It is only to use this thread as an example of what can happen and why we stress the need for backups. It is too late to help you, but if it helps one other user to prevent the loss of his/her files, then it will serve its purpose. I feel bad for you, but this was preventable.

I can not stress this enough.

Please back up your files!

It still comes off sounding wrong, but there is no way to say what needed to be said and make it feel good. Sorry for that.

I am on the search for a backup and restore solution fo OpenSuSe.
I have read this thread. I am more familiar with Windows where I often use Ghost or Acronis.

Since I am new on Linux I would like to get a hint how to create an image similar than Ghost on Windows and I would also like to get a hint how to restore.

Is there anywhere a HowTo I could follow?


If you have Acronis, you can keep using it, it’s able to read and write raw image data so the file system doesn’t matter.

Yes and no. It does not like to ext4 partitions of 11.2, claiming that they are corrupt. The only option it offers is to perform a sector by sector backup - which is both time consuming, space consuming, and does not give the option for file level restoration.

If I had known this before doing a clean install of 11.2, I would have stayed with ext3, but at this point I’d hate to have to reinstall.

Than again, I also hate not having a bare metal backup/restore option either.

Any other options?

I too recently installed W7 where 2HD’s were present. Both having primary ntfs on.
I was installing to the 2nd HD (in bios settings)
I had to take the power from 1st HD, because first attempt it put the boot code on this drive. Taking the power away effectively makes HD2 HD1. So when you re-connect you have to make the switch back in BIOS. Then grub went to the non-windows HD (with the ntfs store partition on it).
It had me scratching my head for a mo:)

I had exactly the same problem (ex. I was coming from 11.1 not 11.0). When I reformatted / and reinstalled 11.1 I found that /home was intact after all, so I think that the previous comment

Do NOT format sda3 ! An error in the partition table doesn’t mean a data loss at this point. Maybe the length of the partition is just gone and the system think it has zero size.

was dead on. When I reinstalled 11.1 I discovered that all the data in /home was intact and available again.

Note: I had a host of very, very serious problems with 11.2, and I’ll be posting on those when I’m no longer on the road. For now I’ll stick with 11.1 which I love.

Too late now, but I’ve recovered disks using gpart(8) where the partition table was hosed.

I have installed 11.2 very many times, and it has always respected the partition table and left filesystems not to be touched alone, as well as creating and formatting filesystems as requested.

The fact is, you are warned to back up, before doing installation, for very reason that even 1 problematic hardware driver, can have unpredictable consequences, and if you’re unlucky cause data loss.

If you don’t wish to have a drive visible to installer, the time to power it off, is before you boot the installer, not part way through!

That’s nice. I’m happy for you, but that’s not our situation here.

I did back up my data. What makes you think I didn’t? In fact I backed it up twice to two redundant copies on two different external drives, and the original post makes it clear in #5 that he must have backed up his data too, otherwise he could not be “restoring g my data.”

If you’re referring to the backup drives, they were powered off and disconnected during the install, what made you conclude that I (we) didn’t do so?

If you’re referring to /home, I kinda wonder how one is to power off one partition while installing to another partition on the same drive. (?)

So, what’s my point here? Very simple… Can we please tone down the attitude? IMHO it’s neither helpful nor polite.

If you don’t want to do a disk or partition backup you could use dar or GuiDar to make a file backup file(s).GuiDar makes it easy to make a dar backup script that then could be run periodically.

Well done, often people skip that, and then have unpleasant surprises. I was pointing out, that your type of issue, is exactly why a backup is wise.

If you’re referring to the backup drives, they were powered off and disconnected during the install, what made you conclude that I (we) didn’t do so?

I made no conclusion, the OP mentioned turning a drive off, it’s their war story made public, don’t be surprised if ppl comment.

So, what’s my point here? Very simple… Can we please tone down the attitude? IMHO it’s neither helpful nor polite.

No attitude, it’s your imagination.

What’s wrong with reminding people that partition tables are recoverable with gpart(8), by someone who knows what they’re doing? In general it’s good practice to dump out a partition table with sfdisk(8) as a precaution to save time.

Debian’s a nice stable system, hope OP enjoys it. I think you were both unlucky with 11.2 upgrade, there were far more heated stories about around 11.1 release time.

I had this problem too - the openSUSE installer hosed my partition table and put my >400gb /home partition out of existence in a breath. I too am sure that I told the installer correctly not to touch it.

I was unable to restore the partition table with gpart and eventually did recover it with testdisk running from a live USB.
This occurred at a very stressful time for me otherwise, and while I love openSUSE I can’t afford to have my computer causing this kind of upheaval in my life. That’s why I’m running Fedora 12 now, though I still miss and love many things about SUSE.

No point in throwing blame around in either direction, but this really is not the right time to blame the user. A distro really shouldn’t do this kind of thing. Upgrade and install are the Achilles heel of openSUSE - it can be as great as it wants, but why should it be this difficult and risky getting it on the disk?

And by the way, did anyone else get that live USB creation trick with dd to work? Because I followed all those instructions to the letter and just can’t get that USB to boot.

Sorry to hear that you too had that problem with /home. I’m just curious though… why did you choose to go to another distro rather than just going back to 11.1 'til the problem gets sorted out? I loved 11.1 before 11.2 came along and wasn’t really too sad to go back to it when I couldn’t load 11.2.

At any rate I won’t be trying 11.2 again for a while. I’ve determined that the new kernel just doesn’t “play nice” with this PC. l can’t install any distro with that kernel version, and I’ve tried a few now. In fact I can’t even boot to many Live CD’s with it. Sorry I can’t provide more details folks, but the house was broken into recently while we were on the road, so I’m more concerned with those issues right now. (What kind of sick ***** even steals the toilet paper and the laundry detergent?)

I’m really sorry to hear about your burglary … that happened to me once (twice actually, in rapid succession). It’s the kind of experiience that reminds you why they say you should store backups offsite, huh?

I also had those odd kernel issues with openSUSE 11.2. And I couldn’t get the broadcom-wl wifi driver package for the kernel, so I downgraded to However, I must say that 11.2 booted really fast, and looked much cleaner than 11.1. I really enjoyed the week I spent with it and was sure it was going to be a great operating system.

But in the long run, for me, setting up an installation of linux is a time investment for the long term. I’m not a programmer, I’m a journalist, and I use my machine for production.
So I’m not the kind of guy who likes to do a fresh reinstall of my system every six months - I prefer an upgrade pathway, and hopefully successive distribution upgrades will make my system better and more stable as I work out the kinks. My Ubuntu machine has been running since Gutsy, and it’s ready for three more years.

openSUSE is far more flashy and beautiful than Fedora and boots in half the time, but Fedora is stable and reliable.
Imagine - at one point in the openSUSE 11.2 fiasco, I had upgraded to openSUSE Factory in the hopes of having a system I wouldn’t have to wipe clean again. I was adding packages from the Packman Factory repos, when they were literally pulled offline in mid-download. I remember when the same thing happened with the Community repos. And how is a user to know? The answer: subscribe to the mailing lists. That’s fine for people whose job is to make operating systems - but my job is to use them.

I love openSUSE and I will come back someday. I love it the way a teenager loves that fixer-upper old Camaro. But for now I need to be driving a german sedan with automatic transmission…