11.2 Boot Problem but not giving up

Newbie here,

Cut the windows cord 6 months ago, and was up and running 11.1 almost perfectly. The only problem was the 3D desktop wasn’t running, so I decided to upgrade to 11.2 . That appears to have been a mistake for two reasons, 1) the 3D graphics weren’t running because I was only using the motherboard for graphics and 2) the upgrade doesn’t like the onboard ATI graphics or the new ATI card that I’ve since bought.

Initially I was only getting a black screen, then after running the install repair it wouldn’t boot at all. Bought the new video card, and tried some bad advice before trying to boot and disabled the onboard video to see if it would recognize the new card, then I was flying blind with no video. After removing the boards battery and resetting the bios jumper, I was able to boot with limited sucess, and I ran the repair tool several more times but was still unable to get to a command prompt.

I’ve now done a clean install with the new video card and now I can get to a command prompt but the boot is still being interupted. With some help I’ve also been able to run Yasta from the command prompt and install the latest (last weekend) updates.

I get to runlevel 5 and it shows maximum number of X display failures reached.

I’m using an AMD Athlon 64 X2 on a Biostar TA780G motherboard. I believe the motherboard uses an ATI chip and the new video card is a Sapphire HD 2400 with an ATI chip.

Can someone let me know if I’m close and how to fix the boot problem?

Why didn’t you buy an nvidia card? Chances are, you would be running now…

Post the details of the driver you use for the ATI card, if you can.

Search the forum for instructions and descriptions of ATI cards’ drivers.

I don’t know what driver it’s trying to use. If I had enough sence to poke around in the forums before trying 11.2, I would have tried a nvidia and I wouldn’t have updated either. I read on the ATI website which video cards worked with well with the onboard card and I don’t remember seeing the opengl listing on any of the nvidia, that why I bought the Sapphire.

A few things.
I don’t see a Linux driver for your card. Graphics Drivers & Software

If we go with this page, ATI - openSUSE you should get at least 2D working.

With out knowing more about your old card, I can’t say or not if we can get 3D working.

I did manage to find this; Download Driver ATI Radeon HD 2300/HD 2350/HD 2400 Linux (free)

Please post if you need more help.

I pulled the Sapphire HD2400 card out and did a clean install of 11.2 and it working fine in 2D now. I still want to have the 3D desktop effects though. I think I’m going to pick up a different video card, nvidia this time, and see if that works.

Before I spend time configuring 11.2 with plugins and setting up evolution, will it be easier to install a new nvidia card and then do another clean install for suse to configure it properly or will it automatically detect the new hardware now?

If another install is the easiest for a newbie, should I also clean up the partitions, there seem to be some extra partitions from my previous attempts?.

You should be able to just slot the card in and away you go. Just make sure you don’t have a file /etc/X11/xorg.conf