11.2 blank screen after DVD install phase is done

Hi everyone,
have problem of black screen after DVD phase of installation is completed,
I am relatively new to Linux/openSUSE, could really use some guidance.

had openSUSE 11.1 with which never had any installation issues (desktop + laptop); wiped out the 11.1 from the laptop (HP/Compaq NW8440, ATI FireGL 5200 if I remember correctly, 1GB RAM, 80 GB HDD, Intel DualCore/CoreDuo), installed 11.2 from the bootable DVD (i586 32bit)
and after DVD (auto config) install phase was done (no errors) and laptop was expected to reboot in order to complete/finalize installation I have left the laptop alone waiting for it to reboot once countdown finished but it simply froze (no response to kbd, no HDD activity); when turned off and on it would boot, but shortly after the ‘starting HAL’ statement the screen flickered few times and eventually no HDD activity and blank screen (however not frozen, short press on power button made it shut down properly);

(wiped and) reinstalled again, this time clicked the ‘reboot’ and it seemed to go a bit further (actually rebooted and more output after the HAL statement) before it ended up in the same status.

tried with auto config (setup option) on and off, single/multiple partition(s) (reinstalling from scratch each time), always the same results.

tried to boot in ‘safe mode’ as well (i.e. after DVD install phase is done), same results.

novice, but based on prev experience (Fedora) I would guess this is a display (driver) issue ? however how to fix it ? help please ?

Place this in the grub kernel boot line vga=0xf06 at startup.

Here is the thread where I picked up this fix. 11.2 Fixes For Xpress 200 and other legacy Cards

Also you should probably run sax2 -r -m 0=radeon the instruction for doing so are in that thread as well

Best of luck

Resolved by updating the BIOS with latest firmware.