11.2 bizarre KDE window behaviour with desktop effects turned on

when using desktop effects windows seem to get stuck in mid-animation and produce ghost windows which will disappear and go back to normal if i click on a blank area of the desktop.Its not a huge problem, everything else works really well and the issue goes away when i turn the desktop effects off. was wondering if anyone else has seen this?? I am running SLI on quad nvidia gpus so maybe this is a driver issue??

Yes, this may very well be a driver issue, but before I can say anything about this, we need some more info. Please post output of commands below:

uname -a

rpm -qa | grep nvidia

ls -l /etc/X11/xorg.conf

glxinfo | grep direct

NVIDIA model

With the power you have, desktop effects should be smooth. Post output and we’ll help you to get it working

Linux linux-8yiz 2.6.31.5-0.1-desktop #1 SMP PREEMPT 2009-10-26 15:49:03 +0100 x86_64 x86_64 x86_64 GNU/Linux

no output from any of the other commands, I installed the Nvidia driver 195.30 from the shell script… no choice if you want to use the newest driver…

btw… I know Opengl is working, I was just playing Vendetta online last night and it was rendering absolutely beautifully and gears is very pretty too…

OK, then the NVIDIA driver is properly installed. No output of some commands is OK as well. Though:

glxinfo | grep direct

should output, something like this:

direct rendering: Yes
    GL_EXT_Cg_shader, GL_EXT_depth_bounds_test, GL_EXT_direct_state_access,

and, my mistake, “NVIDIA Model” is not a command.

However, we’ll get there. Did you by any chance update to KDE4 4.4 ? Even if not, you should rebuild the desktop’s appearance. Note, your application settings will be saved, no data lost, just back to a default desktop. This can be done like this:

Logout, hit Ctrl-Alt-F1
login with username and password and do:


rm ~/.kde4/share/config/plasma*

Hit Ctrl-Alt-F7, log back in, and you have the default openSUSE desktop. Now re-apply desktop effects and see if things have improved.

direct rendering: Yes
GL_EXT_Cg_shader, GL_EXT_depth_bounds_test, GL_EXT_direct_state_access,

ok, I guess it gave output that time…

Ill try to update the desktop, btw… is updating to kde 4.4 recommended?? and how much of a hassle will that be if so?

Ill try to rebuild and see what happens

Ill try to update the desktop, btw… is updating to kde 4.4 recommended?? and how much of a hassle will that be if so?

This question has been debated a lot lately - I personally am very satisfied with KDE4.4 (better performance, better window management, some cool bits’n’pieces), others are not, though. I wouldn’t consider KDE4.4 to be beta, but there might be some smaller issues which needs fixing. I also wouldn’t recommend updating if you depend on KMail. The update-process itself should be no problem.

Do you have an /etc/X11/xorg.conf? If so, please post it here, since to me the behaviour sounds as if some composite-related functions are missing.

Edit: I doubt that updating to KDE4.4 would solve your problems.

xorg.conf is as follows:

nvidia-settings: X configuration file generated by nvidia-settings

nvidia-settings: version 1.0 (buildmeister@builder58) Fri Dec 18 18:36:44 PST 2009

nvidia-xconfig: X configuration file generated by nvidia-xconfig

nvidia-xconfig: version 1.0 (buildmeister@builder58) Fri Dec 18 18:35:05 PST 2009

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0” 0 0
Screen 1 “Screen1” RightOf “Screen0”
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
Option “Xinerama” “1”
EndSection

Section “Files”
EndSection

Section “InputDevice”

# generated from default
Identifier     "Mouse0"
Driver         "mouse"
Option         "Protocol" "auto"
Option         "Device" "/dev/psaux"
Option         "Emulate3Buttons" "no"
Option         "ZAxisMapping" "4 5"

EndSection

Section “InputDevice”

# generated from default
Identifier     "Keyboard0"
Driver         "kbd"

EndSection

Section “Monitor”
Identifier “Monitor0”
VendorName “Unknown”
ModelName “ViewSonic VX2265wm”
HorizSync 65.0 - 186.0
VertRefresh 59.0 - 120.0
Option “DPMS”
EndSection

Section “Monitor”
Identifier “Monitor1”
VendorName “Unknown”
ModelName “Seiko EPSON PJ”
HorizSync 0.0 - 0.0
VertRefresh 0.0
EndSection

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “GeForce GTX 295”
BusID “PCI:11:0:0”
Screen 0
EndSection

Section “Device”
Identifier “Device1”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “GeForce GTX 295”
BusID “PCI:11:0:0”
Screen 1
EndSection

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
DefaultDepth 24
Option “SLI” “on”
Option “TwinView” “0”
Option “metamodes” “DFP-0: nvidia-auto-select +0+0; DFP-0: 1280x1024 +0+0”
SubSection “Display”
Depth 24
EndSubSection
EndSection

Section “Screen”
Identifier “Screen1”
Device “Device1”
Monitor “Monitor1”
DefaultDepth 24
Option “TwinView” “0”
Option “metamodes” “DFP-1: nvidia-auto-select +0+0”
SubSection “Display”
Depth 24
EndSubSection
EndSection

the issue started b4 i ever enabled xinerama btw…

Hm, strange the effects work at all. These commands should solve your issues:

nvidia-xconfig --composite
nvidia-xconfig --allow-glx-with-composite
nvidia-xconfig --render-accel
nvidia-xconfig --add-argb-glx-visuals -d 24
nvidia-xconfig --damage-events

…then log out, log in again and it should work.

if I do this will it break my previous xorg.conf settings??

It will enhance the xorg.conf. :o)

There’s not much risk in those commands, previous settings will not be overwritten, only new ones added. You could still do a backup by copying it before proceeding.