11.2 a slug?

At the weekend, I installed 11.2 from liveCD on a USB, a new install to a different HDD from my 11.1.
I should by now be enjoying the new candy and zippedy-doo-dah performance and showing it off to anyone who is passing. But I am not because it is so sloooooowww. I know some object to people saying that their machine is slow as it is vague and unscientific, but you know what I mean, 1 or 2 seconds delay after I click any option with the mouse, simple apps take 2 or 3 seconds to load, bouncy ball just bouncing …I tried to find out why, here are htop and sysinfo:



So My CPU is used 100% before I do anything!
I don’t yet have any wonderful widgets running, nor any intensive or demanding graphical whizz-bangery.
Some research on the interweb told me to switch off a couple of options, ( leave this space to edit, I can’t remember what they were! vsync and one other???)

I believe I have installed my Nvidia driver correctly, I do have an Nvidia settings option in the menu, but the simple “My Computer” button shows this screen:

I guess this is just a tiny bug, but I put it in in case the driver is only “half-loaded” (is that possible ?)

It is not, I suppose, tooo late to wipe it and begin again if I have done anything very stupid…

( I will edit my sig to reflect my new set-up when I get it fixed! Promise!)

One of your plasma applets is misbehaving and causing the load. Logout, login as root and remove /home/username/.kde4/share/config/plasma files (or back them up somewhere), logout and login as your normal user.

As for the Sysinfo:/ unknown that’s a “bug” in Sysinfo module itself as it cannot recognize the driver version properly, it says Unknown for all nVidia binary blobs.

I’m on it supersonic Chysantine, Thanks for your super-quick reply…
Chrys Rocks!

Hmm I did as Chryantine suggested, and sure enough, plasma-desktop is no longer the hungry hog it was and has got its snout out of the CPU trough. BUT:
xorg has taken its place, and IT is now hogging the CPU:



:frowning: :frowning:

Same deal, same location, nuke the kwin files :slight_smile:

You might want to consider upgrading to 4.3.3 via repos - it’s running really smooth for me - it includes some bugfixes, perhaps something related to your problems too.

Excellent as usual Chrys!

The results?


ie from 100% CPU Usage to 3% in two posts!

Chrysantine for European President IMHO!

Now I’m off to break it in some other way…

Oh well! On 4.3.4 now, and the same thing happening!!
ie kwin using most of my CPU, and the whole thing running like a slug.
I deleted from a root terminal kwin from .kde4/share/config/ again but it is no better this time. Any ideas anyone?


My guess is you have a misbehaving plasma applet, you should consider backing up (moving) plasma from there as well to another location - unfortunately it’s very hard to track down exactly which one it is.

TY Chrys, another day wasted setting it all up again… :frowning:

Are you using any applets that use the network or things like the weather applet? Because that thing has been sooooo unstable.

Also if you have the Community repo enabled, those plasma applets are … sometimes a little flakey.

No Chrysantine, I have NO widgetery at all, I have just put a CPU Monitor on, to errr monitor this very issue. BTW the “bubble” cpu monitor used up to 90% of the CPU when I tried that.

The 6100 series is getting a bit long in the tooth check and see if you need to use a legacy driver rather then the newest form NVIDIA.

Did you try removing the hidden .kde4 directory?
Maybe a older config file is messing things up, had that happen to me when updating from openSUSE 11.1 to 11.2

> The 6100 series is getting a bit long in the tooth check and see if you
> need to use a legacy driver rather then the newest form NVIDIA.

I have a 6800XT and lately it has been a total pig. This happened after I
went to the 190.x drivers and enabled OpenGL…which was broken in the 173.x
drivers. Now I have OpenGL, but general performance is way down, thing like
launching apps, browsing. It seems that the way the screens are being
drawn/refreshed is very poor which makes the system feel slower than it
actually is. GL performance however is stellar. LOL.

This is not a real solution, but have u thought about installing openSUSE-GNOME and forget about that KDE4 piece of **** (in my humble opinion)?

It’s possible AMAH, I might drop down to xfce, to see if that is zippy speedy, and then think about Gnome

Thanks for the suggestions folks. I will look in to my Nvidia drivers, though I am sure that my current (190.42) is recommended for GeForce 6xxx chipsets.

Could you explain? I don’t really know anything about GL and openGL and what is the difference?

> Could you explain? I don’t really know anything about GL and openGL and
> what is the difference?

I was speaking of the same thing. I just abbreviated. Sorry for the
confusion. The problem is with the latest nVidia. Whether or not it is an
nVidia issue or a KDE one we don’t really know at this point keep an eye out
for an update. If you are really interested in it you could join a KDE
mailing list and see if there is any banter about it. Sometime
conversations about issues like that go on in IRC as well. For me I’ll just
wait it out, I need openGL for gaming.

For what is worth I run a 6800 XT card. Installed the driver using the 1 click method and it works great.