11.2 => 11.3: boot errors after upgrade, but works anyway

The situation is too strange to be well summarized in a title-topic.

I have performed the upgrade from .2 to .3 editing the repos and launching zypper dup.

The boot loader’s choises are:
1)openSUSE 11.3 - 2.6.34-12 (default)
kernel image: /boot/vmlinuz-2.6.34-12-default
ram: /boot/initrd-2.6.34-12-default
root: /dev/disk/by-id/ata-Hitachi_HTS541680J9SA00_SB2204SGEZ91VE-part1
parameters: resume=/dev/disk/by-id/ata-Hitachi_HTS541680J9SA00_SB2204SGEZ91VE-part2 splash=silent quiet showopts

*)

11)Desktop – openSUSE 11.2 - 2.6.31.12-0.2
/boot/vmlinuz-2.6.31.12-0.2-default
/boot/initrd-2.6.31.12-0.2-default
/dev/disk/by-id/ata-Hitachi_HTS541680J9SA00_SB2204SGEZ91VE-part1
resume=/dev/disk/by-id/ata-Hitachi_HTS541680J9SA00_SB2204SGEZ91VE-part2 splash=silent quiet showopts

Now. Trying to boot the first conf, it returns fatal errors related to kernel; booting, instead, the eleventh conf, it’s OK.

Any ideas?

On 2010-07-31 21:06, fullvestito wrote:

> Now. Trying to boot the first conf, it returns fatal errors related to
> kernel;

Please elaborate. Post the exact messages.

> booting, instead, the eleventh conf, it’s OK.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” GM (Elessar))

Also, after you have booted into eleventh conf please post output from :

 
cat /proc/version 
mount 

I’m not sure what *ram: /boot/initrd-2.6.34-12-default *means in first conf.

Solved.

During the upgrading, due to a conflict between kernel 2.6.34-12 and wireless network card (BROADCOM 4311), some packages wasn’t downloaded.
So that, booting the “new” kernel returned fatal errors (module processor not found, module thermal, ecc); booting the “old” kernel, all was ok.
To fix the problem I have removed all broadcom drivers, downloaded all oss11.3 packages, and installed a new broadcom driver.