11.1 sound question.

Linux newb, otherwise successful install but have silly sound question. Yes, I’ve checked other threads to no avail. Still no sound…

My issue is…IN KDE 4, when I right click on the speaker Icon in the tray I get the little Kmix window…why can’t I “uncheck” the mute when the PCM is the “master channel”? When I open the mixer window ALL channels show to be off mute, but the the right click menu selection from the speaker Icon still shows “mute” checked?

Funny thing is…when I select another master channel type, the “mute checked or unchecked” from right clicking the speaker Icon, ALWAYS matches the opened Kmix window?

Ideas? Thankx.

I have the exact same problem,but when i change the master channel fro pcm to “front”,the speaker shows unmute but still no sound at all.besides when i first boot i receive this message on the top of the page that says the sound is not working because it was changed back to the default or something like that which i have absolutely no idea what it is talking about .any suggestion? thanks

I don’t use kde4, but do you get the mixer option when you right click the speaker icon?
If not, try using yast>hardware>sound to configure it.

For those with no sound at all, try working your way through the openSUSE audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE

To determine if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times.

If that does not work, please post here (stating your desktop (kde4, kde3, gnome) and openSUSE version) and there is a script and some rpm commands you could run to provide us more information on your PC setup, upon which a recommendation could be made.

Ok…upon further examination…speakers DO work but ONLY from the rear jack. Anyhoo, headphones plugged in front jack do not work, but DO work from back jack. The front jack however works fine for both speakers AND headphones but only in WIN XP. Scrathcing head now…Obviously a component of 11.1 and the front jack aren’t playing well together. What’s next?

The next thing is to learn more about your hardware, and software, so we can determine if there is a custom configuration we can apply, to tune your setup such that the sound functionality works better. So can you provide more very detailed information so a good recommendation can be given? You can do that, with your PC connected to the internet, by opening a gnome-terminal or a kde konsole and typing:/usr/sbin/alsa-info.shthat will run a diagnostic script and post the output to a web site on the internet. It will give you the URL of the web site. Please post that URL here. I need that output to understand better your PC configuration.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/soundI also need that output.

… and finally, can you advise as to what hardware you have? Motherboard or PC manufacturer/model# ?

Hopefully with that I can make a good recommendation.


No, thank you for the help!

Here’s the URL for the alsa URL info…

the grep alsa infor is as follows:

the grep pulse is as follows:

the libasound2 is…

the uname is…
Linux linux-cpi0 #1 SMP 2008-12-04 18:10:04 +0100 i686 i686 i386 GNU/Linux

and lastly, the cat /etc/modprobe.d/sound
options snd slots=snd-hda-intel

u1Nb.RulhFAaxbD2:82801G (ICH7 Family) High Definition Audio Controller

alias snd-card-0 snd-hda-intel

As for hardware…It’s a mutt. P4 3.4, 1G mem. On board sound…no idea about MOBO/chipset/etc. I suppose I could open it up if the stuff inside is labeled? It doesn’t look like rocket science. Just a few screws it looks like.

I searched the alsa web site for the stac9220 (and 9223) that the script file reports your PC has, and I saw no mention of updates to the stac9220 in a more recent alsa version (as there is an update available).

So you could try keeping your current alsa version, and modifying your /etc/modprobe.d/sound file to see if you can find an optimal configuration to improve the functionality associated with your front headphone jack.

For 1.0.18a of alsa, the ALSA-Configuration.txt file has this list of model options for the STAC9220:

	  ref		Reference board
	  3stack	D945 3stack
	  5stack	D945 5stack + SPDIF
	  intel-mac-v1	Intel Mac Type 1
	  intel-mac-v2	Intel Mac Type 2
	  intel-mac-v3	Intel Mac Type 3
	  intel-mac-v4	Intel Mac Type 4
	  intel-mac-v5	Intel Mac Type 5
	  intel-mac-auto Intel Mac (detect type according to subsystem id)
	  macmini	Intel Mac Mini (equivalent with type 3)
	  macbook	Intel Mac Book (eq. type 5)
	  macbook-pro-v1 Intel Mac Book Pro 1st generation (eq. type 3)
	  macbook-pro	Intel Mac Book Pro 2nd generation (eq. type 3)
	  imac-intel	Intel iMac (eq. type 2)
	  imac-intel-20	Intel iMac (newer version) (eq. type 3)
	  dell-d81	Dell (unknown)
	  dell-d82	Dell (unknown)
	  dell-m81	Dell (unknown)
	  dell-m82	Dell XPS M1210 

So you could try each of these model options one at a time, to see if you can find one that works, to make your front headpone functionality improve.

For example, to try the option “3stack” add a sentence to your /etc/modprobe.d/sound file such that the file now looks like:

options snd slots=snd-hda-intel
options snd-hda-intel model=3stack
# u1Nb.RulhFAaxbD2:82801G (ICH7 Family) High Definition Audio Controller
alias snd-card-0 snd-hda-intel 

then restart your alsa sound driver by typing in a kde konsole **su -c ‘rcalsasound restart’**enter root password when prompted, and restart your mixer and then test your sound functionality.

If “3stack” does not work, then replace “3stack” in your /etc/modprobe.d/sound file with “5stack” and restart your alsa sound driver, mixer, and test the sound functionality.

You can try each model option in the list to see which one provides improved behaviour (if any).

I don’t know if this is related (i’m having other issues with xulrunner) but i also have no sound. Heres my output

I’m runnnig gnome, kernel 2.6.25 opensuse 11.0 64

ALSA lib pcm.c:2162:(snd_pcm_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so
Playback open error: -2,No such file or directory

bash: /usr/sbin/alsa-info.sh: No such file or directory




Linux spirol-zgon #1 SMP 2008-10-21 16:30:26 +0200 x86_64 x86_64 x86_64 GNU/Linux

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

It might be worth mentioning:
The sound issue started happening at the time i installed Songbird (sound was ok at first). At the same time (the nex day) the packagekitd has been trying to get xulrunner 181 update (the update icon shows it’s updateing, but nothing’s happening)

after i did : su -c ‘rcalsasound restart’ it works…then what is happening? each time it starts an update it has no sound,after i restart it it works fine…???

spiro2903, I do not like supporting multiple users on the same thread. The reason being it gets very confusing for me, as in previous threads where many users jumped in looking for help, I have had to search back and forth and back and forth and back and forth and back and forth, to try and see what is the hardware/configuration for each user. Its far too difficult, and its TOTALLY UNNECESSARY when a new thread is much easier.

I eventually got too frustrated, and I now refuse to do it. This thread was started by user average_guy, and I will only help him in this thread. I will only help others with a new thread.

Maybe some one else will pitch in and help you.

Good luck.

Looks like the guys at Fedora figured this one out already, I thought it looked familiar. Alsa 1.0.18 seems to have breakage with snd_hda_intel. If you roll back to a kernel with an older ALSA release, you should be fine.


Cheers, HTH! >:)

One must be careful with generalizations like this. I have a laptop that is using the 1.0.18 version of alsa, and it uses snd_hda_intel and it has no similar problem.

Often alsa sound problems, when they occur, tend to be codec specific, and generalizations/fixes from another distro may work, but can lead to the wrong solution for other users and cause even more problems. This is especially true for different codecs and different kernel builds by different packagers.