11.1 Slow Boot Process: Unable to open '/dev/.udev/queue'

OpenSuse 11.1 is often slow to boot on my machine. The process hangs for a considerable time with the following messages:

Boot logging started on /dev/tty1(/dev/console) at Thu Apr 30 09:39:46 2009
udevadm[527]: unable to open ‘/dev/.udev/queue’: No such file or directory
udevadm[528]: unable to open ‘/dev/.udev/queue’: No such file or directory
udevadm[529]: unable to open ‘/dev/.udev/queue’: No such file or directory

It doesn’t happen every time, but it does happen more often than not. The resulting time delay means a VERY slow boot process.

I have tried creating a text file manually, but I find that after a re-boot, it has disappeared!

I would be very grateful for any advice on how to fix this.

Thanks in advance.

They’re dynamic files created on the fly.

Please copy paste the result of : rpm -q udev

Can you descsribe the computer’s hardware? Funny thing is I don’t have /dev/.udev/queue …

Thanks for your quick reply, Chrysantine.

rpm -q udev gives:

My machine is a Dell Dimension 3000 desktop. OpenSUSE 11.1 was “clean installed” and I don’t think I have done anything silly since I installed it!!

Hope this helps.

Can anyone help?

i have exactly same problem with same udev rpm package. any solutions ?

No, I’ve still have not found a solution. I must admit I’ve been concentrating on other problems, and haven’t done much on this, but it is very annoying, adding a serious delay to the boot time.

Your post reminded me, so I’ve done a bit more experimenting. I unplugged all USB devices (including the built-in hub in the Dell monitor). I didn’t get the udev failure message, but still got a similar delay and set of error messages to those which previously followed the udev errors. This would seem to indicate a deeper problem. This is what I get:

*Kernel logging (ksyslog) stopped.
Kernel log daemon terminating.

Boot logging started on /dev/tty1(/dev/console) at Thu Jul 2 17:22:49 2009

Trying manual resume from /dev/disk/by-id/ata-WDC_WD1600JB-75GVC0_WD-WCAL95118245-part5
Invoking userspace resume from /dev/disk/by-id/ata-WDC_WD1600JB-75GVC0_WD-WCAL95118245-part5
resume: libgcrypt version: 1.4.1
Trying manual resume from /dev/disk/by-id/ata-WDC_WD1600JB-75GVC0_WD-WCAL95118245-part5
Invoking in-kernel resume from /dev/disk/by-id/ata-WDC_WD1600JB-75GVC0_WD-WCAL95118245-part5
Waiting for device /dev/sda6 to appear: ok
fsck 1.41.1 (01-Sep-2008)
[/sbin/fsck.ext3 (1) – /] fsck.ext3 -a -C0 /dev/sda6
/dev/sda6: clean, 148901/1313280 files, 1074703/5242880 blocks
fsck succeeded. Mounting root device read-write.
Mounting root /dev/sda6

Boot logging started on /dev/tty1(/dev/console (deleted)) at Thu Jul 2 18:22:51 2009


Previously, this same message followed the udev error message, so I’m thinking that maybe the udev problem is a red-herring, rather than the cause of the problem.

I hope that this will now provide someone with enough information to be able to help.

Thanks in advance

Use bootchart for a few boots should help narrow it down.

Thanks FM, I’ll give it a try.

Sorry for the absence, FM.

OK - I’ve installed Bootchart, and have several impressive graphs.

Sorry to be so dense, but exactly what am I looking for in these? Nothing obvious leaps out at me!

Thanks for your patience with this “challenged” student!

It breaks it down in time a process is taking to boot, depending on how it is configured it should be logging till window manager login.

So you’re looking at the things that are taking a long time to process.

Perhaps post it up so you can get more eyes looking over it. You also have -n flag which will give you still more processes and not prune it.

So if we say the average boot time is 45 secs you should be seeing a long green bar for something, but some include sub processes so it may not necessarily be the longest. More specifically you seem to reckon it is around udev so around this you should be having a process that is taking a long time.

Here’s an example from trying to improve bootup times from wiki around 10.3 http://files.opensuse.org/opensuse/en/d/d0/021a_bootchart-upstart-openSUSE.10.3.alpha3.plus.png

Thank you again, FM.

I’ll try to compare a chart from a boot process which works OK, with one which “hangs” for a while, then report back.

At last, here are my bootcharts (I had to figure out how to attach the .png files first!).

The “good” one is here, and the one from a “hung” boot is here.

They look much the same to me, exceot for a 65 second delay in the “hung” one.

Any help would be much appreciated.

Nope out of my depth but that has put it very early on so I suspect you need to turn up udev logging. From my brief looking you have /etc/udev/udev.conf then I suspect change it to debug. The only real reference I can find is Kay Sievers what it means by syslog not to sure I suspect dmesg or one of the boot.* but far from knowing.

Though as you have a successful and not so succesful was anything changed i.e peripherals plugged in.

Thanks for your help, FM.

These two charts were successive boots of the machine, with no changes whatsoever. That’s the confusing bit - sometimes it’s OK, sometimes it isn’t. Another entry into my book of 11.1 irritants, I guess!

Like you, I’m way out of my depth here, but I refuse to give up!

Just to bring this up to date/close it off, I installed kernel 2.6.29 (to enable my TV card), and the problem seems to have gone away.

Thanks to everyone for your help