11.1 RC 1 Live CD

I just tried it out and these are my observations so far:

I could not get Amarok to pay an internet radio stream. It crashed after a while when I was trying to chose another stream.

No Gimp. It would be so nice to have Gimp on the live CD so that end users who are artists like me can try the new Gimp out too.

Konqueror: I could not get the thumbnail previews to work in tool tips as I have it set now in KDE 3.5/SuSE 10.0. My friend could not get that to work either and he has SuSE 11.1 installed on his hard drive. Everything was checked off as it was supposed to be (“Show previews in tool tips,” etc.) but it still would not work. Is this a KDE/Konqueror problem or a SuSE 11.1 problem?

The new Dolphin looks impressive. I liked its image previews.

I did not get to see if I could print anything in Open Office from the live CD (I did not have my printer turned on.) Does it detect my printers? Does it come with drivers to run a Samsung CLP-510 laser printer for instance?

I also did not try it out with my scanner. I am hoping that the live CD came with SANE.

mplayer-thumbs from the packman repo gets the thumbnail previews going. Used to be the kdemultimedia3-video-xine package I think, but that depended on some arts stuff. No more arts since KDE4 uses phonom to pump things in from pulseaudio (something like that).

If you install kde3 instead I think you can still do it the old way since I noticed that package still in the 11.1 repo.

Amarok probably crashed due to codecs missing, depending on what format was streaming. Only free codecs come on the cd media. No more non-oss stuff like mp3 playback. Even the DVD doesn’t have it anymore.

An easy fix. Either add the non-oss add-on cd if installing from the DVD, or just add the repo once installed and in Patterns choose the non-oss multimedia pattern to install. You’ll get the fluendo gstreamer mp3 plugin, the flash plugin, and some Adobe thing (gotta choose acroread yourself if you want it, but it’s there in the non-oss repo for you).

The default Amarok gets installed with the gstreamer framework using the yauap player plugin. That’ll work with the fluendo mp3 plugin, but if you want your equalizer back you can install the amarok-xine from packman and choose the xine framework (which will have pulled in the libxine1 update from packman so mp3 comes with that) in Amarok’s preferences. KDE4 might need you to switch Phonom’s preferred codec from gstreamer to xine.

Using the DVD of RC1 on VirtualBox, the default kde3 pattern brought in the sane-backends package that makes my hp scanjet 3970 work. I have no idea about Samsung printers or whether either is included on the Live cd.

Remember, this isn’t Knoppix. The Live stuff here is just to test out some of the hardware configuration and see how OpenSUSE looks and feels. If you want to actually use OpenSUSE then you’d need to install it. I recommend a DVD image so you’ll get full patterns of a default installation rather than the subset included on the Live cd. But if you insist, you can always add the oss, non-oss, updates, and packman after installation and install the Patterns later using YaST.

And if you like KDE but value stability and complete functionality, I still recommend choosing Other when asked which Desktop Environment is preferred, and selecting KDE 3.5.10. But then I’ve been a Debian guy for a while and so wouldn’t touch KDE4 except to play with it. Heh, heh, when Debian testing gets it, that’s when I would install it on other distros when I use them.

KDE3 in OpenSUSE 11.1 is nice, having backported quite a few apps from KDE4. It is the last we’ll see of it, since the future is KDE4. Kind of a chance to give a long goodbye to an old friend. For now, it is more complete and more stable than KDE4 and still runs all the latest stuff just fine.

I install the Gnome Desktop Environment Pattern as well. Even though I use KDE I do use Gnome software and compile some stuff with GTK dependencies.

opensuse-community.org will guide you through multimedia things. Don’t be disappointed based on what’s on the Live version. We always needed to add some stuff, and now in order to ship media without all those proprietary EULA’s to agree to we just need to add a bit more. It only takes a few minutes.

By the way, with the forum change I was given dahveed3, which I used with Novell and one of the forums, and Eck, which I used on the other two forums, got phased out. I’m the same guy with the long, wordy posts. :slight_smile:

I like your long wordy posts, dude, you’re very informative! I will print your reply out for future reference. :smiley:

So, Debian is kinda like the touchstone for the KDE stuff, huh? Cool. I hope that KDE 4 gets its act together and becomes as good as KDE 3.

BTW, I’m artist@noplacelikehome from the old forums.

Yeah, although many posters got to keep their forum names there are some who just got their Novell login’s, especially if they had made one from purchasing an OpenSUSE box like I did. At the time they either didn’t accept 3 letter names (Eck) or someone else had used it, I don’t remember.

I do miss some of the insane humor that would occasionally break out. MattB seemed more rambunctious back then, for example. Takes the edge off.

It’s not that Debian is any big time KDE source, although I’m sure they’ve helped contribute with their KDE team. OpenSUSE is more known for being at the top of KDE development and certainly presents one of the finest KDE desktops of all the distros.

I’m just saying that since ANY software only makes its way into Debian testing if there aren’t any new RC (release-critical) bugs, doesn’t interfere with installations of anything else in testing, and has had a period of time in unstable where users could discover problems, that’s a good benchmark for me to see when software is really ready for stable and complete use on a main system.

KDE in Debian (and most other software in Debian for that matter) is essentially as produced by upstream with the exception of whatever bugs they squash and a few hooks into the Debian distro’s system, update-alternatives, dpkg-reconfigure, package management, some wallpapers, and the like.

KDE in OpenSUSE is customized and also bug-squashed. And I must say it is customized REALLY well! And the user has the opportunity with the Build Service to experiment away with their tracking as much development as they wish. It’s a bit dangerous to track alpha development, but the choice is there with Factory. Debian’s unstable only gets released versions, but they do backport many fixes and updates, from git or whatever, and build them into the released versions whenever they feel that’s appropriate.

Like their Compiz Fusion stuff is called 0.7.6-7, but it is really filled with plugins and updates from much later versions. They just like starting out with a final upstream release as a base to work on. Same thing with testing starting out as a full copy of the stable distro. It’s much easier to fix minor bugs after upstream has completed the major work, and maybe add a few goodies from later versions if possible, than to do what, for example, Ubuntu does and start from a copy of unstable and do major reconstruction to make all the buggy stuff work properly. They get slightly newer software but take the first few months after release to really get it all working properly (if they ever really do).

I must say that for a customized and in most cases cutting edge distro, OpenSUSE does an amazing job in its final releases every 6 months of getting things stable, and if not everything initially working then fixing it all very fast with Online Updates.

But back to the topic, the Live cd is really just to see, “Hmm, do I like this YaST thing, the SUSE Kickoff KDE menu, the Gnome Slab (main menu), the divergence of Gnome stuff to mono based things like Banshee instead of the Rhythmbox suite, stuff like that?”

If so, you get the DVD and install the thing. Don’t expect to use OpenSUSE Live like a full Knoppix distribution. It’s just not built for that.

Thanks for that.
Maybe SuSE should make a Knoppix like version! That would be cool.

Isn’t there any insane humor here now? :slight_smile: I’m sure you could find some! :wink:

Well I think we discussed Tolkien (Hobbits) yesterday. Though I’m not sure that was here or elsewhere. When I jump around I sometimes get lost. :slight_smile:

I just ran the Live KDE4. It managed to lose that desktop folder somehow while I was configuring things. And once I logged out once to get Sax2 all setup properly for my videocard (which worked) I needed to run startx to get logged back in to KDE from then on. It held my settings, but I’d like to know where that desktop folder disappeared to.

I had to switch to traditional ifup/down configuration to get my ethernet card to connect.

The timezone fought with me until ntp started giving me the right time. It would apply the right time, then go back to incorrect time after a few minutes, but eventually I got it to stick properly. But KDE managed to apply the US/New York configuration of the keyboards and locale (that and YaST, I forget which combination worked), and save it between logins. All that had worked instantly, without a hitch, when I configured it on the installed OpenSUSE within VirtualBox. The Live scene is a different animal than a fully setup system.

I reached the short KDE4 guide online from the link in the OpenSUSE intro page once I got the network up. Really not much there yet. I think they’re working on that.

The stuff on the taskbar re-arranged themselves all in weird areas but I managed to figure out how to move them around. But the initial stuff added (the OpenSUSE customizations like shortcuts to the file system and Konqueror) had disappeared just like the desktop folder with its icons. They were all still on the SUSE Kickoff (KMenu) though.

Once I had the proper Monitor/driver configuration I was able to activate KDE4’s fancy desktop effects. They worked fine, and I checked out that new Compiz-like cube too. But trying to turn them off and go back to normal froze everything. I needed to reset my computer so I just took out the cd and came back to normal.

Before that, I had checked out Software Management and saw that they include the configured oss, non-oss, and update repos but they don’t have them activated by default. So if you want to try installing some stuff (you really won’t have much space to do that live, unlike Knoppix) you could probably manage some things. Maybe you could get Gimp on there if you want to check it out.

I noticed hplip (for my printer) is not installed. Since I only wanted to briefly check it out I didn’t bother activating the repos and getting it. The Gnome Live cd is probably more conducive for that since hplip brings in parts of Gnome anyway for its GTK GUI. No idea what you’d need for a Samsung printer, but you could try just using YaST-Hardware-Printers to see if it’s included (and if cups is even installed on the Live cd). I’d activate those repos first so YaST can fetch what it needs. Sometimes it’s able to go get things like cups, foomatic, etc, so you don’t need to manually install it. But not if the repos aren’t active.

Overall quite nice, though I prefer my VirtualBox full install of KDE 3.5.10 and Gnome of course, over the Live subset of things. And that’s the way I’ll install if, when I do.

It’s possible I may switch computers when the Gold is released on the 18th (it’s nearly a carbon copy of this hardware) just to check things out. No need to wipe this one which is setup quite nicely with Debian/Windows 98SE on separate hard drives and XP and 98SE on Debian within VirtualBox and VMWare. Nothing I really use Windows for these days. It’s more something to play with occasionally. My computer stuff is all done on Linux.

In the future I may go without bothering to install Windows at all on a hard drive, just virtual it in VMWare or VirtualBox.

But I’d say OpenSUSE 11.1 and even KDE4 looks nice. I had used 10.2 and 10.3 during their heydays. I skipped 11.0 except in Live and virtual, but I can see myself getting this one installed.

I don’t like how totem-plugin (on my installed version) didn’t seem able to play anything whereas the mplayer plugin worked fine. I had tried both my purchased Fluendo Multipack of Gstreamer plugins and the ffmpeg/gstreamer stuff from Packman and neither would get the plugin to play anything. Totem itself only took to the Packman stuff, not using anything from Fluendo. But I couldn’t get that plugin working even thought all of it appeared in about:plugins. I tried the usual deleting of the firefox pluginreg.dat file to no effect.

I just think totem is crippled by OpenSUSE. The totem-xine used to be needed but is no longer offered, at least in oss or packman. The Build Service may get it (as it did for 11.0 I think). But that shouldn’t be necessary. Totem and the plugin work fine with the gstreamer version on Debian as long as the codecs are installed.

QuickTime stuff wouldn’t work properly even using mplayer’s plugin. It would crash the plugin. I tried packaman’s libquicktime0, replacing libquicktime and the w32 codecs were installed along with libffmpeg0 and friends, all gstreamer and libxine1 packman versions and updates. Nothing got quicktime working through a plugin. But it was registered as I opened a mov file with totem and it played (not with fluendo, but with the usual packman stuff, fluendo never worked at all for anything.) Intentionally crippled software I think.

With the Fluendo pack, I also installed that libstdc33 (something like that) to get the libstdc5 old libraries and gst-inspect | grep flu showed all plugins registered. But totem would have none of it.

It’s not upstream as Totem and gstreamer have only gotten better and better. I think it’s OpenSUSE turning stuff off.

For the Totem issues, can you install it from source then? That might fix some issues but I don’t know. Some of my must have apps, I had to do it that way because then they worked much better. Obviously, make sure you have all the necessary devel packages installed first! :smiley: But why would they cripple Totem? That’s just plain dumb!

Too bad the SuSE live CD does not work like Puppy. With Puppy, you have an option to save your settings and installed stuff too! I’ve been playing around with it. I just have to get it to connect to the internet somehow. SuSE did all that automagically but Puppy did not do that and I found instructions on running a connection wizard for it that involves giving a user name and password (like I said, SuSE did not need to do that). So I will be trying that out soon.

As for my printer, It is a laser printer (CLP-510) and I know that a driver is available in Splix but not for Gutenprint. :frowning:

SuSE has a live DVD? Does it have more stuff?