11.1 Nvidia FX5500 Compiz Won't Run

Hi everyone,

Like everyone else I’ve encountered issues getting compiz running on a new box more than once. This time, I am a bit stumped - I just don’t see what the issue is. I would appreciate any suggestions :slight_smile:

Recently upgraded from 11.0 to 11.1 - running KDE 4.2. Installed the Nvidia driver from the one click install (which also installed Trace kernel) - I see there is a new one click specifically for the FX 5xxx series, which is what I used from: NVIDIA - openSUSE

Everything LOOKS good - but there is no compiz:

Packages installed:

Callandor:~ # rpm -qa | grep -i nvidia

  1. nvidia-settings comes up, looks fine. I see the Nvidia splash screen. Reports FX5500 and driver version 173.14.16 (I believe correct for the legacy FX 5500.)

  2. Callandor:~ # glxinfo
    name of display: :0.0
    display: :0 screen: 0
    direct rendering: Yes
    server glx vendor string: NVIDIA Corporation
    server glx version string: 1.4

    OpenGL vendor string: NVIDIA Corporation
    OpenGL renderer string: GeForce FX 5500/AGP/SSE2
    OpenGL version string: 2.1.2 NVIDIA 173.14.16

3)Ran sax2 -r -m 0=nvidia and it correctly detected card and display

  1. xorg.conf looks fine - copy at:

  2. ccsm runs fine, allows you to configure effect (none of them actually work)

  3. “Enable Desktop Effect” in Config Desktop is enabled. You can disable and enable and no errors are given. OpenGL selected in Compositing type.

  4. Tried running Compiz with alt-f2, “Compiz”

Everything looks fine to me, but there are no effects whatsoever.

I am trying to just compile the kernel module, but that too is being far more tricky than usual for some reason. It really should work with the one Yast / Nvidia package though, it has prior to 11.1

Thanks for any suggestions.


This is a howto from Nvidia showing you what you can and can’t have in your xorg.conf file. Manually Editing the Configuration File

Try removing the section under module

load "dri"

Hope this helps!

Hi there,

The modules section of my config is:

Section “Module”
Load “freetype”
Load “glx”
Load “dbe”
Load “extmod”

(no dri)

I have move a copy of my Xorg.log to here:

One thing I see, but I’m not sure if I am interpreting it correctly is:

(–) PCI:*(0@1:0:0) unknown vendor (0x10de) unknown chipset (0x0326) rev 161, Mem @ 0xe8000000/0, 0xe0000000/0, BIOS @ 0

lspci -v show this, not sure if it is the device referenced in the Xorg.log

00:01.0 PCI bridge: VIA Technologies, Inc. VT8633 [Apollo Pro266 AGP] (prog-if 00 [Normal decode])
Flags: bus master, 66MHz, medium devsel, latency 0
Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
Memory behind bridge: e8000000-e9ffffff
Prefetchable memory behind bridge: e0000000-e7ffffff
Capabilities: [80] Power Management version 2
Kernel modules: shpchp

This is a bit curious. I would appreciate any other suggestions.


Just checked my xorg log and mine also has the unknown chipset message. So I’m not sure what that’s all about.

Try enabling aiglx

In your xorg.conf file under Section “ServerLayout” add

Option "aiglx" "true"

It also doesn’t look like you ran

nvidia-xconfig --composite
nvidia-xconfig --render-accel
nvidia-xconfig --add-argb-glx-visuals -d 24

Try these, log out then log back in.

Thanks for the suggestions, I appreciate it.

My new xorg.conf is at: http://www.timelordz.com/scripts/xorg.conf.2

Still no joy though. Now in configure Desktop Effects I get the message that it can’t enable desktop effect and to check xorg.conf blah blah. (Previously it allowed me to select it but nothing happened.)

Wow - this is getting rather odd. I’ve certainly configured these legacy Nvidia drivers before and I’ve never had this much trouble.

Any other suggestion are certainly appreciated.


I feel really bad right now, since I recently figured out how to get compiz on my ATI Radeon HD 3200, but I have no idea how to fix it on nvidia. I stared at that xorg.conf file for maybe 20 minutes and nothing came to mind :frowning: I’ll try to get you some help. I personally know how frustrating this is.

Linux Guide and discussing: nvidia geforce fx5500 on opensuse 11

Here you go. Looks like this guy figured it out. Try his way, maybe it will work for you too.

Edit: One more source to look at.

This guy had Debian Etch with KDE installed on it. But I’m pretty sure this is a Linux core problem so this might help you as well.

Wootness! Etch + KDE + Xgl + Compiz + NVIDIA working! - LinuxQuestions.org

Good luck, Pete.

Hey A13kSAk3,

Thanks for you help - I appreciate it. I’ll try this tonight, thanks for the links! Good grief man - guess I’ll have to get a new card soon as I keep having trouble with it, but really - you would think it wouldn’t be this hard.

Thanks again for your help.


Mmm not sure I’ve got this card its running fine in fact my WM is compiz fusion… eats a chunk of ram but not to bad, de is a mix of stayalonetray, docks and compiz-desk-menu and emerald, cmms handles hotkeys, gmrun, xkill etc…

Can’t really comment as not on Suse but this is vanilla from upstream and don’t have any problems with compiz-fusion and this card.

From the updated xorg.conf file you posted you still need to add this under Section “Screen”

Option "RenderAccel" "True"
Option "AddARGBGLXVisuals" "True"

That is what

nvidia-xconfig --render-accel
nvidia-xconfig --add-argb-glx-visuals -d 24

should have done.

Hope this helps!