11.1 NO sound with 82801I (ICH9 Family) HD Audio Controller


I can do what I want, I can’t get any sound out of my computer with the above soundcard.

What can i do ?

You could try working your way through the openSUSE audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE

Also, please note that to determine if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times.

If you have no success with the audio troubleshooting guide, then I will need more information if I am to make a recommendation … So can you provide more very detailed information so a good recommendation can be given? You can do that, with your PC connected to the internet, by opening a gnome-terminal or a kde konsole and typing:
that will run a diagnostic script and post the output to a web site on the Internet. It will give you the URL of the web site. Please post that URL here. Just the URL. It may be that you need to run that script with root permissions. Please note that I need that output to understand better your PC’s configuration.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/soundI also need that output. Hopefully with that I can make a good recommendation

Well I don’t exactly know what i did last time. But i had it working…
I think i deleted the soundcard out of yast and reconfigured it.
It tourned out that the mixer settings where to low to hear any sound…
Why where these sliders on 0 ? Does the value 0 as default volume make any sense at all?!

However today I got a message somewhere on my screen:
“Soundcard” doesn’t work anymore i switch to “default”.
What ever default means, I don’t know… the PC-Speaker maybe or
my mice starts beeping now I don’t know…
I tried the same thing again but this time i still got no sound!

I’m tierd of executing your commands and stuff… You (the guys who are guilty for this) have to fix that without my help!
I mean it’s a silly simple cheap Intel soundcard. And I don’t want much, 5.1 Sourround sound
or digital outputs and what ever no, all i want is simple Stereo Sound
for some small blingblings.

We got SuSE 11.1. And we got troubles with soundcards!

You? You? Who do you mean by you?

I suspect you do not realize that we are volunteers on this forum. We contribute our own free time to help other users like ourselves, and users like you. We are not developers. We get paid nothing for our efforts.

How are we, who are trying to help you, guilty?

Guilty of wasting our time with those who accuse us, when all we are doing is volunteering to help? Yes, we are guilty of that.

We try help best we can. But with no information, as volunteers and given that we do not know your hardware, its impossible to help you.

Good luck with your efforts.

Sorry I had the naive thought that this Forum would be visited by the developers. I’m afraid they don’t.

Maybe without you volunteers there would be more effort to improve this OS. 'caus the poeple are unable or unwilling to use it since it doesn’t work.

“hda-intel” driver?

Yes snd_hda_intel

Same here. It seems that opensuse 11.1 cannot support ICH9 Family chipset. (k)ubuntu works out of box I described in here. But opensuse doesn’t.

I guess THIS PROBLEM DEPENDS ON USERS! But I’m not smart enough to solve this problem. The best choice is ‘time’. Wait until opensuse 11.2 :’(

Check if this can help “http://en.opensuse.org/SDB:AudioTroubleshooting#Installing_alsa-firmware_on_openSUSE-10.3_to_11.1”. I had the same problem of not getting any sound. And whenever I started my system I got the message “going to default” or something… I just execute “alsaconf” as root and sound starts coming out of my system. Give it a try and see if that can help. :slight_smile:

oldcpu, it was reading your comments in different threads that I was able to solve my sound problem. Thank you for that :slight_smile:

Thanks vendetta18. Trying to help users get their sound working in openSUSE, is the major way in which I try to give back what I can, to the open source free software movement. I have also tried to help Fedora and Ubuntu (and derivative) users whose sound does not work, but openSUSE is mostly my focus.

As you know, I’m not a developer, just a regular user, contributing best I can.

I don’t think so.

Over the past 7 to 8 years, I’ve watched users on the Fedora forum, on the Ubuntu forum, and some generic Linux forums (and many other distributions) , simply leave their distribution because the sound did not “just work” for them. I’ve also seen the same on the SuSE/openSUSE forums. I’ve also read a number of the bug reports for openSUSE and other distributions and read post of frustrated users who state they will leave Linux because their sound just does not work.

Their typically flaming departure has not changed this. The reason being this is NOT an easy problem to solve. There is far too much different sound hardware, with far too limited manufacturer support. So the community is forced to hack at this as best they can.

The efforts to help, from users like myself, trying to help does not change the situation. We are too small in the over all scheme of things to influence the manufacturers approach. We are also too small to influence the developers approach. And if one reads the bug reports, one WILL see that the developers pretty much ask the same questions (that I asked above), albeit they often come to the crux of the problem a bit quicker.

What we do do, is try hard to give the users whose sound does not work another alternative. Yes, the alternative is not easy for a new user to follow, but its the best I can do. You are free to ignore it, which is the beauty of Linux, as one always has the freedom.

Again, good luck in getting your sound to function in what ever approach you take.

alsaconf worked like a charm. Thanks for an easy fix.