11.1 No mount USB drive (auto or manual) / No internet /

Install platform is IBM ThinkPad T40 2373 fresh install, installed three times. Same issue. Not hardware as work fine on MS Windows side and worked with w/ Xandros 3.0.2 OCE (although internet was spotty) Had internet working on the first install, but then Poof not working. USB problem persists, tried all sorts of solutions, none of them work.

2 problems:

Cannot mount external USB flash drives. dmesg reports a scsi device, identify as sdb : sdb1 automount fails, turned on automount with Yast2, turned off java.bnfmt_misc (per another thread), tried to manually mount at any mount point (created /mnt/cf) and mount /dev/sdb1 /mnt/cf returns special device /dev/sdb1 does not exist. I tried on previous install to MAKEDEV sdb which didn’t help either. The device I’m using is actually a Compact Flash card in a reader, but it has never presented a problem on other machine also similar T40 with Xandros 3.0.2, MS XP or ThinkPad 350X with Xandros 3.0.2.

A USB CD drive was also not recognized, but also seen in dmesg.

Internet not working either. Driver recognizes CISCO Airnet hardware.
IWCONFIG reports network
IFCONFIG identify eth1 by MAC address
dhclient fails to get ip address

Thank you.

I can’t help with the USB stuff, not enough knowledge.

Re the internet: try configuring the network interface.