11.1 no microphone input with HD controller ICH10

I got a dell optiplex 760 and with some efforts I have my system running now. I am having sound with the HD controller but my microphone is not working. I am not sure what you would need but I am giving the contents of my etc/modprobe.d/sound file:

options snd slots=snd-hda-intel

u1Nb.KWDE54XGfM6:82801JD/DO (ICH10 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

thanks

Thanks. Thats a start.

Microphone problems can be difficult. I find the Linux implementations for using one’s Mic is not as user friendly as some other OS … still, … in many cases it can be made to work.

What is your criteria for deciding your mic does not work? Typically, I use arecord as a basic test of my mic. To use arecord, try to record from a simple terminal command as such:arecord -d 10 myrecording.wavand then play back “myrecording.wav” with a nominal player. The “-d 10” specifies a 10 second recording.

I also know nothing about the dell optiplex 760, and I was hoping I did not have to research it. … Is this your internal mic (if the dell optiplex 760 has such a beast) or is it an external mic? Is it an external USB mic? or one that plugs into a jack for the mic on the PC?

Can you provide more very detailed information on your dell optiplex 760 so a good recommendation can be given? Set up your mixer the way you think it should be set up for your mic to work. Then with openSUSE-11.1, you can do that, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and typing “su” (no quotes - enter root password) and then and typing and executing twice :
/usr/sbin/alsa-info.shthe first time it will ask to update. Select YES for the update. The second time that will run a diagnostic script and post the output to a web site on the Internet. It will give you the URL of the web site. Please post that URL here. JUST the URL.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -aGood luck with your efforts.

Thanks a lot,
I used both arecord and kderecord to test my microphone and I cannot hear anything afterwords (I did check that my speakers are working with some other audio).

Dell optiplex is a workstation pc. it has microphone and headphone jacks at the back as well as front… and I checked both…

done…
http://www.alsa-project.org/db/?f=5b2f2152aebc947e0cb4c6b796dfb5071c1aab55

done and here is the output

rpm -qa | grep alsa
alsa-plugins-pulse-1.0.18-6.13
alsa-devel-1.0.18-8.9
alsa-oss-1.0.17-1.43
alsa-oss-32bit-1.0.17-1.37
alsa-1.0.18-8.9
alsa-plugins-1.0.18-6.13
tsalsa-20080914-0.pm.1
alsa-firmware-1.0.19-4.1
alsa-utils-1.0.19-5.1
alsa-tools-1.0.19-4.3

rpm -qa | grep pulse
libpulse0-0.9.12-9.5
alsa-plugins-pulse-1.0.18-6.13
libpulse-browse0-0.9.12-9.5
pulseaudio-utils-0.9.12-9.5
pulseaudio-module-x11-0.9.12-9.5
pulseaudio-module-lirc-0.9.12-9.5
pulseaudio-esound-compat-0.9.12-9.5
libpulse-mainloop-glib0-0.9.12-9.5
pulseaudio-0.9.12-9.5
pulseaudio-module-zeroconf-0.9.12-9.5
libxine1-pulse-1.1.15-23.3.3
pulseaudio-module-jack-0.9.12-9.5
libpulsecore4-0.9.12-9.5
pulseaudio-module-bluetooth-0.9.12-9.5

rpm -q libasound2
libasound2-1.0.18-8.9

uname -a
Linux vmve37 2.6.27.21-0.1-default #1 SMP 2009-03-31 14:50:44 +0200 x86_64 x86_64 x86_64 GNU/Linux

What shall I try now?

OK, and AD1984A is your PC’s hardware audio codec. It is possible to force the model configuration for that upon booting (in case the alsa auto probe did not work) but first, before that, there are some things I do not understand about your configuration.

openSUSE-11.1 comes with a mix of 1.0.17 and 1.0.18 rpms. Yet you have some 1.0.19 rpms. Where did you get those from? They could be your problem … and it could also be something else.

Your mixer setup puzzles me. You were trying to record? Right ?

Recall I asked you to setup your mixer the way you expected it should be setup, BEFORE you ran the diagnostic script. So I assume you did what I asked. But when I check your mixer, it is setup to ensure the mic does not work (at least that is how I read it). Please look at the settings as noted by the script:

!!-------Mixer controls for card 0 [Intel]

Card hw:0 ‘Intel’/‘HDA Intel at 0xfebdc000 irq 16’
Mixer name : ‘Analog Devices AD1984A’
Components : ‘HDA:11d4194a’
Simple mixer control ‘Master’,0
Front Left: Playback 21 68%] -15.00dB] [on]
Front Right: Playback 21 68%] -15.00dB] [on]
Simple mixer control ‘PCM’,0
Front Left: Playback 12 39%] -16.50dB] [on]
Front Right: Playback 12 39%] -16.50dB] [on]
Simple mixer control ‘Front Mic’,0
Capabilities: pvolume pswitch
Front Left: Playback 0 0%] -34.50dB] off]
Front Right: Playback 0 0%] -34.50dB] off]
Simple mixer control ‘Front Mic Boost’,0
Capabilities: volume
Front Left: 0 0%]
Front Right: 0 0%]
Simple mixer control ‘Line Boost’,0
Front Left: 0 0%]
Front Right: 0 0%]
Simple mixer control ‘Mic’,0
Capabilities: pvolume pswitch
Front Left: Playback 0 0%] -34.50dB] off]
Front Right: Playback 0 0%] -34.50dB] off]
Simple mixer control ‘Mic Boost’,0
Capabilities: volume
Front Left: 0 0%]
Front Right: 0 0%]
Simple mixer control ‘Capture’,0
Capabilities: cvolume cswitch
Front Left: Capture 0 0%] -58.50dB] off]
Front Right: Capture 0 0%] -58.50dB] off]
Simple mixer control ‘Capture’,1
Capabilities: cvolume cswitch
Front Left: Capture 0 0%] -58.50dB] off]
Front Right: Capture 0 0%] -58.50dB] off]
Simple mixer control ‘Input Source’,0
Capabilities: cenum
Items: ‘Front Mic’ ‘Mic’ ‘Line’ ‘CD’ ‘Mix’
Item0: 'Front Mic’
Simple mixer control ‘Input Source’,1
Capabilities: cenum
Items: ‘Front Mic’ ‘Mic’ ‘Line’ ‘CD’ ‘Mix’
Item0: **‘Front Mic’**Your PC’s master/PCM volume are both low. If your trying to pick up a weak mic signal. I assume you tried higher settings? Because those won’t pick up much.

I note you have your PC’s Selected ‘FRONT MIC’, yet you have ‘FRONT MIC’ off and at 0% capture. 0% capture means NO capture. (ie no mic functionality) OFF means your mic is OFF. Your PC has 0% boost set. 0% means boost will be difficult to get your mic to function. You have 0% capture elsewhere. That pretty much guarantee’s your PC’s mic will not work.

So while you may have other problems on your PC, the bad mixer settings effectively mask the ability to find the other problems.

Please, can you take a GOOD LOOK at your mixer settings?

Hello,
Thanks a lot… playing with the mixer helped me with the microphone… thanks a lot

Super! Glad to read it helped.

Help, please!! I don’t know why, but I can’t record anything with my mic. Everything seems to be OK, I use mixer, mute/unmute microphone, I can hear echo from microphone, but nothing is recorded. AMD 790FX/SB600 board, 11.1 64-bit. What should I do?

You could provide more information? What desktop? (KDE4 ? KDE3 ? Gnome? XFce? ) What mixer ? Kmix? Alsamixer? Internal integrated mic? External mic? USB mic?

When testing your mic, follow the guidance here:
Microphone - openSUSE
in particular use this command for testing:

arecord -vv -fdat foo.wav

Also provide some more information on PC, by running script with PC connected to the internet:

/usr/sbin/alsa-info.sh

Run it as root the first time, and say yes to updating. Then run it again a second time as a regular user, and say yes to sharing/uploading the information to the web. When the script is complete it will give you a URL with the diagnostic information. Please post the URL here. Just the URL.

Also provide the output of running:

rpm -qa '*alsa*'
rpm -qa '*pulse*'
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

Desktop is KDE 4.1.3, mixer kmix (also tried qamix), labtec headset connected to the rear audio connectors.

alsa-plugins-pulse-1.0.18-6.13
alsa-1.0.18-8.12.1
alsa-oss-1.0.17-1.43
alsa-oss-32bit-1.0.17-1.37
alsa-utils-1.0.18-6.4
alsa-plugins-1.0.18-6.13

alsa-plugins-pulse-1.0.18-6.13
libpulse-browse0-0.9.14-2.2.1
pulseaudio-module-jack-0.9.14-2.2.1
libxine1-pulse-1.1.15-23.3.3
pulseaudio-module-lirc-0.9.14-2.2.1
pulseaudio-module-x11-0.9.14-2.2.1
vlc-aout-pulse-1.0.1-1.3
pulseaudio-module-bluetooth-0.9.14-2.2.1
pulseaudio-lang-0.9.14-2.2.1
libpulse0-0.9.14-2.2.1
pulseaudio-utils-0.9.14-2.2.1
pulseaudio-module-zeroconf-0.9.14-2.2.1
libpulse-mainloop-glib0-0.9.14-2.2.1
pulseaudio-0.9.14-2.2.1
pulseaudio-esound-compat-0.9.14-2.2.1

libasound2-1.0.18-8.12.1

Linux linux-3w9c 2.6.27.29-0.1-default #1 SMP 2009-08-15 17:53:59 +0200 x86_64 x86_64 x86_64 GNU/Linux

options snd slots=snd-hda-intel

5Dex.8qRx2YE_Lv8:SBx00 Azalia (Intel HDA)

alias snd-card-0 snd-hda-intel

Thank you for help!!!

Alsa info is here:

http://www.alsa-project.org/db/?f=dda182321e1eaa5a76056411e0de634451d892a2

Ok, a 64-bit openSUSE-11.1 with the 2.6.27.29 kernel and an AD1988B hardware audio codec.

I note this in your mixer settings:

!!Amixer output
!!-------------
!!-------Mixer controls for card 0 [SB]
Card hw:0 ‘SB’/‘HDA ATI SB at 0xfe6f4000 irq 16’
Mixer name : ‘Analog Devices AD1988B’
Simple mixer control ‘Front Mic’,0
Front Left: Playback 31 [100%] [12.00dB] [off]
Front Right: Playback 31 [100%] [12.00dB] [off]
Simple mixer control ‘Front Mic Boost’,0
Front Left: 0 [0%]
Front Right: 0 [0%]
Simple mixer control ‘Mic’,0
Front Left: Playback 31 [100%] [12.00dB] [off]
Front Right: Playback 31 [100%] [12.00dB] [off]
Simple mixer control ‘Mic Boost’,0
Front Left: 1 [33%]
Front Right: 1 [33%]
Simple mixer control ‘Capture’,0
Front Left: Capture 42 [78%] [4.50dB] [on]
Front Right: Capture 42 [78%] [4.50dB] [on]
Simple mixer control ‘Capture’,1
Front Left: Capture 39 [72%] [0.00dB] [off]
Front Right: Capture 39 [72%] [0.00dB] [off]
Simple mixer control ‘Capture’,2
Front Left: Capture 39 [72%] [0.00dB] [off]
Front Right: Capture 39 [72%] [0.00dB] [off]
Simple mixer control ‘Input Source’,0
Items: ‘Mic’ ‘Front Mic’ ‘Line’ ‘Front Line’ ‘CD’ ‘Aux’ ‘Mix’
Item0: 'Mic’
Simple mixer control ‘Input Source’,1
Items: ‘Mic’ ‘Front Mic’ ‘Line’ ‘Front Line’ ‘CD’ ‘Aux’ ‘Mix’
Item0: 'Mic’
Simple mixer control ‘Input Source’,2
Items: ‘Mic’ ‘Front Mic’ ‘Line’ ‘Front Line’ ‘CD’ ‘Aux’ ‘Mix’
Item0: 'Mic’
I note you have Front Mic muted (off) and its boost at 0. That should be ok, IF the mixer is mapped correctly. But you have the mixer mic-0 OFF, and its boost only at 33%. And you have capture-1 and capture-2 muted. Until you establish of capture 0, 1, or 2 is controller for you mic, it may be prudent NOT to mute those. Once you get the mic working, then you can selective mute the ones that do not matter via trial and error.

I did a search for the AD1988B on the alsa web site, and I did not find any new updates: Search results - AlsaProject

If looking at the mixer aspects I suggested does not work, you could try to force the alsa configuration upon boot to a specific model. Below is a list of the model options for the AD1988B:

	AD1988/AD1988B/AD1989A/AD1989B
	  6stack	6-jack
	  6stack-dig	ditto with SPDIF
	  3stack	3-jack
	  3stack-dig	ditto with SPDIF
	  laptop	3-jack with hp-jack automute
	  laptop-dig	ditto with SPDIF
	  auto		auto-config reading BIOS (default)

One can apply those settings, ONE at a time, to the /etc/modprobe.d/sound file. Example syntax, for example option “laptop” from that list, the edit to the /etc/modprobe.d/sound file would be:

options snd-hda-intel model=6stack
options snd slots=snd-hda-intel
# 5Dex.8qRx2YE_Lv8:SBx00 Azalia (Intel HDA)
alias snd-card-0 snd-hda-intel

then restart alsa with su -c ‘rcalsasound restart’ and enter root password when prompted and restart one’s PC’s mixer and then test. Test thoroughly. Take a look if your mixer settings are worse or better. Some of these options may break one’s sound. If “laptop” does not work, pick another item from list such as “3stack” and replace “laptop” in the /etc/modprobe.d/sound file with “3stack”, restart alsa, restart mixer, and test. Try each of those options, one at a time.

I have feeling that something stupid is hapenning, but I still can not get the mic to work. When I try to select any option (model=6stack, for example), after rcalsasound restart I get the following message:
Shutting down sound driver done
Starting sound driver: hda-intelWARNING: Error inserting snd (/lib/modules/2.6.27.29-0.1-default/kernel/sound/core/snd.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_hwdep (/lib/modules/2.6.27.29-0.1-default/kernel/sound/core/snd-hwdep.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_timer (/lib/modules/2.6.27.29-0.1-default/kernel/sound/core/snd-timer.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_pcm (/lib/modules/2.6.27.29-0.1-default/kernel/sound/core/snd-pcm.ko): Unknown symbol in module, or unknown parameter (see dmesg)
FATAL: Error inserting snd_hda_intel (/lib/modules/2.6.27.29-0.1-default/kernel/sound/pci/hda/snd-hda-intel.ko): Unknown symbol in module, or unknown parameter (see dmesg)
failed

When I remove model option, sound works, but no microphone. One thing that confuses me all the time is that mic responds to Kmix very well: I can hear mic echo, (un)mute, increase boost, everything works, but nothing can be recorded with arecord or Krecord :frowning:

No, that is expected for many of the options. Try each option. One or more of them will work better.

That could be your mixer. I gave you some suggestions as to what you need to look at on your mixer. Thats all I can do there.

Its also possible an update to alsa 1.0.21 is necessary, and I can help give you the zypper commands for that if need be, but first try EVERY option that are in the list I provided.

I am happy to say it works now! Problem was with connectors mapping, when I plug in mic in rear connector, it requires ‘front mic’ to be selected and boosted. It doesn’t matter if the mute is selected (I keep it muted to avoid echo). Skype now works well :slight_smile:

Thank you very much for help!!!

Glad to read it works.

If I may offer a suggestion, take a screen shot of your working mixer configuration, and place it somewhere easy to find. I do this for my wife’s openSUSE (I keep it on her desktop). Without that, she forgets the mixer settings and rants at me about Linux poor functionality, when in fact it is her misconfiguring the mixer, and forgetting the functional settings.

Here is my mixer conf.:

http://i.imagehost.org/0928/kmix.jpg

Great ! So keep that on your desktop or somewhere on your PC, so you can use it as a reference/baseline, next time your mic ‘acts up’. :slight_smile: