11.1 Net Install fails during package install - MD5 sum

I’m trying to perform a net install of 11.1 and ran in to a problem with package install. Any ideas?

I’ve run the install twice, the first time failing on on a glibc package. I repeated the install and it made it 82% through the package install.

The error gives the package name (yast2-network this time) saying it failed. The expanded detail shows a Subprocess failed Error: RPM failed: error: unpacking of archive failed on file /usr/share/… : cpio: MD5 sum mismatch

Network error? repo error? or hardware problem?

Thanks in advance!

I ignored that problem, since I figured I could install yast2-network later (possibly…)

However, I see another error later during the Automatic Configuration portion.

The dialog says “Error”

with the following content:

Download failed:
Download (curl) error for ‘http://download.opensuse.org/distribution/11.1/repo/oss/content
Error code: Connection failed
Error message: Couldn’t resolve host ‘download.opensuse.org

Following that, I did a retry which failed, then clicked ‘Skip Autorefresh’

The install continued from there.

When I was trying the install, I got numerous errors of different types. Then I tried a different mirror and got much better results and no errors.

During the Installation Menu on the boot cd, I think its F4 to change installation types (look at the bottom of the screen for HTTP). Select HTTP again.

It will give you two entries to change.

Change the server to one of the mirrors. I did the following:

Site: suse.mirrors.tds.net
Dir: pub/opensuse/distribution/11.1/repo/oss/

I hope this helps. It doesn’t seem to be a problem with the install method, just the site where the packages are from.

Good luck,


Great, thanks!

I wondered about that. The download.opensuse.org is a mirror re-direct link, isn’t it? I’ll try a direct mirror.

My last install failed, even though I thought I might be able to work through it.

“Calling the Yast module 'inst_user has failed”
It then recommends filing a bug, and reviewing the yast log info at

Clicking ‘Next’ allowed login as root, but did not create any other users, and it looks like package install is broken ( I presume because yast_network is missing and I have no network config.)

I did notice a minor difference in the install program from tds.net vs. download.opensuse.org. I’ve been trying to setup users in my 11.1 install from a prior version of suse install on the same system. The install program had an option to import them on the version from the download link, but the one from tds.net did not have the option. :’(

It just sounds like you are having failures while downloading the packages. Is your internet connection stable? If not you might need to download the live CD or DVD to do your installation that way.

I considered this, but it’s a very good internet connection that I don’t see any other problems with. Changing to tds.net allowed me to do a full network install, so it seems to me it’s a problem with some of the mirrors or the download.opensuse.org redirector.

I’ve had a good install now, based on using tds.net mirror. Also, it seems the distro changed a little, or the auto detection changed, as neither the download.opensuse.org or tds.net installs shows me the ‘migrate user accounts’ option when I repeated the install yesterday (see my comments in post 5.)

Thanks Noisome, you where right on about the repo problems. :slight_smile:

this thread helped me too…having the same problem and kept saying retry on the package

put in the mirror above and worked great

thank you