11.1 KDE 4.1 with Nvidia

Hello,

I’m facing some problems when trying to activate Desktop effects. All is greyed out and the message:

Compositing wird auf Ihrem System leider nicht unterstützt
Required X extensions (XComposite and XDamage) are not available.

After googling some thing I found to add some options like this to each screen:


    Option         "AllowGLXWithComposite" "True"
    Option         "RenderAccel" "True"
    Option         "AddARGBGLXVisuals" "True"
    Option         "DamageEvents" "True"

But when I do so, the XWindow session won’t came up. If I remove AddARGBGLXVisuals it will start, but the extensions are still not working.

Current Kernel: 2.6.27.21-0.1-pae
Current Driver: NVIDIA graphics driver for GeForce4 GPUs 96.43.11-1.1
CPU: AMD Athlon™ XP 2500+

xorg.conf:


Section "Files"                                              
  FontPath     "/usr/share/fonts/misc:unscaled"              
  FontPath     "/usr/share/fonts/local"                      
  FontPath     "/usr/share/fonts/75dpi:unscaled"             
  FontPath     "/usr/share/fonts/100dpi:unscaled"            
  FontPath     "/usr/share/fonts/Type1"                      
  FontPath     "/usr/share/fonts/URW"                        
  FontPath     "/usr/share/fonts/Speedo"                     
  FontPath     "/usr/share/fonts/PEX"                        
  FontPath     "/usr/share/fonts/cyrillic"                   
  FontPath     "/usr/share/fonts/latin2/misc:unscaled"       
  FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"      
  FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"     
  FontPath     "/usr/share/fonts/latin2/Type1"               
  FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"      
  FontPath     "/usr/share/fonts/baekmuk:unscaled"           
  FontPath     "/usr/share/fonts/japanese:unscaled"          
  FontPath     "/usr/share/fonts/kwintv"                     
  FontPath     "/usr/share/fonts/truetype"                   
  FontPath     "/usr/share/fonts/uni:unscaled"               
  FontPath     "/usr/share/fonts/CID"                        
  FontPath     "/usr/share/fonts/ucs/misc:unscaled"          
  FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"         
  FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"        
  FontPath     "/usr/share/fonts/hellas/misc:unscaled"       
  FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"      
  FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"     
  FontPath     "/usr/share/fonts/hellas/Type1"               
  FontPath     "/usr/share/fonts/misc/sgi:unscaled"          
  FontPath     "/usr/share/fonts/xtest"                      
  FontPath     "/opt/kde3/share/fonts"                       
  InputDevices "/dev/gpmdata"                                
  InputDevices "/dev/input/mice"                             
EndSection                                                   

Section "InputDevice"
  Driver       "kbd" 
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "de"     
  Option       "XkbModel" "microsoftpro"
  Option       "XkbRules" "xfree86"     
  Option       "XkbVariant" "nodeadkeys"
EndSection                              


Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "5"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "ImPS/2 Generic Wheel Mouse"
  Option       "Protocol" "explorerps/2"          
  Option       "Vendor" "Sysp"                    
  Option       "ZAxisMapping" "4 5"               
EndSection                                        


# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder57)  Sat Jan 24 20:05:32 PST 2009

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    InputDevice    "Keyboard[0]" "CoreKeyboard"
    InputDevice    "Mouse[1]" "CorePointer"    
EndSection                                     


Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1" 
    Load           "freetype"
    Load           "glx"     
EndSection                   

Section "ServerFlags"
    Option         "Xinerama" "1"
EndSection                       

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"                         
    VendorName     "Unknown"                          
    ModelName      "BenQ FP 767"                      
    HorizSync       31.0 - 81.0                       
    VertRefresh     56.0 - 75.0                       
EndSection                                            

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor1"                         
    VendorName     "Unknown"                          
    ModelName      "BenQ FP 767"                      
    HorizSync       31.0 - 81.0
    VertRefresh     56.0 - 75.0
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce4 Ti 4200 with AGP8X"
    BusID          "PCI:2:0:0"
    Screen          0
EndSection

Section "Device"
    Identifier     "Videocard1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce4 Ti 4200 with AGP8X"
    BusID          "PCI:2:0:0"
    Screen          1
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "metamodes" "CRT-0: 1280x1024 +0+0; CRT-0: 1280x960 +0+0; CRT-0: 1152x864 +0+0; CRT-0: 1024x768 +0+0; CRT-0: 800x600 +0+0; CRT-0: 640x480 +0+0"
    Option         "AllowGLXWithComposite" "True"
    Option         "RenderAccel" "True"
#    Option         "AddARGBGLXVisuals" "True"
    Option         "DamageEvents" "True"
    SubSection     "Display"
        Depth       24
        Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Videocard1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "metamodes" "CRT-1: 1280x1024 +0+0"
    Option         "AllowGLXWithComposite" "True"
    Option         "RenderAccel" "True"
#    Option         "AddARGBGLXVisuals" "True"
    Option         "DamageEvents" "True"
    SubSection     "Display"
        Depth       24
        Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Enable"
EndSection

Your xorg.conf is corrupted by double entries: you have the same videocard 2 times configured on the same BusID. Also NVidia states on their forum that most of the extra lines are not necessary.
Do this:

  • Logout
  • Hit Ctrl-Alt-F1
  • log in as root
  • type: init 3
  • type: sax2 -r -m0=nvidia
  • Click Change Configuration
  • Click Card Options and tick RenderAccel (and NoLogo if you don’t want the Logo)
  • Check Monitor resolution,
  • Save and exit
  • type: init 5
    Should be OK by now,