11.1 IBM Thinkpad T20 disc access failure [SOLVED]

I upgraded my 10.3 into 11.1. The machine is a rather old (but working) IBM Thinkpad and has seen a number of SuSEs on it.

Install went fine, but after 1st reboot it gave me something like this:

pata_isapnp 00:11: disabled
pata_isapnp: probe of 00:11 failed with error -16
pata_isapnp: probe of 00:12 failed with error -16
ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata1.00: cmd c8/00:08:c8:f5:0f/00:00:00:00:00/e0 tag 0 dma 4096 in
         res 40/00:00:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
ata1.00: status { DRDY }
ata1: EH complete
sd 0:0:0:0: timing out command, waited 180s
sd 0:0:0:0: [sda] Result: hostbyte=DID_OK driverbyte=DRIVER_OK,SUGGEST_OK
end request: I/O error, dev sda, sector 1045960

It pretty much hang there.

Every assessment I could find with similar symptoms stated that the disc is bad. Since I took backups from my old 10.3 I knew for sure that the hardware was not faulty.

It does not take a genius to deduce that this machine does not have an ISAPNP PATA-connector. Since the problem starts after attempting to load that module, it would be nice not to do that.


blacklist pata_isapnp

into /etc/modprobe.d/blacklist does help. Now the 1st boot phase succeeds. Problem solved!

Jari Turkia