11.1 hangs during shutdown

the (almost) last message I see is

"shutting down (remotefs) network interface

If I then press Ctrl-Alt-Del the system goes on until:

shutting down (localfs)
network interface: eth0

… and that’s it - no further go on possible,
by any means.

No complete shutdown possible.

Until present I did at least get no
journal replay at the next startup.

But should I consider such a system reliable??

OK,

until present no journal replay by ext3 at reboot.

Seems that despite this evth. works smooth.

Meanwhile I discovered that this error occurs only,
if I’ve been online.

I connect by modem, using Kinternet.

Probably this isn’t the usual way go online.

If you’ve been online or if you haven’t disconnected when restarting/shutting down?

OK,

I’m probably from the stone age.

I’m still connecting by means of a modem.

Despite of that I have an ethernet card plugged in,
which however isn’t connected to anything.

Under OpenSUSE 10.2 this didn’t lead to any problems.

Under OpenSUSE 11.1, even the rescue systems hangs,
probably because of that (as far as I can guess, at least).

This is my current state of knowledge after some
crashes …

Is there any setup I could perform (perhaps using Yast
or another toot, as well command line) to keep Linux
from searching the network that isn’t present?

Thank you

Mike

i.e. the rescue system to be booted from
the OpenSUSE 11.1 DVD.

Before that reboot (i.e. during the
preceding shutdown) every connection
(modem or otherwise) is disconnected.

The shutdown problem did not occur only
after sessions, during which I didn’t
went online at all.

I never did shut down still being online.

Mike

Check two things:

(1) Enter the command ‘dmesg’ and check for any kernel oops messages. Report the
details if found.

(2) If you do not see any of the above, then start the shutdown. As soon as the
splash screen shows, hit the ESC key and watch the shutdown messages. Report the
last 5 or 6 before the hang.

Larry

check which process is running while you are trying to shut down the pc. Reinstall that program might help.

Hi Larry,

I have to admit that I’m not an experienced
Linux user.

Honestly I don’t know what kernel oops are.
Probably you mean error/warning messages.

For about half an hour I scanned through the vast
output of dmesg to find such.

Here are the lines that I remarked:


Local APIC disabled by BIOS – you can enable it with “lapic”

ACPI: setting ELCR to 0200 (from 0e20)
evxfevnt-0091 [00] enable : Transition to ACPI mode successful
weird, boot CPU (#0) not listedby the BIOS.

  • Found PM-Timer Bug on the chipset. Due to workarounds for a bug,
  • this clock source is slow. Consider trying other clock sources

Marking TSC unstable due to TSC halts in idle

parport_pc 00:0a: reported by Plug and Play ACPI
parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE,EPP]
request region #1
isp1760: probe of 0000:00:07.3 failed with error -16

nf_conntrack version 0.5.0 (8192 buckets, 32768 max)
CONFIG_NF_CT_ACCT is deprecated and will be removed soon. Plase use
nf_conntrack.acct=1 kernel paramater, acct=1 nf_conntrack module option or
sysctl net.netfilter.nf_conntrack_acct=1 to enable it.


I have stored the dmesg output, so if I should look for a specific
text phrase or pattern I could still do that even by full text search.

If you think that would be helpful, I could as well post the output here.

OK, point (2).
When I want to shut down I have to confirm,
next comes a black screen with only a white mouse curser,
then come the shutdown messages.

You did mean the black screen with the white mouse curser
when talking about the splash screen?
I did hit ESC then and the shutdown messages looked
a bit different then.

(a) Without the ESC key:


Shutting down service kdm
done
/etc/init.d/kdb stop
done
Shutting down SSH daemon
done
Shutting down acpid
done
Shutting down Name Service Cache Daemon
done
Saving random seed
done
Shutting down (remotefs) network interfaces:

Here the system did hang the first time.
Pressing Ctrl-Alt-Del the shutdown went on:


Not stopping NFS client services:
not used
Shutting down Hal daemon:
done
Shutting down rpcbind
done
Shutting down syslog services
done
Shutting down (localfs) network interfaces:
eth0 device: 3COMCorporation 3 …

That’s it.
Couldn’t read more.
The 3COM device is the ethernet card
which isn’t connected to anything.

(b) With ESC key hit:


Shutting down the Firewall
skipped
Shutting down SMPPPD
done
Shutting down auditd
done
Shutting down Avahi daemon
done
Shutting down Service kdm
done
Shutting down java.binfmt_misc
done
/etc/init.d/kdb stop
done
Shutting down SSH daemon
done
Shutting down acpid
done
Shutting down (remotefs) network interfaces:
Not stopping NFS client services: unused
Shutting down rpcbind
done
Saving random seed

That’s it here.
No reaction to Ctrl-Alt-Del or anything else here.

And I checked again: when I’m not going online
with the modem between startup and shutdown
then I get a proper shutdown.

The order of the shutdown messages seem however
to vary a bit from shutdown to shutdown.

Thank you for helping
Mike

If I switch off the modem (i.e. turn off power
for the modem after SUSE hangs during shutdown),
SUSE is continuing and shutting down properly,
just if I hadn’t accessed the internet during
the LINUX session.

BUT on the other hand this means that some freshly installed
component of 11.1 has been trying to access the internet
during shutdown (which with my modem connection of course
isn’t possible),
and that this component does so WITHOUT NOTICING ME,
I.E. WITHOUT THAT I WOULD BE AWARE OF THAT,
OR THAT I WOULD BE OK WITH THAT,
which I dislike.

I always expected WINDOWS to do such things,
but never LINUX.

I have to say that I am disappointed and
somewhat disillusioned, discovering this.

Ouch… I feel ya homie…

ratzi wrote:
> but never LINUX.
>
> I have to say that I am disappointed and
> somewhat disillusioned, discovering this.

It may also be that there is a bug in the modem driver that prevents a
normal shutdown, but the power disconnection works. Remember that not
many Linux users actually have modems - at least not of the dial-up
variety.

Always remember that every non-trivial program has at least one bug.
For certain, Linux is not trivial!

Hi lwfinger,

I used Kinternet to connect under SUSE 10.3 and never
experienced such a behaviour like under 11.1 (under 11.1
I still use Kinternet as well).

I guess Kinternet hasn’t changed that much, if at all, since.

In fact, modem connections are slow.

But there is one advantage:
One exactly knows when the computer accesses the internet,
one knows if (at all) the computer is transferring data,
and one can at least guess how much data is transferred.

And: if I pull out the power plug (or physically turn off
the power switch) I’m very sure that there isn’t any
connection anymore.

Believe me:
if I would have observed the same behaviour under SUSE 10.3
already, I wouldn’t have posted here for 11.1.

Anyway, thanks for your comments.
Mike

You could also try to disable the Ethernet network card. If onboard, in the BIOS, if not onboard by removing it. Normally I would expect the connection to be closed on shutdown, no matter whether modem is on or not.
But I’ve worked on one machine where disabling the onboard network card was a solution to a similar problem. It felt like the system wanting something from the network card first before doing anything with the modem connection. Never realy solved it, i.e. still don’t understand why it worked that way.

Similar experience on both boot and shut down. The process hangs repeatedly, continuing only when a key is hit. It’s like the process is being piped through the “more” utility in DOS. My install of 11.1 will neither boot nor shut down without manual intervention, which can take over 20 minutes (each); a restart today took almost an hour. Is there a “trace” mode being invoked here where it is not wanted?
This computer is on a fast Ethernet connection to a fiber access loop.

Hi Knurpht,

I tried it out, screw up my computer and removed the
ethernet card.
However, the behaviour remained the same.

Another observation was, that a LED on the modem (DTR)
turned on during shutdown, that was inactive before,
indicating that some component of SUSE 11.1 was in fact
trying to access the internet by means of the modem,
i.e. definitely not by means of the ethernet card.

Take care
Mike

My problems disappeared when I added options at the first screen with the options: noapic acpi=off
I’m happy again.