11.1 deactivates USB-keyboard

Hi all,

I used to work with a PS/2 keyboard.
But one key of it has a malfunction.
So I bought a new Cherry USB Keyboard.

GRUB and the BIOS like it - no doubt, the
keyboard itself is OK.

But as soon as SUSE 11.1 takes control during boot,
the lights of the keyboard are switched off,
and the keyboard is deactivated.

I even tried to re-install 11.1 from DVD with the
USB keyboard plugged in alone - in vain.

With the PS/2 keyboard I didn’t ever had any such problems.

I run a system with a Pentium III (Katmai) on an
Intel RC440BX Motherboard.

Does anybody have an idea how to fix this ?

Thank you.

You can boot with your PS/2 keyboard and plug your USB keyboard later to see if it is recognized. There is nothing wrong with having both keyboards. But DON’T unplug you PS/2 keyboard while your computer is on!

Also make sure that other USB devices (on the same port) work.
Does that keyboard work with oher systems? Is your keyboard a new model (which might possibly not be supported by 11.1 hal daemon - responsible for detecting hardware). If so try to boot openSUSE 11.2 livecd!

there is an adapter plug converter to connect usb keyboard to ps/2 socket.
else while installing keyboard selection choice must be changed
check if there is a configuration of keyboard change available in yast.
it is the X server to find this usb keyboard.

Don’t use that! It will be seen as ‘generic keyboard’ by the hal daemon. It might work though if that’s what you want, but extra keys if any won’t be available. You should avoid USB to PS/2 adapters noawdays. :frowning:

Thank you please_try_again,

after plugging the keyboard to the same USB 2.0 hub,
to which my USB-mouse already is connected to,
evth. works fine!

Before that, the keyboard was attached to an older
USB hub (probably USB 1.0 or 1.1), which is connected
to the 2nd USB port of the PC.