11.1 Beta 3 on offline machine

Yesterday I installed 11.1 beta 3 on my home machine (no internet connection; x86-64; main system 11.0, additionally XP prof).
After starting software installation, I came back an hour later.
Screen dark, no action possible.
New start necessary.
After boot the PS/2-mouse was permanently freezed (retry: same reaction).
Boot in ‘save mode’.
Surprisingly, this was possible (that worked never before on my machine).
Mouse is working in safe mode, but I don’t see how to correct the situation.
A short time later I got some unclear system problem.

It looks like an unfinished installation.
For what should I look at first?

There are some minimum requirements; recommend you check.
Try a LiveCD, if it will work you may be OK.
Look at a minimal install 1st.

If you can boot in safe mode
go to Yast > hardware & select the correct mouse.
save out of all that & reboot

If not, type “level 3” at the bootsplash & boot to the command line
login as "
type “sax2 -r” or “sax2 -m 0=vesa” to load a very basic video driver
have a look at the video/monitor config and also the mouse again (yeah, it’s in sax2); test when you have the config the way you want (always test)
save out of all that
type “reboot”

should work if you meet the min requirements

You can also take the repos and put them on a DVD and use Yast’s PatchCD (or add-on) button to ID that to the system and use it as a repo (once you are up).

Good luck…

I didn’t try it with much power in 11.1 beta 3, but after updating(!) to 11.1 beta 5 which was resulting in the same mouse problem.

“sax2 -r” in safe mode was in fact the key to solve the problem -

but sax2 proved to be a hard problem in 11.1 beta 5:

before saving I tested - and the result of testing was disgusting (strange effects on the screen - my card: ATI Radeon X600 (RV380 Pro) with a Sony Multiscan 20sfII.
After some trial and reboot I found a solution to get a success for setting the mouse, and some time (and perhaps some reboot and/or system hanger later) a way to set the screen to 1600x1200 as usual (using the generic ‘SNY Sony Monitor’; I had to avoid to set to 20sfII, which was allowing only 1280x1024 using only a part of the screen).

For successful settings I had to ignore strictly the principially crazy “test” output of sax2 (yes, I’ve experience, that that’s normally ending in desaster. 11.1 beta5 was giving me a slight reminder of the pains of installing SuSE9.3 with an ATI card and an ancient monitor in 2005).

For the mouse I had simply to follow the sax2 proposal.
I don’t remember the successful steps.
The mouse I could set in safe mode, the screen maybe at level 3, maybe as root in normal mode … too much tries to remember the successful tries.
( not working: yast calling sax2 from normal user after asking for superuser password )

After that and after too much time to become acquainted with - what I think - much too much changes only for making changes between KDE3 and KDE4 and at the moment too less info for new and changed features, I’m resuming:

:slight_smile: 11.1 beta 5 is promising, that 11.1 will be clearing the main obstacles of 11.0 (even 11.1 beta 5 is a big step forward from 11.0) :slight_smile:

Yesterday evening I wanted to make an entry into my fuel statistics. Not more.


  • seeing wrong syntax for a lot of Calc cells(working in OpenOffice under openSuSE11.0)
    (this was caused by semicolons after formulas, which was accepted in older versions of OpenOffice)
  • strictly denying to show an x axis scale for the resulting picture
  • I made a new second x-scale, also not shown up
  • while trying that, a movable box containing one of the formulas of the sheet was shown up as text in the center of the diagram.
  • a while later OpenOffice crashed

But the resulting sheet is working in OpenOffice under openSuSE11.0, and it is showing two x axis scales - the old and the new made in 11.1 beta 5.

Storing the result to an USB stick:
The stick was not accepted, it was permanently ignored, also after retry and after reboot, the same under root.
But a second stick was accepted and worked correctly.

While working on this problem:

“KDE-crashman. : schwerer Fehler, plasma crashed, signal 11”

Is this a known failure situation?
There may be some error logging - what exactly will be needed?

After that: System without usable functionality.
After a new system start, only a single, but acting Dolphin window on an empty background was shown up.

It was early in the morning, and I had to go to bed.

Maybe, it will be enough, to kill all KDE4 entries in my home directory - that would bad enough.
Maybe, a system repair is necessary.

KDE4 may be nice, but it’s acting as a time consuming tamagotchi, and it isn’t stable enough for a 11.1 RC1 !!