11.1 Alpha2 > Factory (> near Beta1)

I’ve been reading & messing around and finally have my 11.1 Alpha2 install updating to today’s Factory which I hope is close to Beta 1 .

Here’s what I did:

In Yast under repositories, untick all except SL-OSS-factory/inst-source.

Go here Index of /distribution/SL-OSS-factory/inst-source/suse & get the latest:
satsolver-tools
zypper
libzypp

In a terminal as root install them with:
“rpm -Uhv --nodeps packagename.rpm”

Now a little housework:
Go to /etc/products.d and rename it products.d.bak; then recreate the folder /etc/products.d
I also went into /var/cache/zypp/solv/OSS-factory and moved to trash “cookie” & “solv”
I had no @System folder to start (part of my problem.

Now do:
“zypper ref”
everything zypper related is recreated.
Then do:
“zypper dup”
every thing is off & running…
Hopefully @ reboot I have close to Beta 1;)

I will then go back and add back the other repros like non-OSS, Packman, KDE4, etc. and see what happens:P

It worked; says:

Linux 2.6.27-rc5-git9-6-default x86_64

openSUSE -Alpha3plus

Hopefully the Yast > Factory Update feature will work next time.

Now for some playing around;)

I don’t have Icons in Yast Control Center; but do in all other Yast pages.
Have my rpm DB back
Everything seems to be working:)

Plenty to play with, have fun…

i didn’t have to do any of that to get to a3+. it just showed up that way. although that was after i added those two repos a day or two ago.

i didn’t have any icons in yast2 either.

but now i’ve got that ui syntax error that i commented about in the bug. my problem is that yast2 won’t even launch from it’s menu entry. so i can’t even do the first step you did…

UPDATE:
as i said before, i couldn’t disable any repos from yast cuz it won’t launch, but i went ahead and did what you did. the result i got when running “zypper ref” was the same as what i had been getting before:

File ‘/media.1/media’ not found on medium ‘http://download.opensuse.org/distribution/SL-Factory-non-oss/inst-source-extra/

Abort, retry, ignore? [A/r/i]: i
File ‘/media.1/media’ not found on medium ‘http://download.opensuse.org/distribution/SL-Factory-non-oss/inst-source-extra/

Abort, retry, ignore? [A/r/i]: i
Error building the cache database:
File ‘/media.1/media’ not found on medium ‘http://download.opensuse.org/distribution/SL-Factory-non-oss/inst-source-extra/

Skipping repository ‘FactoryNon-OSS’ because of the above error.

the rest was ok except at the end:
File ‘/content’ not found on medium ‘http://download.opensuse.org/repositories/openSUSE:/Factory/standard/
(this is the old repo but i can’t disable it with yast like i said before).

i appear to be in working order again though. i will try launching yast after my updates are done.

thanks so much!

does anyone know what caused this in the first place?

In a terminal as root “yast” or “yast2” (I forget). What happens?

i was getting the ui syntax error.

the solution you posted partially worked:

yast2 starts now. still no icons. however nothing works. when i click “Software Respoitories” i get a little window that says:
Error while creating client module sw_single. it has a little round OK button which is all you can click.

when i click on other entries in yast i get similar resutls:
Error while creating client module blah blah blah.

same when i try to launch yast by command line:
sudo /sbin/yast2 --install
Error while creating client module sw_single

how can i remove repositories without using yast?

Do you have “Smart” installed? Use Smart from a terminal as root “/usr/bin/smart --gui” and update all the yast packages from the Factory repro. Then reboot and try it again.

I always install “Smart” at the install so I will have a backup package manager.

Otherwise, download and manually install:
satsolver-tools
zypper
libzypp
With --nodeps or they won’t install.
and go from there.

Good luck.

i already installed those via rpm from command line.

i’m saying yast will start but the modules don’t work.

that is a good idea. i used to use syanptic in kubuntu (i thought adept left a lot to be desired) but i still had adept installed just in case. i’ll install smart and try it out.