11.1/4.2 Locking up - fixed (I Hope)

This is more of a solution than a question. I have been having numerous lockups of the system, where everything freezes except the mouse pointer which I could move but not actually do anything with, regardless of what software was running, requiring an unplug to restart. There are threads in relation to lockups but they seem to entail Samba or servers, neither of which I am running. One thread referenced the PAE kernel, which was what was installed as default on my Thinkpad for a clean install. I have changed the kernel to the ‘default’, ie non PAE and so far I have fixed this problem.

Laptop has been running for 1/2 a hour with various browsings happening with no lockups. Also Firefox, now is much, much quicker, with almost instant page loading whereas before it could take a a minute with two of three tabs loading at once, then the system would freeze.

1/2 a hour may not seem a fair test, but this morning I was getting lockups literally every 3-4 minutes, sometimes i would reboot, and it would lock before I could actually do anything. Sometimes, I swear, sneezing or praying for no lockups actually caused it to freeze:’(.

Therefore, from my small perspective having (please, please, please) fixed the problem it is my conclusion that the PAE kernel is evil>:), and has psychic powers which it uses to really stuff up your day.

The kernel is not evil. Looks like your machine reports it’s capable of running a PAE-kernel, but in fact isn’t. So manufacturor is evil, as ever.

I am possibly willing to concede that point as it is an Intel chip, which the EU considers to be a spawn of the devil.:wink:


I had been suffering similar lock-ups until I found the culprit being my Linuxant modem driver(rather tha KDE)and uninstalled it right away.

As soon as I again install the Linuxant driver for my Conexant-based modem, I can hear a hissing(?) sound, the one that is typical of dial-up modems and after a couple of minutes or at random boot-ups, the system freezes up like hell.

I’m new to Linux and this is just the 3rd day of my Linux experience.I had alreay sorted out most of the issues that usually comes up after a fresh install, and finding a driver for my softmodem mady me quite happy that I was ready to transfer my whole files from Windows and choose Linux as my default OS; but without an internet connection what the heck am I supposed to do? you know it is essential.:expressionless:

So I checked the FAQ section of Linuxant website and found a relevant question to my problem.The answer though was not helpful; it simpy informed that they are aware of the problem and that it has something to do with my AC97(ALC888) audio driver.According to Linuxant, the two drivers conflict each other either at desktop startup or when an audio function is invoked(like playing music).

The FAQ is located here.As you can see, it suggests to disable any conflicting modules while I use the modem but thing is i don’t know how to do that(maybe lsmod?) and even if can disalbe the problematic module, it won’t do me any good 'cause system freezes happen even if I don’t use the modem.

I don’t know, but maybe it’s because of the alsa drivers that I downloaded off their website.

I would be grateful if someone helps me to solve the problem.


since yesterday I have the same problem. After installing the driver for my ATI graphics card of the ATI repository my systems hangs when trying to boot KDE4.1.

I’ve done several attempts of installing openSuse 11.1. It runs fine as long as I don’t install the ATI driver for the pae-Kernel. Days before it ran fine but not since I’ve done the latest update.

Strange. Cannot boot anymore, screen’s black. The installation before the mouse pointer could be moved but I couldn’t activate anything on the desk.

Not funny.

@xnixxx: This could be a tricky one. I have a Conexant chipset, but it is a long time since I had to rely on dialup, so I don’t currently have linuxant modem driver installed. (I don’t remember having any issues with it). Anyway, maybe try stopping sound via CLI:

su (to become root user, enter password when prompted)
rcalsasound stop

Then see if modem works ok.

Sound system can be started again with

rcalsasound start

@deano_ferrari: I haven’t tried the command yet but whether or not it works doesn’t solve the problem.At most it only confirms the Linuxant’s answer to the problem that the modem driver is in conflict with the audio’s.

Is there any workaround to this? Or should I just stick to Windows until Linuxant issues a patch or something?

Also does switching to another distro remove the conflict? I’m thinking of Mandriva.

I don’t have the Linuxant modem driver, so that counts that out. As it turns out using the default kernel didn’t help anyway. Today it crashed in the middle of an update which killed openSuse completely. After rushing out and buying a magazine with a Linux DVD on it (I am not presently at home where my install disc is) I have finished up with SLED 11, which is fine except for the godawful Gnome. There is definitely a problem.
Too many people have reported very similar lock ups but the threads get highjacked into discussions about SAMBA and SSH, neither of which I run. Pages and pages of log files later we are no nearer to a solution. I am certainly not, especially as all my logs just got formatted with the SLED install. But I had tried vanilla firefox which didn’t work, different browsers, which didn’t work either. (apologies for cut and paste from another thread)

@deano: “bash: rcalsasound: command not found”

I will follow my issue in this thread.