11.0 update gone wrong: radeonhd doesn't work anymore

Hi everyone. I recently tried to update my openSUSE from 10.3 to 11.0 but I ran into some problems with the graphics driver. The radeonhd driver doesn’t seem to be working properly. This is a picture of my login screen (so it’s not exclusively a desktop environment issue):


And this how the desktop looks in KDE (notice the gray area in the bottom third of the screen and how everything on the right-hand side seems to have been “cut off” from view):


This is what happens when I try to move a window through the gray panel in the middle of the screen:


The resolution in these photos is 1440x900 but a similar effect can also be seen when I try to use the radeonhd driver at 1280x1024 (and probably other resolutions). I checked the aspect ratio (16:10) and the display size (x=410mm, y=257mm, d=19.1in)and everything seems to be correct. I also tried to install the ATI driver instead, but it didn’t work. I had tried to do so previously with 10.3, but I never managed and as such, I don’t think I have any other way to use monitor’s native resolution of 1440x900, which is not covered by Vesa.

The graphics card is a Radeon X1650 Pro and the monitor a Samsung SyncMaster 920NW. Any suggestions on what might be causing this bizarre behaviour and on how to get the radeonhd driver working normally at 1440x900 are most welcome :frowning:

P.S. - I’ll resize the photos or just paste a link to them if they’re taking up too much bandwidth.

I just did an update from 10.3 to 11.0 and I had to run sax2 again. I am using nvidia and the proprietary driver though. When I was doing the update I changed the 10.3 nvidia repository to point from 10.3 to 11.0 and enabled the repo when I did the update.

I went for a clean installation with a RC1 live cd and then changed the repositories from factory to the regular 11.0 ones.

By the way, when I load the live cd I used, the exact same thing shown in the above pictures happens, so it’s probably not some installation error.

I had the same Problem. Finally solved it by using the other Connector on my video card.