11.0 - odd issue w/ Toughbook touchscreen

I’ve been running 10.3 for a bit on my Toughbook CF-74. Thursday night I decided to use the 11.0 dvd to “upgrade” the install. I ran into some display issues and a couple other items, so I decided to just back up my profile and just wipe the machine and reinstall.

So I build an 11.0 install from scratch on the laptop. Miraculously, EVERYTHING worked outside of the box. In 10.3, I had to manually get the sound and the wifi to work, and I could never get the touchscreen to work at all (though it would strangely work as a joystick). But 11.0, it all worked, touchscreen included. The only problem I’m running into is a calibration issue.

The touchscreen will let me move the mouse around and click on items, but it almost seems like X thinks my screen is bigger than it actually is. It’s only a 13.3" screen (I set that in Sax2), and if you tap the center of the screen, it’ll line up, but the further you slide in any direction, the further out away from the stylus the cursor goes. Basically, it hits the edge of the screen by the time the stylus is about 2/3 of the way to the edge.

Configuration-wise, I actually have set nothing in Sax2 in regards to the touchscreen. Everything just “worked.” In 10.3, I did all sorts of different configurations with the drivers mentioned in this page and nothing ever worked.

I realize that touchscreen/tablet technology is not a very common thing for a lot of linux users (from everything I’ve read), and there is virtually NO support from Panasonic for linux. I’ve emailed both them and Fujitsu (the makers of the touchpanel) and both of them told me that I would have to get the driver from the other company.