11.0 installer problems

Hey guys I am trying to install Opensuse 11.0 and it seems to be getting stuck at the installation (installing boot manager). The message box reads:

Error occurred while installing GRUB

<All of the usual grub stuff about minimal BASH-like editing>

grub> setup --stage2=/boot/grub/stage2 (hd0,2) (hd0,2)

Error 17: Cannot mount selected partition
grub> quit

There are three main partitions I have (in order):

60GB C:/ drive with windows vista on it

~350GB D:/ drive with all of my data

25GB (unsure of drive letter) drive labelled “linux”. i made this partition in windows for opensuse.

And a 25GB hidden partition with my image of vista.

the “linux” partition is hda3 and i formatted it in the opensuse installer to ext3 with ‘/’ as the thingo.

When I try to exit the setup and load windows, it will never load it. it will always load the opensuse installer. the way i started the install was in windows by running the installer application which then rebooted my pc and commenced with opensuse install. When I get to boot screen (windows) it has two options:

windows vista
opensuse installer

If i try to launch vista from there, it will go straight to installer.

I tried going ahead with installation – without any bootloader (grub or lilo) and it finished. Went well, got into opensuse fine. When I shut it down and tried to reboot, the windows boot manager came up with two options again:

Microsoft Windows Vista
Opensuse 11.0 installer (LOCAL)

if i try and select vista, it goes straight to the opensuse installation again.

I am getting very worried now because vista will not boot. What I want it to do now is to get rid of the opensuse installer from the bootmenu.

the vista disk where you can fix the boot sector comes back with results: “startup repair could not detect a problem”

I have been searching endlessly around the internet about this error 17 and the grub bootloader. I have gone through the details of the opensuse installation and under booting this is what it says:

* Boot loader type: GRUB
* Location: /dev/sda3("/boot")

is there a way maybe that i could overwrite the windows one with grub because it seems grub is not overwriting the mbr.

I tried downloading super grub disk and trying to install grub to the mbr, but that wouldn’t work either!

Any help I recieve at all will be immensely appreciated.

You inserted the DVD while in Vista and launched the installation from there, right?

I’m going from memory here so this may not be pefectly correct, but it is close: Take a look at your C root directory, and you’ll see ~6 new files there. Look at the contents of boot.ini, and also for a file that is similar but renamed. The current boot.ini has a line which calls one of those new files in C (I think it may be something like “brgrub”); it’s a temporary boot sector. The other boot.ini probably is empty (except maybe for some comment text). Rename the openSUSE modified boot.ini to something else, and rename the renamed original boot.ini back to boot.ini. Or if there isn’t a file that looks like an original boot.ini, just rename the current one (again, the one with the openSUSE boot sector line) so there is no boot.ini at all. Reboot. The openSUSE installer line should be gone and Vista should boot.

See if this works and we can take it from there.

Hi Mingus
I too have the same problem as in my original post: Cannot boot into Vista after openSuse 11.0 Install - openSUSE Forums

I dont find my boot.ini file at all in my whole system. I did a search from under / directory as root:

linux-7utb:/ # find . -name boot.ini
linux-7utb:/ #

Here is the outyput of my C directory, can you please see what could be that file if my boot.ini got renamed?

joe@linux-7utb:/windows/C> ls -lrt
total 4498164
-rw-r–r-- 1 root users 496 2005-07-05 22:44 sysprep
-rw-r–r-- 1 root users 24 2006-09-18 17:43 autoexec.bat
-rw-r–r-- 3 root users 10 2006-09-18 17:43 config.sys
-rw-r–r-- 1 root users 438840 2006-11-02 04:53 bootmgr
drwxr-xr-x 1 root users 0 2006-11-02 08:02 Documents and Settings
drwxr-xr-x 1 root users 4096 2007-05-23 17:39 Boot
-rw-r–r-- 1 root users 8192 2007-05-23 17:39 BOOTSECT.BAK
-rw-r–r-- 1 root users 420 2007-10-26 02:44 RHDSetup.log
drwxr-xr-x 1 root users 0 2007-10-26 03:08 swtools
-rw-r–r-- 1 root users 8192 2007-12-03 09:30 grldr.mbr
-rw-r–r-- 1 root users 208876 2007-12-03 09:30 grldr
-rw-r–r-- 1 root users 158 2007-12-09 12:36 YServer.txt
drwxr-xr-x 1 root users 0 2007-12-10 18:15 Intel
-rw-r–r-- 2 root users 96726 2007-12-22 10:35 HeadVideo.log
-rw-r–r-- 1 root users 16413155 2007-12-22 10:36 FaceProv.log
drwxr-xr-x 1 root users 4096 2008-01-11 17:27 Users
drwxr-xr-x 1 root users 4096 2008-01-11 17:28 $Recycle.Bin
drwxr-xr-x 1 root users 0 2008-02-09 18:32 ApolloDivxToDVD
drwxr-xr-x 1 root users 0 2008-04-29 16:53 Startup
-rw-r–r-- 1 root users 3336 2008-04-29 16:53 deskPDF.opt
drwxr-xr-x 1 root users 0 2008-05-07 20:18 share
drwxr-xr-x 1 root users 4096 2008-08-26 00:14 ProgramData
drwxr-xr-x 1 root users 20480 2008-09-29 19:24 Program Files
drwxr-xr-x 1 root users 0 2008-10-11 10:37 openSUSE
drwxr-xr-x 1 root users 4096 2008-10-11 14:24 QUARANTINE
drwxr-xr-x 1 root users 40960 2008-10-11 14:36 Windows
drwxr-xr-x 1 root users 4096 2008-10-11 17:32 Apps
-rw-r–r-- 1 root users 2451374080 2008-10-11 18:03 pagefile.sys
-rw-r–r-- 1 root users 2137448448 2008-10-11 18:03 hiberfil.sys
drwxr-xr-x 1 root users 20480 2008-10-11 23:50 System Volume Information
-rw-r–r-- 2 root users 44 2008-10-12 02:00 openSUSE_hitme.txt
-rw-r–r-- 1 root users 220 2008-10-12 02:00 menu.lst

The contents of the last two files are as follows:

joe@linux-7utb:/windows/C> cat openSUSE_hitme.txt
This file was created by openSUSE installer.joe@linux-7utb:/windows/C>
joe@linux-7utb:/windows/C> cat menu.lst
timeout 0
title openSUSE 11.0 installer (LOCAL)
find --set-root /openSUSE_hitme.txt
kernel /openSUSE/linux devfs=mount,dall ramdisk_size=65536 lang=en splash=silent vga=0x31A
initrd /openSUSE/initrd

I’ve replied in detail on the other thead, here Cannot boot into Vista after openSuse 11.0 Install - openSUSE Forums

It worked for me with this solution:

  1. boot up your Suse Linux
  2. log in as root and open the console, or open your console in root mode
  3. go to your windows drive
  5. to be on the sure side, rename your GBLDR files to anything invalid
  6. Restart your comp
  7. Choose your windows from the windows boot manager

The only thing that i didn’t yet find out was how to remove that silly linux installation entry on their bootloader. i’ll look into it and will edit here when i found out how (and why it wasn’t auto removed maybe :P)