100% CPUload bt Xorg in KDE4.4


I have upgraded my KDE4.3.4 to 4.4 RC1 yesterday. All programs i use work fine (some Dolphin crashes though). A more irritating problem is that Xorg is using 100% of one of my CPU’s (dualcore).Not all the time, but cycling. Mostly noticable when the laptop is idle or downloading a torrent for example.

Does anyone else have this problem? Is this a know bug and is there already a workaround?

Laptop, AMD Turion dualcore, Nvidia 6100 VGA chip, Nvidia non-oss drivers

Repo’s: KDE4.4 factory, updates, OSS, Non-OSS, Nvidia, Packman, Community & Backports

Personally I wouldn’t use backports I have seen too many sob stories where such is the case.
Did you do this on the main kde4.4 desktop repo

Try disabling effects

None of your issues exist with me, or generally AFAIK

yep, did exactly like the screenshot. Got Backports disabled now, wasn’t really using it anyway. Also disabled Effects and Powerdevil and screensaved, because the cpu-load rises after a minute or two, and goes down when i start using the pc…

Any clues? Can it be the powermanagement? Or should i try a clean install of kde4.1 and than, before customization, upgrade to 4.4?

Before all that, try creating a new user, start a KDE4 session as that new user and see if the problem exists. If not, it might very well be the remains of some plasmoid. You could then
simply logout, hit Ctrl-Alt-F1,
login with normal username and password and do:
rm ~/.kde4/share/config/plasma*
This would remove all plasma config files and give back a clean standard KDE4 desktop.

thnx for replying. Tried the new user, seemed to work. No high load for 10mins. So i cleaned out the plasma for the standard user. But unfortunately, no effect; high cpu load after a minute or three…

other options?

You may have to go the whole hog and do this from a terminal

mv .kde4 .kde4-old

logout immediately and back in

I know this one, but it throws away all settings for KDE4 apps as well, thus creates the next problem.

Any plasmoids used?

No, not at all - never had this happen here.
Dolphin is running very smooth as well, not a single crash here.

Only real issue I had was that the taskbar was behaving and displaying strangely after upgrading to 4.4 RC. Deleting the taskbar and creating a new one from scratch fixed that. You could try that as well.

after much time and effort i’ve decided to switch back to KDE4.3.4, and now the problem is gone! No more cpu-hogging…

Haven’t removed my .kde and .kde4 folders, so my settings are still there. At least in this version of KDE that doesn’t seem the problem.
The way i look at it that is somehow does have to do with KDE4.4, at least on my system… When i have the time (and the guts) i will try a new install of KDE4.3.1 and then upgrade to 4.4. See what happens then.

@Knurpht:i don’t have any plasmoids left, besides the taskbar and DesktopFolder

It is weird though, that this only seems to happen on my pc…:’(

I’d say that the problem isn’t Kde, but some program that doesn’t run on it well yet.
Are you using any non-standard programs?

I have no programs installed other than those in the aforementioned repo’s. The only program from outside the repo’s is VirtualBox non-OSS version…

I do wonder what the issue is, as KDE4.3.4 does not have the problem. Can it have something to do with the plasma-theme’s i have installed (i have a lot of them) which i can’t seem to remove (nor via CLI, GUI or Yast)

thnx again

I too had this problem … only with an earlier version of KDE4. After about 10 min my system would go into what I called hyper drive and Xorg was 100% of the CPU. At that time it was determined to be caused by the Powerdevil and that is why there was a delay before it happened. That was supposed to be fixed -but- it could be rearing its ugly head again. The other culprit is PulseAudio. I have had the most troubles with both of these. Check out the Bug list and search for Powerdevil and PulseAudio. You may find some hints there.
Take care and have fun

I’m using PowerDevil and PulseAudio and don’t have the slightest problem with either.
It’s even that sound wouldn’t work before I switched it to PulseAudio.

Tried the above solution,and unchecked the DPM settings, but it did not help. What helped me was to delete the power settings in /.kde4/share/config/.

I just got hit by this… twice.
I wasn’t using my computer for a while so the screen went into standby (which I had turned off before but I guess KDE4.4 re-enabled). When I tried using it again everything was laggy as possible without being completely frozen. I tried starting system monitor to see what was causing the problem but everything was so laggy I couldn’t so I just killed and restarted X, everything was fine. I disabled DPMS standby, shutdown, etc via xset and added lines to my xorg.conf that should’ve made it permanent (“Option Standby Time 0” etc) but after a reboot it did it again (this time I had system monitor open already so I could confirm X was hogging the CPU, though it was sucking from all 4 cores instead of just 100%ing one core) so now I just commented out the DPMS line in xorg.conf.

Side not… possibly related… I noticed power settings is telling me “ConsoleKit was not found active on your PC, or PowerDevil cannot contact it…”

I had X and Plamsa-desktop doing the same thing (running the CPU constantly at 70 to 90%). I also had a problem whereby right clicks to get popup menus would result in them flashing then going away).

I removed the Weather and Network widgets from System tray and that fixed both problems.

Not sure this is related …

I have almost the same problem, but with kde4 process on lenovo x200 laptop. The string from the top output is:

3454  user  20  0   429m  31m  15m  R   100   0.8  20:20.80  kded4

I also noticed that 100% load started after I run Korganizer. It should sync with remote calendar (authorization is required) but it didn’t ask me password for all the time of 100% CPU load. After near 10 min it asked the password, successfully synced and the CPU load became normal. I experienced this few times as started using sync with remote calendar.
The KDE version is 4.3.1 “release 6”, it was originally with OpenSuse 11.2 x64. Any other suggestions how to solve this?

I think this post can help!

Kinda regards,

OpenSuse 11.0
Platform Version 4.4.00 (KDE 4.4.0) “release 222”

Unfortunately, it didn’t. Seems it is connected with Korganizer alarm system, because after launching Korganizer I cannot even go to power management settings (error concerned with powerdevil and D-bus appears).

Did you try a new user account.?
If you create one we can delete it easily later.
But it will be a nice clean user account, if you get the same there, then I would say you need to consider trying an upgrade of kde4.

I can’t say I have ever experienced this and I have used just about every stage of kde4 and I do use korganizer