10.3 wireless setup in NetworkManager not working

I have just decided to go to wireless networking and have been left confused as to what is happening.

I have purchased a D-Link DWL-G122 usb device and am using the BT Total Broadband package which provides a wireless hub.

Firstly, when I plug the device in to the usb port, it does not automatically add itself to the NetworkManager. So I had to add the device manually. Whilst doing this, I found that the module dropdown box had nothing in it, so I had to manually enter the rt73usb module name.

Having done that, I then filled out the required information for security zone, etc, only to be asked to do this yet again when I pressed “Next” to continue on to the security information. That is niggling but no big thing :rolleyes:

Now come the problems.

Having gone through the whole process and pressing “Finish” in the NetworkManager, the network subsystem was restarted and whilst it started the nic it did not start the wireless.

NOTE: I have a nic and wireless device both connected to the same BT hub.

I then restarted the network from the cli in order to find more information on what was going on, only to find that the process was hidden from view due to NetworkManager. So I edited /etc/sysconfig/network/config as per the following


I then restarted the network again and found that the network system complained that it could not find any configuration information for the wlan0 device.

Further investigation showed that whilst the network system was looking for a wlan0 device, NetworkManager has created the wireless device as ifcfg-wlan-bus-usb.

So I created a symlink from ifcfg-wlan-bus-usb to wlan0 and restarted the network. Sure enough the network tried to bring up the wlan0 device and now could find the relevant configuration information.

After a very long wait, the wireless device finally got a dhcp supplied address from the BT hub.

Now that I had a lease for both the wireless device and the nic, I changed the default route to use the wlan0 device and unplugged the nic cable. Yay, the wireless network works :slight_smile:

Having satisfied myself that the device can get a lease now that I had created the configuration symlink and that the device works, I re-enabled NetworkManager and restarted the network. Starting the network this way, brings the wireless device up but never retrieves a dhcp lease from the BT hub :frowning:

Question: why does NetworkManager not have any modules in the module dropdown box for the wireless device?

Question: why does the NetworkManager create a different device name to the one that the network system is obviously looking for?

Question: am I missing the point, in that NetworkManager uses different device names to the ones used by the “if” scripts, in which case I have answered the previous question?

Question: why does it take so long to get a dhcp lease from the hub when it is much faster, almost instantaneous under windows?

Question: why does the device have to get a new lease each time the computer is rebooted, is there something broken in the dhcp client or is this a “feature” of the BT hub?

Question: am I missing the point here, in that I should set the nic to start only when the cable is plugged in, so that NetworkManager will raise a lease for the wireless card instead of the nic, solving my problems?

Question: why is there yet another interface created called wmaster0, as can be seen in the network startup screen, which I have attached later in this post?

Question: why can’t the network startup scripts add a nickname to the wlan device, as can be witnessed in the network startup output attached later in this post?

Actually, this is my girlfriends computer in a different location to me and I am now kicking myself that I did not do a final test to answer one of these questions myself. I am aware that the routing will not work with 2 devices holding a network address on the same network and so should have set the nic to only be enabled when the cable is plugged in, then restart NetworkManager to see if it did bring up the wireless device with a lease. So if that is indeed the solution to NetworkManager correctly bringing up the wireless device, I apologise to Tux :o

Here’s the output from lsmod

massai:/etc/sysconfig/network # lsmod | grep 73
rt73usb 29696 0
rt2x00usb 15872 1 rt73usb
rt2x00lib 27008 2 rt73usb,rt2x00usb
usbcore 124268 5 rt73usb,rt2x00usb,usbhid,uhci_hcd

Here’s the output from network restart

massai:/etc/sysconfig/network # /etc/init.d/network restart
Shutting down the NetworkManager done
Shutting down the DHCP DBUS Daemon done
Shutting down the NetworkManagerDispatcher done
Shutting down network interfaces:
eth0 device: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 43done
wlan0 done
Shutting down service network . . . . . . . . . . . . . done
Hint: you may set mandatory devices in /etc/sysconfig/network/config
Setting up network interfaces:
lo IP address:
Checking for network time protocol daemon (NTPD): doneed
eth0 device: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 43)
eth0 (DHCP) . . IP/Netmask: / done
command ‘iwconfig wlan0 nick massai’ returned
Error for wireless request “Set Nickname” (8B1C) :
SET failed on device wlan0 ; Operation not supported.
wlan0 (DHCP) . . . . . no IP address yet… backgrounding. waiting
Setting up service network . . . . . . . . . . . . . . done
SuSEfirewall2: Setting up rules from /etc/sysconfig/SuSEfirewall2 …
SuSEfirewall2: Warning: no default firewall zone defined, assuming ‘ext’
SuSEfirewall2: using default zone ‘ext’ for interface wmaster0
SuSEfirewall2: batch committing…

I did not want to attach a screen shot to this post (apologies for that) so here is a list of the devices that NetworkManager has created, extracted from the gui

D-Link DFE-530TX not connected
Ethernet network card not connected = eth-eth-bus-usb
Wireless network card not connected = wlan0-wlan0
Wireless network card not connected = wlan-wlan-bus-usb

I work on many different nix systems in my job but love to use suse at home. Due to massive time spent in Guild Wars recently, I have not spent much time in openSuse 10.3. I used to use KDE but am now falling for Gnome, as it has made huge leaps in openSuse since I last looked in to it.

Ultimately, I could just go along with a hack to keep the wireless device working ahead of the nic but as this is my girlfriends computer and whilst she is a brave girl that loves to mess about with linux instead of using Windows, I know she would like an easier time with all of this, so I would really like to get this all working via NetworkManager.


have you tried setting it up via YaST - network devices - network settings ? As for the bt hub, i have one & you can set the lease time on individual devices, all mine are set for permanent,so, if i take out the eth cable,the wireless gets the same i.p. as was previously set for it


Thanks for the info on the BT hub, that will be a great help.

As for Yast, yes I did. That is how I added the wireless device in the first place and the scenario I posted is all based on that installation.

Having not used 10.3 since I originally installed it, I am assuming that Yast -> Network Devices -> Settings is actually NetworkManager, though I could be wrong on this.

oops, my apologies, didn’t notice you were using 10.3, it should be YaST - network devices - network cards. Also, network manager only links to the config scripts IIRC. Also, have you tried the serialmonkey drivers ? get them here Main Page - Rt2x00Wiki


Hmm, I can get a dhcp lease and can use the wireless network when I change the route accordingly, so I don’t think the drivers are the issue here.

My problem is that NetworkManager does not fire the wireless device up, so I have to switch NetworkManager off and use the network start scripts from the cli.

I suppose what I really need to know is how I get NetworkManager to initialize the device. I’m thinking that if I configure the nic to only start if the cable is connected, then hopefully NetworkManager will initialize the wireless device.

I’ll happily forget the fcat that the BT hub seems to be really slow in sending a lease to the wireless device when I have set the lease for the device to never expire.

when setting up via YaST, did you select traditional ifup or network manager ? check to see which is controlling, also, set your ethernet to on cable connect & wireless at boot,see if that helps