10.3 updates

Going through online update configuration in yast I get an error message and the process will not complete. So I manually added an update repository. After selecting online update it goes through the refresh function and then comes back and says no active update sites available.

It goes to the site and downloads the list of patches but still tells me that no update site available.

I’m getting wrong checksum in primary.xml at every mirror I try. Is the update repository corrupted?

> It goes to the site and downloads the list of patches but still tells
> me that no update site available.

Have you considered the possibility that your 10.3 is fully patched already. (My
10.3 is fully current and therefore there are NO new updates available.)

> Is the update repository corrupted?

No, no corruption detected here, about 12 hours after you asked the
question–so, try again. If you still have a problem then you can assume that
the problem is on your end, not the repo end.

Heal thyself.

I got the same problem in Sat/Sun. I did redo 4 times and get the same result. I don’t think the problem in our end.

I reinstall the 10.3 again and again and run the YAST to do the update. Everytime after 30 min downloaded from the Repositories, the system just reported “No Update Availble”.

I found the filelist.xml was modified on 7th and 9th Nov. I just do the stupid reinstall again by using the same procedure, then configure the repository with Mirror. This time, it works.

I also reported the problem to openSUSE contact on Sunday monring. And the filelist.xml was then modified on 9th 22:xx.

I would bet, there is something wrong in the repo (Fedora did experience it before).

Each of those installs, did you do them with the machine attached to the internet?

If so, the script first installs from the CD/DVD and THEN automatically updates
all the packages to the latest available via the net.

So, if you then immediately try to update there are NO updates available. See??

And, my experience is that you can trust the SUSE-updater applet to signal you
when an update is available–and, just click to allow it to download and install
the patches. You just need to click, give the root password and go on to doing
other things. YaST is not even needed for updates. (NOTE: This is a CHANGE
from 10.2)

I had no issues this weekend at all with updated 6 different computers as that is when I normally do my updates to my systems. No problems with the default repositories or substituted mirrors.

a) the machine connects to a Wireless Router via LAN port. It is a stable broadband Internet.

b) some people said I may mis-operated. When U do the CD Installation, the Update is also doing in the same time … I can tell this is NOT TRUE. Why? Since I am only use text base console with vga=0x31a. The console screen is differet before upgrade (No SUSE Logo on the top) and after upgrade (do have SUSE Logo on the top of the screen).

c) One more for your reference :- by defaullt, after the CD installation, type “uname -a” the OS level is: After the update, the OS level should be: U can see the OS Level is different.

Um … anyway, I am downloading the UPDATE and to build a local-copy …

So, what is the messsage U got? Or, what patches U did successfully update in weekend?

What I experienced, just finish the CD Install and then proceed to Online Update. I recalled that there should be an Update for Kenerl (just after the CD Installation). However, in the Sat/Sun, after the Online Update, the system reports “No Update Available”. This is quite odd for me … (and honestly, very annoying!!! >:()

“The Update will just follow up after the CD Installation” - this is NOT my case.

I did have some bad experience before with SUSE CD Installation. I then divide the Installation into smaller batches. And do “sync;sync;reboot” after each Installation. I will only do Update after all required Patterns installed. Hence, I normally select “Configure Later” in the Repository setup. the system has no way to pull the XML.

I finally gave up. Installed 10.2 and it updated just fine.

I tried at least 6 mirrors and got the same error every time.

Never had this issue before. And didn’t do anything different. Guess I shouldn’t have reinstalled 10.3.

I finally gave up on 10.3. 10.2 worked ok.