10.3: ALSA, snd-emu10k1x in KDE

I’m starting with a new installation of SUSE 10.3, KDE 3.5.7 (I replaced SUSE 10.0). To my dismay, the sound driver is apparently not configured right. It claims card ‘0’ exists to root but not to users:

The play/aplay command works in root but with other user I see this:

> /usr/bin/aplay /usr/share/sounds/logout.wav
ALSA lib confmisc.c:768:(parse_card) cannot find card ‘0’
ALSA lib conf.c:3510:(_snd_config_evaluate) function snd_func_card_driver returned error: No such device
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:3510:(_snd_config_evaluate) function snd_func_concat returned error: No such device
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:3510:(_snd_config_evaluate) function snd_func_refer returned error: No such device
ALSA lib conf.c:3982:(snd_config_expand) Evaluate error: No such device
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM default
aplay: main:546: audio open error: No such device

I tried giving the user full read/write permission on every device in /dev that might have had anything to do with snd.

I tried alsaconf but basically sound was already working (only for root):

Configuring snd-emu10k1x
Do you want to modify /etc/modprobe.d/sound (and /etc/modprobe.conf if present)? <Yes>

OK, sound driver is configured.
will prepare the card for playing now.

Now I’ll run alsasound init script, then I’ll use amixer to raise the default volumes.
You can change the volume later via a mixer program such as alsamixer or gamix.

  • commented this out:

remove this if sound is configured

install char-major-116 /bin/true

– works as root –

Plays only as root:
root# /usr/bin/aplay /usr/share/sounds/logout.wav
Playing WAVE ‘/usr/share/sounds/logout.wav’ : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo

Thankyou for your post.

I almost missed your post, because it was in the HowTo/Faq area. There is a “multimedia” area, where we try to help users with their sound, and multimedia applications.

… but back to your problem, … I’ve been pushing that users look at the openSUSE audio troubleshooting guide, in case they have problems:
SDB:AudioTroubleshooting - openSUSE

In particular, please ensure you have installed alsa-firmware.

Also, take a look at step-6 in that guide, where it recommends for the sort of problem you reported, that you add your regular users to group audio:
SDB:AudioTroubleshooting - openSUSE

If that fails, can you please post here the output of:
rpm -qa | grep alsa
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

and post the URL(s) provided by running the two diagnostic scripts explained in the audio troubleshooting guide (step-3):
SDB:AudioTroubleshooting - openSUSE

Thankyou, and good luck!

Thank you, I’m glad this was moved to the appropriate forum. I was referring to the FAQ about how to post, but failed to find the appropriate forum before starting :confused:

That SDB:AudioTroubleshooting is good idea if it guides people to proper solutions. I had a hard time finding anything official about my problem, and the only thing I heard about ‘audio’ grp was on the side, someone mentioned (without details) that they had already checked that. It took a while for me to think of looking back there again.

I solved the problem, belonging to ‘audio’ group. I want to point out that there could be other steps that helped but many of them I have tried were not necessary (but were the things I found in searches). The biggest hint is that I had got aplay to work as root but not my username (hence not the KDE where I was logged in). It seemed unlikely that I had missed installing something for ALSA. If I did a normal install, why would anything for sound not be installed? Doesn’t YaST take care of that stuff? If that were possible then more documentation is needed to explain that.

I thought before that I had seen that I belonged to some sort of sound group, but I was still not. I added my user to the ‘audio’ group, re-logged in, then “poof”, sound works in KDE.

It leaves me to wonder, why does SUSE user management assume that every user I added did NOT want sound to work??

Thanks! How sweet the sounds!

Congratulations!! And thank you for sharing your solution.

I don’t know the answer. I do know for the vast majority of sound cards (when used with the alsa driver) it is not necessary to add users to group “audio”. Yet with some (in particular Sound Blaster) it often is.

Why is that? I don’t know.

On occasion I have “speculated” (and “speculated” is the operative word) that the reason for this (add to group audio for some sound cards and not for others) might because creating the driver application alsa is a joint developer effort, and some of those developers require group audio, and others do not. But thats pure speculation on my part. … Maybe some day we will know the real reason.

Anyway, glad to read your sound is working now.

Thank you; that explanation is good for me. Well put. I see that the challenge in documenting this stuff is due to the dynamic complexity. For example the answer might need re-worded for new version of drivers released while one is writing the docs.