0.97 GRUB, 256 inode SuSE, no boot.

I boot old GRUB on hd1, Windows hd0, new openSuSE all alone on hd2.

I want to keep old GRUB. What can I do to get GRUB to boot openSuSE? I plan to load F10 and PCLOS on hd2 along with SuSE…

Thanks

You could install OpenSUSE’s new GRUB to the partition boot record and then get the GRUB in the master boot record to chain to that.

Thanks there Ken…

I’m not sure exactly how to do that.

Boot the LiveCD first, I guess?

Open up GRUB command line next?

After that, ?

Here’s what I got now:

=============================================

chucknb@chucknb-desktop:~$ sudo fdisk -l
[sudo] password for chucknb:

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000afd18

               openSuSE

Device Boot Start End Blocks Id System
/dev/sda1 1 262 2104483+ 82 Linux swap / Solaris
/dev/sda2 * 263 2351 16779892+ 83 Linux

Disk /dev/sdb: 30.7 GB, 30735581184 bytes
255 heads, 63 sectors/track, 3736 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0006ca0a

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 3736 30009388+ 7 HPFS/NTFS

Disk /dev/sdc: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00022288

Device Boot Start End Blocks Id System
/dev/sdc1 * 1 7343 58982616 83 Linux
/dev/sdc2 9448 9729 2265165 5 Extended
/dev/sdc3 7344 9447 16900380 83 Linux
/dev/sdc5 9448 9729 2265133+ 82 Linux swap / Solaris

Partition table entries are not in disk order
chucknb@chucknb-desktop:~$ sudo gedit /boot/grub/menu.lst

=======================================================

title Ubuntu 8.04.2, kernel 2.6.24-23-generic
root (hd0,0)
kernel /boot/vmlinuz-2.6.24-23-generic root=UUID=c750b94d-415d-4015-8d90-54500d601b5d ro quiet splash
initrd /boot/initrd.img-2.6.24-23-generic
quiet

END DEBIAN AUTOMAGIC KERNELS LIST

This is a divider, added to separate the menu items below from the Debian

ones.

title Other operating systems:
root

This entry automatically added by the Debian installer for a non-linux OS

on /dev/hdb1

title XPPro
map (hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd1,0)
chainloader +1

This entry automatically added by the Debian installer for an existing

linux installation on /dev/sda1.

title openSUSE in (hd2,1) <–not booting; settings ARE correct.
root (hd2,1)
configfile /boot/grub/menu.lst

Sorry, I don’t know about the mechanics of this, I only know it should work because I once had a 11.0 and 11.1 system in such an arrangement, done by YaST. You might want to start a new thread with a new title so that the people who can answer notice. But I believe it involves the chainloader directive, similar to the Windows stanza.

I think that a less specific title might get more futile answers from rookies (like myself), who don’t know the real answer, where as the ones who know the answer will know and understand right away the title.

I’m givin’ it a try anyway - maybe I’m wrong (again).

Chainloading the boot into the root partition was correct.

Old and new menu entries:


title openSuSE chainloader   <--- WORKED
root (hd2,1)
chainloader +1


title openSUSE in (hd2,1)   <--- Didn't work
root (hd2,1)
configfile /boot/grub/menu.lst


title openSUSE 11.1   <---Didn't work
    root (hd2,1)
    kernel /boot/vmlinuz-2.6.27.7-9-default root=/dev/disk/by-id/ata-ST3802110A_5LR74M8V-part2 resume=/dev/disk/by-id/ata-ST3802110A_5LR74M8V-part1 splash=silent showopts vga=0x317
    initrd /boot/initrd-2.6.27.7-9-default

What would happen if you tried instead of hd2

root (sd2,1)