Results 1 to 9 of 9

Thread: Font-antialias is not working?

  1. #1
    Join Date
    Jul 2008
    Location
    Athens
    Posts
    293

    Question Font-antialias is not working?

    Hello,
    I moved to tumbleweed a few weeks ago, fresh installation.
    I use my old /home since it was on another disk.

    My problem: Font rendering, is awful. Of course the in KDE settings I have enabled the Antialias (by disabling it, logging out login and enable, logout and login again).
    I also have a ~/.config/fontconfig/fonts.conf file which is the same as in the last 10 years (when I fixed it in the then openSUSE installation and then never touched it again).

    Searching around seems like Tumbleweed doesn't need any special repository with other than the default font rendering libraries, but in my case this is not working!

    For reference, what I have in the
    ~/.config/fontconfig/fonts.conf:

    Code:
    <?xml version="1.0"?> 
    <!DOCTYPE fontconfig SYSTEM "fonts.dtd"> 
    <fontconfig> 
     <match target="font" > 
      <edit mode="assign" name="rgba" > 
       <const>rgb</const> 
      </edit> 
     </match> 
     <match target="font" > 
      <edit mode="assign" name="hinting" > 
       <bool>true</bool> 
      </edit> 
     </match> 
     <match target="font" > 
      <edit mode="assign" name="hintstyle" > 
       <const>hintmedium</const> 
      </edit> 
     </match> 
     <match target="font" > 
      <edit mode="assign" name="antialias" > 
       <bool>true</bool> 
      </edit> 
     </match> 
     <match target="font" > 
      <edit mode="assign" name="lcdfilter" > 
       <const>lcddefault</const> 
      </edit> 
     </match> 
     <match target="font"> 
             <edit mode="assign" name="autohint"> 
                     <bool>true</bool> 
             </edit> 
     </match> 
    </fontconfig>
    
    I would appreciate if someone pointed me what I should do to fix this.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    31,739

    Default Re: Font-antialias is not working?

    As you used your existing home directory (which is in /home that you re-used unaltered) many setting will be of the system it was lastly used on (which you do not specify).

    To test if it is related to old configs, you could create a new user and see how it works there.
    Henk van Velden

  3. #3
    Join Date
    Jul 2008
    Location
    Athens
    Posts
    293

    Default Απ: Font-antialias is not working?

    Just to summarize what I have tested:

    1. Create new user, setup antialias/subpixel from the KDE config page
    2. Disable antialias/subpixel from the KDE config page, use only the /home/$USER/.config/fontconfig/fonts.conf settings
    3. Enable
    antialias/subpixel from the KDE config page, do not use the /home/$USER/.config/fontconfig/fonts.conf settings
    4. Copy the
    /home/$USER/.config/fontconfig/fonts.conf to the /etc/fonts/local.conf
    5. Use different fonts (like for example Arial).

    So far nothing works. The old repos I was using with Leap (either bran0k or namtrac) don't have subpixel packages anymore.

    I feel quite desperate to be honest and I would hate to abandon Suse/openSUSE after almost 26 years!


  4. #4
    Join Date
    Jun 2008
    Location
    Germany
    Posts
    210

    Default Re: Font-antialias is not working?

    Try Ubuntu fonts (available via zypper/yast), they make quiet a difference. If you are still not happy, you can take a look at the settings that are being used in GeckoLinux (based on TW). I was forced to reinstall my system last week and actually I am pretty happy how it looks with the Ubuntu fonts /antialias aktiv/subpixel rendering- rgb/hinting-slight.

  5. #5
    Join Date
    Jul 2008
    Location
    Athens
    Posts
    293

    Default Απ: Font-antialias is not working?

    Having half of the desktop with Ubuntu fonts, like for example Kate/KWrite etc and the rest (like FF for example) of it with ugly, tiresome fonts from the 80's is not ideal.

    I managed to restore my previous (still ugly) setup, but at least now I will check if I can make it better somehow, otherwise I know the solution: Fedora.

  6. #6
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    3,307

    Default Re: Font-antialias is not working?

    Perhaps you're not using your monitor's native resolution? This can lead to ugly artifacts.

  7. #7
    Join Date
    Jul 2008
    Location
    Athens
    Posts
    293

    Default Απ: Font-antialias is not working?

    That could be a case if I had issues with Leap 15.2.
    Besides, working with linux for 25+ I think I would know a couple of things about resolutions etc.

    Simply speaking, it's Tumbleweed and it's libraries. I booted the old disk with Leap 15.2 and everything was OK.

  8. #8
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    3,307

    Smile Re: Απ: Font-antialias is not working?

    Quote Originally Posted by tpe View Post
    That could be a case if I had issues with Leap 15.2.
    But it could be an issue with the upgrade. Breaking (literally) news for you: not everything works the same between versions!

    Quote Originally Posted by tpe View Post
    Besides, working with linux for 25+ I think I would know a couple of things about resolutions etc.
    I stand humbled. I've only used openSUSE since version 10 (it was called SUSE then, IINM) so, a relative newbie.

    Quote Originally Posted by tpe View Post
    Simply speaking, it's Tumbleweed and it's libraries.
    Thank you for the simple explanation, I thing I got it.

    Good luck for you.

  9. #9

    Default Re: Font-antialias is not working?

    Not sure what's affecting the op.

    I've saw this in the tumbleweed snapshot, I'm not expert but any hint if this is related.
    Code:
    Packages changed:   filesystem   glibc   ispell (3.4.00 -> 3.4.05)   systemd (251.4 -> 251.5)   virt-viewer   xz (5.2.6 -> 5.2.7)
     === Details ===
     ==== filesystem ====
     - Update /usr/etc/skel per XDG Directory Specification:   * Add .local/bin to eventually replace bin for user executable     files   * Use .local/share/fonts instead of .fonts for user specific fonts   * Add missing dirs: .local/share .local/state
    You can try also the font hintstyle in yast2-sysconfig editor.
    People who do not break things first will never learn to create anything

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •