Results 1 to 9 of 9

Thread: Failed to install caliber

  1. #1
    Join Date
    Feb 2021
    Location
    SOBRE RUEDAS
    Posts
    67

    Default Failed to install caliber

    Hello. When installing caliber I get the following error:
    Code:
    Problema: nada proporciona libQt6Gui.so.6(Qt_6.3.2_PRIVATE_API)(64bit), que el elemento calibre-6.5.0-1.1.x86_64 que se va a instalar necesita
     Solución 1: no instalar calibre-6.5.0-1.1.x86_64
     Solución 2: romper calibre-6.5.0-1.1.x86_64 ignorando algunas de sus dependencias
    
    Elija las soluciones usando '1' o cancele usando 'c' [1/2/c/i/?] (c):
    Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    31,721

    Default Re: Failed to install caliber

    Please always copy/paste the whole set of lines, starting with the prompt/command line (so we can see who you were, where you were and what you did), all the output (and not only what you think is important, let everybody decide for themselves what is important) including the next prompt line.

    And please when posting from a non-English language system into the English language forums, precede your command with LANG=C, like
    Code:
    LANG=C zypper in ..........
    Henk van Velden

  3. #3
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    7,468

    Default AW: Failed to install caliber

    Post:
    Code:
    LANG=C zypper se -s libqt6gui
    Code:
    LANG=C zypper lr -d
    Last edited by Sauerland; 03-Oct-2022 at 09:02.

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    7,468

  5. #5
    Join Date
    Sep 2014
    Location
    Germany
    Posts
    1,088

    Default Re: Failed to install caliber

    OPs problem might be this
    Code:
    # zypper dup
    Retrieving repository 'openSUSE Tumbleweed Oss' metadata ............................................................................................................................[done]
    Building repository 'openSUSE Tumbleweed Oss' cache .................................................................................................................................[done]
    Retrieving repository 'openSUSE Tumbleweed Non-Oss' metadata ........................................................................................................................[done]
    Building repository 'openSUSE Tumbleweed Non-Oss' cache .............................................................................................................................[done]
    Retrieving repository 'Packman openSUSE Tumbleweed' metadata ........................................................................................................................[done]
    Building repository 'Packman openSUSE Tumbleweed' cache .............................................................................................................................[done]
    Loading repository data...
    Reading installed packages...
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Computing distribution upgrade...
    3 Problems:
    Problem: the installed python310-PyQt6-6.3.1-1.3.x86_64 requires 'libQt6Core.so.6(Qt_6.3.2_PRIVATE_API)(64bit)', but this requirement cannot be provided
    Problem: the installed calibre-6.5.0-1.1.x86_64 requires 'libQt6Gui.so.6(Qt_6.3.2_PRIVATE_API)(64bit)', but this requirement cannot be provided
    Problem: the installed python310-PyQt6-6.3.1-1.3.x86_64 requires 'libQt6Core.so.6(Qt_6.3.2_PRIVATE_API)(64bit)', but this requirement cannot be provided
    
    Problem: the installed python310-PyQt6-6.3.1-1.3.x86_64 requires 'libQt6Core.so.6(Qt_6.3.2_PRIVATE_API)(64bit)', but this requirement cannot be provided
      deleted providers: libQt6Core6-6.3.2-1.2.x86_64
     Solution 1: deinstallation of python310-PyQt6-6.3.1-1.3.x86_64
     Solution 2: keep obsolete libQt6Core6-6.3.2-1.2.x86_64
     Solution 3: break python310-PyQt6-6.3.1-1.3.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c/d/?] (c):
    I saw it just a minute ago on openSUSE Tumbleweed 20220930.

  6. #6
    Join Date
    Feb 2021
    Location
    SOBRE RUEDAS
    Posts
    67

    Default Re: AW: Failed to install caliber

    Quote Originally Posted by Sauerland View Post
    Post:
    Code:
    LANG=C zypper se -s libqt6gui
    Code:
    LANG=C zypper lr -d
    Thank you for your answers. This comes out in terminal with your instruction. However, I have already seen that caliber is unstable right now.


    Code:
    atreides@localhost ~> LANG=C zypper se -s libqt6guiLoading repository data...
    Reading installed packages...
    
    
    S | Name       | Type    | Version   | Arch   | Repository
    --+------------+---------+-----------+--------+------------------------
    i | libQt6Gui6 | package | 6.4.0-1.1 | x86_64 | openSUSE-Tumbleweed-Oss
    v | libQt6Gui6 | package | 6.4.0-1.1 | i586   | openSUSE-Tumbleweed-Oss
    atreides@localhost ~> LANG=C zypper lr -d
    # | Alias               | Name                        | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                          | Service
    --+---------------------+-----------------------------+---------+-----------+---------+----------+--------+------------------------------------------------------------------------------+--------
    1 | openSUSE-20220930-0 | openSUSE-20220930-0         | No      | ----      | ----    |   99     | rpm-md | hd:/?device=/dev/disk/by-id/usb-SanDisk_Ultra_4C531001630304111235-0:0-part2 | 
    2 | packman             | packman                     | Yes     | (r ) Yes  | Yes     |   90     | rpm-md | https://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/         | 
    3 | repo-debug          | openSUSE-Tumbleweed-Debug   | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/tumbleweed/repo/oss/                      | 
    4 | repo-non-oss        | openSUSE-Tumbleweed-Non-Oss | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss/                        | 
    5 | repo-oss            | openSUSE-Tumbleweed-Oss     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/                            | 
    6 | repo-source         | openSUSE-Tumbleweed-Source  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/tumbleweed/repo/oss/                     | 
    7 | repo-update         | openSUSE-Tumbleweed-Update  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/

  7. #7
    Join Date
    Apr 2011
    Location
    Texas USA
    Posts
    524

    Default Re: Failed to install caliber

    Just for information, calibre update installed fine in leap 15.4 by pasting their provided update string into a terminal.

    tom kosvic

  8. #8
    Join Date
    Feb 2021
    Location
    SOBRE RUEDAS
    Posts
    67

    Default Re: Failed to install caliber

    Quote Originally Posted by tckosvic View Post
    Just for information, calibre update installed fine in leap 15.4 by pasting their provided update string into a terminal.

    tom kosvic
    Thanks. Are you referring to the terminal command provided on the calibre website itself? https://calibre-ebook.com/download_linux
    Code:
    sudo -v && wget -nv -O- https://download.calibre-ebook.com/linux-installer.sh | sudo sh /dev/stdin

  9. #9
    Join Date
    Sep 2012
    Posts
    8,218

    Default Re: Failed to install caliber

    Quote Originally Posted by tckosvic View Post
    calibre update installed fine in leap 15.4 by pasting their provided update string into a terminal.
    This thread is about Tumbleweed provided package, not about third party installation on Leap 15.4. Please do not make discussion even more confusing than it already is.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •