SUSE Security Update: Security update for webkit2gtk3 ______________________________________________________________________________ Announcement ID: SUSE-SU-2022:3488-1 Rating: important References: #1203530 Cross-References: CVE-2022-32886 CVE-2022-32912 CVSS scores: CVE-2022-32886 (NVD) : 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVE-2022-32886 (SUSE): 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVE-2022-32912 (NVD) : 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVE-2022-32912 (SUSE): 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H Affected Products: SUSE Linux Enterprise Desktop 15-SP4 SUSE Linux Enterprise High Performance Computing 15-SP4 SUSE Linux Enterprise Module for Basesystem 15-SP4 SUSE Linux Enterprise Module for Desktop Applications 15-SP4 SUSE Linux Enterprise Module for Development Tools 15-SP4 SUSE Linux Enterprise Server 15-SP4 SUSE Linux Enterprise Server for SAP Applications 15-SP4 SUSE Manager Proxy 4.3 SUSE Manager Retail Branch Server 4.3 SUSE Manager Server 4.3 openSUSE Leap 15.4 ______________________________________________________________________________ An update that fixes two vulnerabilities is now available. Description: This update for webkit2gtk3 fixes the following issues: Updated to version 2.36.8 (bsc#1203530): - CVE-2022-32886: Fixed a buffer overflow issue that could potentially lead to code execution. - CVE-2022-32912: Fixed an out-of-bounds read that could potentially lead to code execution. Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.4: zypper in -t patch openSUSE-SLE-15.4-2022-3488=1 - SUSE Linux Enterprise Module for Development Tools 15-SP4: zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP4-2022-3488=1 - SUSE Linux Enterprise Module for Desktop Applications 15-SP4: zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP4-2022-3488=1 - SUSE Linux Enterprise Module for Basesystem 15-SP4: zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP4-2022-3488=1 Package List: - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64): libjavascriptcoregtk-4_0-18-2.36.8-150400.4.15.1 libjavascriptcoregtk-4_0-18-debuginfo-2.36.8-150400.4.15.1 libjavascriptcoregtk-4_1-0-2.36.8-150400.4.15.1 libjavascriptcoregtk-4_1-0-debuginfo-2.36.8-150400.4.15.1 libjavascriptcoregtk-5_0-0-2.36.8-150400.4.15.1 libjavascriptcoregtk-5_0-0-debuginfo-2.36.8-150400.4.15.1 libwebkit2gtk-4_0-37-2.36.8-150400.4.15.1 libwebkit2gtk-4_0-37-debuginfo-2.36.8-150400.4.15.1 libwebkit2gtk-4_1-0-2.36.8-150400.4.15.1 libwebkit2gtk-4_1-0-debuginfo-2.36.8-150400.4.15.1 libwebkit2gtk-5_0-0-2.36.8-150400.4.15.1 libwebkit2gtk-5_0-0-debuginfo-2.36.8-150400.4.15.1 typelib-1_0-JavaScriptCore-4_0-2.36.8-150400.4.15.1 typelib-1_0-JavaScriptCore-4_1-2.36.8-150400.4.15.1 typelib-1_0-JavaScriptCore-5_0-2.36.8-150400.4.15.1 typelib-1_0-WebKit2-4_0-2.36.8-150400.4.15.1 typelib-1_0-WebKit2-4_1-2.36.8-150400.4.15.1 typelib-1_0-WebKit2-5_0-2.36.8-150400.4.15.1 typelib-1_0-WebKit2WebExtension-4_0-2.36.8-150400.4.15.1 typelib-1_0-WebKit2WebExtension-4_1-2.36.8-150400.4.15.1 typelib-1_0-WebKit2WebExtension-5_0-2.36.8-150400.4.15.1 webkit-jsc-4-2.36.8-150400.4.15.1 webkit-jsc-4-debuginfo-2.36.8-150400.4.15.1 webkit-jsc-4.1-2.36.8-150400.4.15.1 webkit-jsc-4.1-debuginfo-2.36.8-150400.4.15.1 webkit-jsc-5.0-2.36.8-150400.4.15.1 webkit-jsc-5.0-debuginfo-2.36.8-150400.4.15.1 webkit2gtk-4_0-injected-bundles-2.36.8-150400.4.15.1 webkit2gtk-4_0-injected-bundles-debuginfo-2.36.8-150400.4.15.1 webkit2gtk-4_1-injected-bundles-2.36.8-150400.4.15.1 webkit2gtk-4_1-injected-bundles-debuginfo-2.36.8-150400.4.15.1 webkit2gtk-5_0-injected-bundles-2.36.8-150400.4.15.1 webkit2gtk-5_0-injected-bundles-debuginfo-2.36.8-150400.4.15.1 webkit2gtk3-debugsource-2.36.8-150400.4.15.1 webkit2gtk3-devel-2.36.8-150400.4.15.1 webkit2gtk3-minibrowser-2.36.8-150400.4.15.1 webkit2gtk3-minibrowser-debuginfo-2.36.8-150400.4.15.1 webkit2gtk3-soup2-debugsource-2.36.8-150400.4.15.1 webkit2gtk3-soup2-devel-2.36.8-150400.4.15.1 webkit2gtk3-soup2-minibrowser-2.36.8-150400.4.15.1 webkit2gtk3-soup2-minibrowser-debuginfo-2.36.8-150400.4.15.1 webkit2gtk4-debugsource-2.36.8-150400.4.15.1 webkit2gtk4-devel-2.36.8-150400.4.15.1 webkit2gtk4-minibrowser-2.36.8-150400.4.15.1 webkit2gtk4-minibrowser-debuginfo-2.36.8-150400.4.15.1 - openSUSE Leap 15.4 (noarch): WebKit2GTK-4.0-lang-2.36.8-150400.4.15.1 WebKit2GTK-4.1-lang-2.36.8-150400.4.15.1 WebKit2GTK-5.0-lang-2.36.8-150400.4.15.1 - openSUSE Leap 15.4 (x86_64): libjavascriptcoregtk-4_0-18-32bit-2.36.8-150400.4.15.1 libjavascriptcoregtk-4_0-18-32bit-debuginfo-2.36.8-150400.4.15.1 libjavascriptcoregtk-4_1-0-32bit-2.36.8-150400.4.15.1 libjavascriptcoregtk-4_1-0-32bit-debuginfo-2.36.8-150400.4.15.1 libwebkit2gtk-4_0-37-32bit-2.36.8-150400.4.15.1 libwebkit2gtk-4_0-37-32bit-debuginfo-2.36.8-150400.4.15.1 libwebkit2gtk-4_1-0-32bit-2.36.8-150400.4.15.1 libwebkit2gtk-4_1-0-32bit-debuginfo-2.36.8-150400.4.15.1 - SUSE Linux Enterprise Module for Development Tools 15-SP4 (aarch64 ppc64le s390x x86_64): libjavascriptcoregtk-5_0-0-2.36.8-150400.4.15.1 libjavascriptcoregtk-5_0-0-debuginfo-2.36.8-150400.4.15.1 libwebkit2gtk-5_0-0-2.36.8-150400.4.15.1 libwebkit2gtk-5_0-0-debuginfo-2.36.8-150400.4.15.1 typelib-1_0-JavaScriptCore-5_0-2.36.8-150400.4.15.1 typelib-1_0-WebKit2-5_0-2.36.8-150400.4.15.1 webkit2gtk-5_0-injected-bundles-2.36.8-150400.4.15.1 webkit2gtk-5_0-injected-bundles-debuginfo-2.36.8-150400.4.15.1 webkit2gtk4-debugsource-2.36.8-150400.4.15.1 - SUSE Linux Enterprise Module for Desktop Applications 15-SP4 (aarch64 ppc64le s390x x86_64): libjavascriptcoregtk-4_1-0-2.36.8-150400.4.15.1 libjavascriptcoregtk-4_1-0-debuginfo-2.36.8-150400.4.15.1 libwebkit2gtk-4_1-0-2.36.8-150400.4.15.1 libwebkit2gtk-4_1-0-debuginfo-2.36.8-150400.4.15.1 typelib-1_0-JavaScriptCore-4_1-2.36.8-150400.4.15.1 typelib-1_0-WebKit2-4_1-2.36.8-150400.4.15.1 typelib-1_0-WebKit2WebExtension-4_1-2.36.8-150400.4.15.1 webkit2gtk-4_1-injected-bundles-2.36.8-150400.4.15.1 webkit2gtk-4_1-injected-bundles-debuginfo-2.36.8-150400.4.15.1 webkit2gtk3-debugsource-2.36.8-150400.4.15.1 webkit2gtk3-devel-2.36.8-150400.4.15.1 - SUSE Linux Enterprise Module for Basesystem 15-SP4 (aarch64 ppc64le s390x x86_64): libjavascriptcoregtk-4_0-18-2.36.8-150400.4.15.1 libjavascriptcoregtk-4_0-18-debuginfo-2.36.8-150400.4.15.1 libwebkit2gtk-4_0-37-2.36.8-150400.4.15.1 libwebkit2gtk-4_0-37-debuginfo-2.36.8-150400.4.15.1 typelib-1_0-JavaScriptCore-4_0-2.36.8-150400.4.15.1 typelib-1_0-WebKit2-4_0-2.36.8-150400.4.15.1 typelib-1_0-WebKit2WebExtension-4_0-2.36.8-150400.4.15.1 webkit2gtk-4_0-injected-bundles-2.36.8-150400.4.15.1 webkit2gtk-4_0-injected-bundles-debuginfo-2.36.8-150400.4.15.1 webkit2gtk3-soup2-debugsource-2.36.8-150400.4.15.1 webkit2gtk3-soup2-devel-2.36.8-150400.4.15.1 References: https://www.suse.com/security/cve/CVE-2022-32886.html https://www.suse.com/security/cve/CVE-2022-32912.html https://bugzilla.suse.com/1203530

More...