Results 1 to 8 of 8

Thread: Tumbleweed can't update as it can't find 'libQt5Core.so.5(Qt_5.15.5_PRIVATE_API)(64bit)'

  1. #1

    Default Tumbleweed can't update as it can't find 'libQt5Core.so.5(Qt_5.15.5_PRIVATE_API)(64bit)'

    As per title, Tumbleweed can't install latest update as it says it can't find 'libQt5Core.so.5(Qt_5.15.5_PRIVATE_API)(64bit)'. It says I have to either remove deepin desktop or break qt5integration, neither of which sounds a good idea!

    Any help would be much appreciated.

  2. #2
    Join Date
    Sep 2012
    Posts
    8,268

    Default Re: Tumbleweed can't update as it can't find 'libQt5Core.so.5(Qt_5.15.5_PRIVATE_API)(64bit)'

    Somebody needs to trigger rebuild of your package with new libraries. It was last rebuilt exactly one month ago (Sep 1). Open bug report or ping users listed as maintainers (https://build.opensuse.org/package/u.../deepin-daemon)

    See also https://forums.opensuse.org/showthre...-qt5-libraries

  3. #3

    Default Re: Tumbleweed can't update as it can't find 'libQt5Core.so.5(Qt_5.15.5_PRIVATE_API)(64bit)'

    Thanks for the fast reply. I see someone else has reported the same problem: https://bugzilla.opensuse.org/show_bug.cgi?id=1203919

  4. #4
    Join Date
    Sep 2012
    Posts
    8,268

    Default Re: Tumbleweed can't update as it can't find 'libQt5Core.so.5(Qt_5.15.5_PRIVATE_API)(64bit)'

    Quote Originally Posted by susebob6 View Post
    Thanks for the fast reply. I see someone else has reported the same problem: https://bugzilla.opensuse.org/show_bug.cgi?id=1203919
    As I already explained in the other thread, it is not the same problem. Rebuilding pcmanfm is not going to help you with deepin in any way. Tacking your comment on unrelated problem will likely get ignored too.

    In the meantime you may try devel project which seems to have been rebuilt against newer Qt: https://download.opensuse.org/reposi...SE_Tumbleweed/

  5. #5
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    4,374
    Blog Entries
    5

    Default Re: Tumbleweed can't update as it can't find 'libQt5Core.so.5(Qt_5.15.5_PRIVATE_API)(64bit)'

    Quote Originally Posted by susebob6 View Post
    As per title, Tumbleweed can't install latest update as it says it can't find 'libQt5Core.so.5(Qt_5.15.5_PRIVATE_API)(64bit)'. It says I have to either remove deepin desktop or break qt5integration, neither of which sounds a good idea!
    Nope! I does update smoothly to latest snapshot:
    Code:
    erlangen:~ # zypper dup 
    Loading repository data... 
    Reading installed packages... 
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command. 
    Computing distribution upgrade... 
    Nothing to do. 
    erlangen:~ #
    Provide a list of enabled repos as below and the full output of "zypper dup".
    Code:
    erlangen:~ # repos 
    #  | Alias         | Enabled | GPG Check | Refresh | Priority | URI 
    ---+---------------+---------+-----------+---------+----------+------------------------------------------------------- 
     7 | Packman       | Yes     | (r ) Yes  | Yes     |   90     | https://ftp.fau.de/packman/suse/openSUSE_Tumbleweed/ 
    21 | non-oss       | Yes     | (r ) Yes  | Yes     |   99     | https://download.opensuse.org/tumbleweed/repo/non-oss/ 
    23 | oss           | Yes     | (r ) Yes  | Yes     |   99     | https://download.opensuse.org/tumbleweed/repo/oss/ 
    30 | update        | Yes     | (r ) Yes  | Yes     |   99     | https://download.opensuse.org/update/tumbleweed/ 
    11 | google-chrome | Yes     | (r ) Yes  | No      |  100     | https://dl.google.com/linux/chrome/rpm/stable/x86_64 
    18 | jalbum        | Yes     | (  ) No   | Yes     |  100     | https://jalbum.net/download/software/yumrepo/ 
    20 | myrepo        | Yes     | (  ) No   | Yes     |  100     | dir:/home/karl/Downloads/myrepo 
    erlangen:~ # 
    openSUSE Tumbleweed, KDE Plasma, Blogs/KeepItSimple, i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), 5600X, 5700U (2022)

  6. #6

    Default Re: Tumbleweed can't update as it can't find 'libQt5Core.so.5(Qt_5.15.5_PRIVATE_API)(64bit)'

    Quote Originally Posted by karlmistelberger View Post
    Nope! I does update smoothly to latest snapshot:
    Code:
    erlangen:~ # zypper dup 
    Loading repository data... 
    Reading installed packages... 
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command. 
    Computing distribution upgrade... 
    Nothing to do. 
    erlangen:~ #
    Provide a list of enabled repos as below and the full output of "zypper dup".
    Code:
    erlangen:~ # repos 
    #  | Alias         | Enabled | GPG Check | Refresh | Priority | URI 
    ---+---------------+---------+-----------+---------+----------+------------------------------------------------------- 
     7 | Packman       | Yes     | (r ) Yes  | Yes     |   90     | https://ftp.fau.de/packman/suse/openSUSE_Tumbleweed/ 
    21 | non-oss       | Yes     | (r ) Yes  | Yes     |   99     | https://download.opensuse.org/tumbleweed/repo/non-oss/ 
    23 | oss           | Yes     | (r ) Yes  | Yes     |   99     | https://download.opensuse.org/tumbleweed/repo/oss/ 
    30 | update        | Yes     | (r ) Yes  | Yes     |   99     | https://download.opensuse.org/update/tumbleweed/ 
    11 | google-chrome | Yes     | (r ) Yes  | No      |  100     | https://dl.google.com/linux/chrome/rpm/stable/x86_64 
    18 | jalbum        | Yes     | (  ) No   | Yes     |  100     | https://jalbum.net/download/software/yumrepo/ 
    20 | myrepo        | Yes     | (  ) No   | Yes     |  100     | dir:/home/karl/Downloads/myrepo 
    erlangen:~ # 

    I think the problem only appears if you've got Deepin desktop installed.

  7. #7
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    4,374
    Blog Entries
    5

    Default Re: Tumbleweed can't update as it can't find 'libQt5Core.so.5(Qt_5.15.5_PRIVATE_API)(64bit)'

    Quote Originally Posted by susebob6 View Post
    I think the problem only appears if you've got Deepin desktop installed.
    I suggested to provide some information on your installation, but you are concealing it.
    openSUSE Tumbleweed, KDE Plasma, Blogs/KeepItSimple, i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), 5600X, 5700U (2022)

  8. #8

    Default Re: Tumbleweed can't update as it can't find 'libQt5Core.so.5(Qt_5.15.5_PRIVATE_API)(64bit)'

    Sounds like Debian Sid is currently broken because of this as well. All the same files are affected: https://release.debian.org/transitio...bi-5-15-6.html

    Should be fixed soon, hopefully.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •