Results 1 to 2 of 2

Thread: Problem with connection of external monitor - frozen screen, laptop

  1. #1

    Post Problem with connection of external monitor - frozen screen, laptop

    Hi,

    I have a problem with using an external monitor with laptop on LEAP 15.4., KDE:

    Code:
    Operating System: openSUSE Leap 15.4                 
         CPE OS Name: cpe:/o:opensuse:leap:15.4
              Kernel: Linux 5.14.21-150400.24.18-default
        Architecture: x86-64
     Hardware Vendor: Acer
      Hardware Model: Predator PT314-51s
    Code:
    Qt: 5.15.2
    KDE Frameworks: 5.90.0
    kf5-config: 1.0
    The second monitor seems to be connected

    xrandr --listproviders --listmonitors returns

    Code:
    Providers: number : 2
    Provider 0: id: 0x6a; cap: 0xf (Source Output, Sink Output, Source Offload, Sink Offload); crtcs: 4; outputs: 2; associated providers
    : 1; name: modesetting
       output eDP-1
       output DP-1
    Provider 1: id: 0x44; cap: 0x2 (Sink Output); crtcs: 4; outputs: 1; associated providers: 1; name: modesetting
       output HDMI-1-1
    Monitors: 1
    nonetheless after "enabling" through display manager, nothing happens and the laptop screen completely freezes.

    inxi -Ga returns

    Code:
    Graphics:  Device-1:Intel TigerLake-LP GT2 [Iris Xe Graphics]driver:i915v:kernel
    Device-2:NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q]driver:nouveauv:kernel
    Device-3:Chicony HD User Facingtype:USBdriver:uvcvideo
    Display:x11server:X.Org 1.20.3driver:loaded:modesetting,nouveauunloaded:fbdev,vesa
    resolution:1920x1080~144Hz
    OpenGL:renderer:Mesa Intel Xe Graphics (TGL GT2)v:4.6 Mesa 21.2.4
    Audio:     Device-1:Intel Tiger Lake-LP Smart Sound Audiodriver:sof-audio-pci-intel-tgl
    Device-2:NVIDIAdriver:snd_hda_intel
    Sound Server-1:ALSAv:k5.14.21-150400.24.18-defaultrunning:yes
    Sound Server-2:PulseAudiov:15.0running:yes

    I saw a lot of similar problems connected to the KDE and drivers, however I'm still not able to find any soluton. I would appreciate any hints.
    Thank you in advance for your reply.

  2. #2
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    4,291
    Blog Entries
    1

    Default Re: Problem with connection of external monitor - frozen screen, laptop

    Have you installed and used suse-prime?

    Your inxi -Ga output looks wrong. Please, whenever you post command output, include the command, so we can be sure what happened and what we see match. Leap 15.4 provides a broken old inxi version. Try sudo inxi -U first to upgrade to latest version from upstream, then try inxi -Ga again.
    Reg. Linux User 211409 *** multibooting since 1992
    Primary: 15.4, TW, 15.1 & 13.1 on Haswell @earthlink.net
    Secondary: eComStation (OS/2) &15.4 on i965P/Radeon
    Tertiary: Debian, Fedora, Mageia, more on Rocket Lake & older Intel, AMD, NVidia....

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •