Results 1 to 8 of 8

Thread: MacBookPro3,1 Tastatur / Tastenbelegung

  1. #1
    Join Date
    Sep 2022
    Posts
    3

    Default MacBookPro3,1 Tastatur / Tastenbelegung

    Hi,

    ich habe mir mal testweise Leap 15.4 auf ein 2007er MacBookPro3,1 installiert - via GeckoLinux Installer. Läuft out of the box! Nur die Tastaturbelegung kann ich nicht so einstellen, dass das System produktiv auf der Hardware genutzt werden könnte. Insbesondere bereitet das @ Zeichen Kopfschmerzen (welches ich nur nach Layoutumschaltung aus EN-US erreichen kann).

    Sprache und Tastaturlayout sind auf GER - Macintosh eingestellt, als Hardware ist Apple MacBookPro International gewählt.

    Ich habe bereits diverse Kombinationen des Tastatur-Mappings und 3rd Level Keys unter System Settings - Eingabegeräte - Tastatur - Advanced probiert. Ich habe keine Kombination gefunden, mit der ich das @ Zeichen unter DE Tastaturlayout entweder auf Q oder L mappen bzw aufrufen könnte.

    Kennt hier jemand eine Lösung für dieses Problem? Leider funktioniert die Forum-Suche bei mir nicht. Ich erhalte keinerlei Ergebnisse bei Eingabe relevanter Suchbegriffe zum Thema - daher ein neuer Post...

  2. #2

    Default AW: MacBookPro3,1 Tastatur / Tastenbelegung

    Unter:
    https://forums.opensuse.org/showthre...rache-wechseln
    findet man einige (gut versteckte) Hinweise zur Konfiguration der Tastaturbelegung.

  3. #3

    Default Re: MacBookPro3,1 Tastatur / Tastenbelegung

    Du hast leider nicht erwähnt, welche Desktopumgebung du benutzt. Je nach DE befindet sich die Einstellmöglichkeit an einer anderen Stelle.
    Kann es sein, das das "@" Zeichen auf der "1" als Viertbelegung liegt?
    Hier ein Link, wie du die Einstellungen zum Beispiel unter Gnome erreichst:
    https://askubuntu.com/questions/1666...%E2%82%AC-keys

  4. #4
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    4,364
    Blog Entries
    5

    Default Re: AW: MacBookPro3,1 Tastatur / Tastenbelegung

    Quote Originally Posted by GrandDixence2 View Post
    Unter:
    https://forums.opensuse.org/showthre...rache-wechseln
    findet man einige (gut versteckte) Hinweise zur Konfiguration der Tastaturbelegung.
    Gut sichtbar habe ich hier das Wesentliche zusammengefasst: https://forums.opensuse.org/entry.ph...-Configuration
    openSUSE Tumbleweed, KDE Plasma, Blogs/KeepItSimple, i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), 5600X, 5700U (2022)

  5. #5
    Join Date
    Sep 2022
    Posts
    3

    Default Re: MacBookPro3,1 Tastatur / Tastenbelegung

    Quote Originally Posted by hui View Post
    Du hast leider nicht erwähnt, welche Desktopumgebung du benutzt. Je nach DE befindet sich die Einstellmöglichkeit an einer anderen Stelle.
    Kann es sein, das das "@" Zeichen auf der "1" als Viertbelegung liegt?
    Hier ein Link, wie du die Einstellungen zum Beispiel unter Gnome erreichst:
    https://askubuntu.com/questions/1666...%E2%82%AC-keys
    Danke für den Hinweis. Ich benutze KDE Plasma. Auf dieser Tastatur kann ich auf der 1 nichts anderes als die 1 und das ! erreichen. Eigenartigerweise kann ich auch kein visuelles Tastaturlayout aufrufen. Das geht nur für die US Belegung.

  6. #6
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    4,364
    Blog Entries
    5

    Default Re: MacBookPro3,1 Tastatur / Tastenbelegung

    Quote Originally Posted by 3,1 View Post
    Danke für den Hinweis. Ich benutze KDE Plasma. Auf dieser Tastatur kann ich auf der 1 nichts anderes als die 1 und das ! erreichen. Eigenartigerweise kann ich auch kein visuelles Tastaturlayout aufrufen. Das geht nur für die US Belegung.
    Eigenartigerweise erzählst du einerseits Geschichten und andererseits verzichtest du darauf, Kommandos auszuführen:

    Wie wäre es damit?
    Code:
    karl@erlangen:~> localectl 
       System Locale: LANG=en_GB.utf8 
           VC Keymap: de-latin1-nodeadkeys 
          X11 Layout: de 
           X11 Model: pc105 
         X11 Variant: nodeadkeys 
         X11 Options: terminate:ctrl_alt_bksp 
    karl@erlangen:~> 
    
    Oder damit?
    Code:
    karl@erlangen:~> cat .config/plasma-localerc  
    [Formats] 
    LANG=de_DE.UTF-8 
    
    [Translations] 
    LANGUAGE=en_GB:de 
    karl@erlangen:~> 
    openSUSE Tumbleweed, KDE Plasma, Blogs/KeepItSimple, i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), 5600X, 5700U (2022)

  7. #7
    Join Date
    Sep 2022
    Posts
    3

    Default Re: MacBookPro3,1 Tastatur / Tastenbelegung

    Quote Originally Posted by karlmistelberger View Post
    Eigenartigerweise erzählst du einerseits Geschichten und andererseits verzichtest du darauf, Kommandos auszuführen:

    Wie wäre es damit?
    Code:
    karl@erlangen:~> localectl 
       System Locale: LANG=en_GB.utf8 
           VC Keymap: de-latin1-nodeadkeys 
          X11 Layout: de 
           X11 Model: pc105 
         X11 Variant: nodeadkeys 
         X11 Options: terminate:ctrl_alt_bksp 
    karl@erlangen:~> 
    
    Oder damit?
    Code:
    karl@erlangen:~> cat .config/plasma-localerc  
    [Formats] 
    LANG=de_DE.UTF-8 
    
    [Translations] 
    LANGUAGE=en_GB:de 
    karl@erlangen:~> 
    Moin Karl,

    da kommt bei mir folgendes raus:

    Code:
    :localectl 
       System Locale: LANG=de_DE.utf8 
                      LC_NUMERIC=pl_PL.utf8 
                      LC_TIME=pl_PL.utf8 
                      LC_MONETARY=pl_PL.utf8 
                      LC_PAPER=pl_PL.utf8 
                      LC_NAME=pl_PL.utf8 
                      LC_ADDRESS=pl_PL.utf8 
                      LC_TELEPHONE=pl_PL.utf8 
                      LC_MEASUREMENT=pl_PL.utf8 
                      LC_IDENTIFICATION=pl_PL.utf8 
           VC Keymap: de 
          X11 Layout: de 
    :~> locale 
    locale: Kann �LC_ALL� nicht auf die Standard-Lokale einstellen: Datei oder Verzeichnis nicht gefunden 
    LANG=de_DE.UTF-8 
    LC_CTYPE=de_DE 
    LC_NUMERIC=de_DE.ISO-8859-1 
    LC_TIME=en_DE.UTF-8 
    LC_COLLATE=de_DE 
    LC_MONETARY=en_DE.UTF-8 
    LC_MESSAGES=de_DE 
    LC_PAPER=de_DE 
    LC_NAME=de_DE 
    LC_ADDRESS=de_DE 
    LC_TELEPHONE=de_DE 
    LC_MEASUREMENT=en_DE.UTF-8 
    LC_IDENTIFICATION=de_DE 
    LC_ALL= 
    :~> cat .config/plasma-localerc  
    [Formats] 
    LANG=de_DE.UTF-8 
    LC_MEASUREMENT=en_DE.UTF-8 
    LC_MONETARY=en_DE.UTF-8 
    LC_NUMERIC=de_DE.ISO-8859-1 
    LC_TIME=en_DE.UTF-8 
    
    [Translations] 
    LANGUAGE=de:en_US
    
    
    
    Ich hatte OpenSuse dummerweise irrtümlich mit polnischer Sprache per GeckoLinux Installer installiert. Diese polnische Sprache für LC, wie unter localectl angegeben, kriege ich nun nicht mehr raus. Scheint aber nicht ursächlich für die Schwierigkeiten gewesen zu sein, auf dem MacBookPro aus 2007 ein brauchbares deutsches Layout zu erreichen.

    Momentan habe ich ein Setup für das MacBookPro3,1 gefunden, welches unter Leap 15.4 zumindest gängige Zeichen, wie @ und € richtig mappt:

    Systemeinstellungen - Eingabegeräte - Tastatur

    dort im Reiter (bei mir ist das in Englisch angezeigt, deshalb hier die Originalbezeichnungen in Englisch):

    - Hardware: Apple MachBook/MacBookPro (intl.)
    - Layouts: Global / Map: de, Layout: German (ohne Variante, da eine Vorschau der Tastaturbelegung nur mit der Einstellung Default unter Variante möglich ist)
    - Advanced: Keys to choose 3rd Level - Enter on keypad (das ist auf dem MacBookPro die Taste rechts neben der rechten Apfeltaste, damit kann ich nun die 3rd Level Zeichen weitgehend so erreichen, wie sie auf der Tastatur des MacBookPro gewohnt sind - z.B. @ auf L usw. Ein Mapping der 3rd Umschalter auf die linke oder rechte Apfeltaste oder die ALT-Taste ist mir nicht gelungen - solche Einsestellungen hatten nicht die erwartete Funktion. Durch das Weglassen der Variante funktionieren evtl. die Akzente nicht mehr richtig, wie mir scheint.)

  8. #8
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    4,364
    Blog Entries
    5

    Default Re: MacBookPro3,1 Tastatur / Tastenbelegung

    Quote Originally Posted by 3,1 View Post
    Moin Karl,

    da kommt bei mir folgendes raus:

    Code:
    :localectl 
       System Locale: LANG=de_DE.utf8 
                      LC_NUMERIC=pl_PL.utf8 
                      LC_TIME=pl_PL.utf8 
                      LC_MONETARY=pl_PL.utf8 
                      LC_PAPER=pl_PL.utf8 
                      LC_NAME=pl_PL.utf8 
                      LC_ADDRESS=pl_PL.utf8 
                      LC_TELEPHONE=pl_PL.utf8 
                      LC_MEASUREMENT=pl_PL.utf8 
                      LC_IDENTIFICATION=pl_PL.utf8 
           VC Keymap: de 
          X11 Layout: de 
    :~> locale 
    locale: Kann �LC_ALL� nicht auf die Standard-Lokale einstellen: Datei oder Verzeichnis nicht gefunden 
    LANG=de_DE.UTF-8 
    LC_CTYPE=de_DE 
    LC_NUMERIC=de_DE.ISO-8859-1 
    LC_TIME=en_DE.UTF-8 
    LC_COLLATE=de_DE 
    LC_MONETARY=en_DE.UTF-8 
    LC_MESSAGES=de_DE 
    LC_PAPER=de_DE 
    LC_NAME=de_DE 
    LC_ADDRESS=de_DE 
    LC_TELEPHONE=de_DE 
    LC_MEASUREMENT=en_DE.UTF-8 
    LC_IDENTIFICATION=de_DE 
    LC_ALL= 
    :~> cat .config/plasma-localerc  
    [Formats] 
    LANG=de_DE.UTF-8 
    LC_MEASUREMENT=en_DE.UTF-8 
    LC_MONETARY=en_DE.UTF-8 
    LC_NUMERIC=de_DE.ISO-8859-1 
    LC_TIME=en_DE.UTF-8 
    
    [Translations] 
    LANGUAGE=de:en_US
    
    
    
    Ich hatte OpenSuse dummerweise irrtümlich mit polnischer Sprache per GeckoLinux Installer installiert. Diese polnische Sprache für LC, wie unter localectl angegeben, kriege ich nun nicht mehr raus. Scheint aber nicht ursächlich für die Schwierigkeiten gewesen zu sein, auf dem MacBookPro aus 2007 ein brauchbares deutsches Layout zu erreichen.

    Momentan habe ich ein Setup für das MacBookPro3,1 gefunden, welches unter Leap 15.4 zumindest gängige Zeichen, wie @ und € richtig mappt:

    Systemeinstellungen - Eingabegeräte - Tastatur

    dort im Reiter (bei mir ist das in Englisch angezeigt, deshalb hier die Originalbezeichnungen in Englisch):

    - Hardware: Apple MachBook/MacBookPro (intl.)
    - Layouts: Global / Map: de, Layout: German (ohne Variante, da eine Vorschau der Tastaturbelegung nur mit der Einstellung Default unter Variante möglich ist)
    - Advanced: Keys to choose 3rd Level - Enter on keypad (das ist auf dem MacBookPro die Taste rechts neben der rechten Apfeltaste, damit kann ich nun die 3rd Level Zeichen weitgehend so erreichen, wie sie auf der Tastatur des MacBookPro gewohnt sind - z.B. @ auf L usw. Ein Mapping der 3rd Umschalter auf die linke oder rechte Apfeltaste oder die ALT-Taste ist mir nicht gelungen - solche Einsestellungen hatten nicht die erwartete Funktion. Durch das Weglassen der Variante funktionieren evtl. die Akzente nicht mehr richtig, wie mir scheint.)
    Ich habe hier alles aufgeschrieben: https://forums.opensuse.org/entry.ph...-Configuration

    Code:
    erlangen:~ # localectl list-keymaps |grep mac-
    mac-Pl02
    mac-be
    mac-br-abnt2
    mac-cz-us-qwertz
    mac-de-latin1
    mac-de-latin1-nodeadkeys
    mac-de_CH
    mac-dk-latin1
    mac-dvorak
    mac-es
    mac-euro
    mac-euro2
    mac-fi-latin1
    mac-fr
    mac-fr_CH-latin1
    mac-gr
    mac-hu
    mac-it
    mac-jp106
    mac-no-latin1
    mac-pl
    mac-pt-latin1
    mac-ru1
    mac-se
    mac-template
    mac-uk
    mac-us
    erlangen:~ #
    Code:
    erlangen:~ # localectl set-keymap mac-de-latin1-nodeadkeys
    erlangen:~ # localectl 
       System Locale: LANG=en_GB.utf8
           VC Keymap: mac-de-latin1-nodeadkeys
          X11 Layout: de
           X11 Model: pc105
         X11 Variant: nodeadkeys
         X11 Options: terminate:ctrl_alt_bksp
    erlangen:~ #
    Jetzt hast du an der virtuellen Konsole (Strg+Alt+F1) eine Mac Tastatur.
    openSUSE Tumbleweed, KDE Plasma, Blogs/KeepItSimple, i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), 5600X, 5700U (2022)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •