Results 1 to 2 of 2

Thread: [nfs kernel server] auto mount seems to be broken since server upgraded from 15.1 to 15.4

  1. #1
    Join Date
    May 2009
    Location
    Liège Walifornia
    Posts
    524

    Unhappy [nfs kernel server] auto mount seems to be broken since server upgraded from 15.1 to 15.4

    Greetings,

    I just installed a fresh version on my server jumping from 15.1 to 15.4.
    I got two computers linked with nfs: 192.168.0.3 and 192.168.0.4

    I use automount to mount the exports from 196.168.0.3.

    Here is the /etc/exports from 192.168.0.3
    Code:
    /nfsshares *(rw,no_root_squash,sync,no_subtree_check,fsid=0,no_wdelay) 
    /nfsshares/BTRFS1       *(rw,no_root_squash,sync,no_subtree_check,fsid=2,no_wdelay) 
    /nfsshares/BTRFS2       *(rw,no_root_squash,sync,no_subtree_check,fsid=3,no_wdelay) 
    /nfsshares/BTRFS3       *(rw,no_root_squash,sync,no_subtree_check,fsid=4,no_wdelay) 
    /nfsshares/BTRFS4       *(rw,no_root_squash,sync,no_subtree_check,fsid=5,no_wdelay) 
    /nfsshares/BTRFS5       *(rw,no_root_squash,sync,no_subtree_check,fsid=6,no_wdelay) 
    /nfsshares/BTRFS6       *(rw,no_root_squash,sync,no_subtree_check,fsid=7,no_wdelay) 
    /nfsshares/BTRFS7       *(rw,no_root_squash,sync,no_subtree_check,fsid=8,no_wdelay)
    
    When i use showmount on the client 192.168.0.4:
    Code:
    sirius:/ # showmount --exports 192.168.0.3 
    Export list for 192.168.0.3: 
    /BTRFS7    * 
    /BTRFS6    * 
    /BTRFS5    * 
    /BTRFS4    * 
    /BTRFS3    * 
    /BTRFS2    * 
    /BTRFS1    * 
    /nfsshares * 
    
    All seems to work properly concerning rpcbind... if I'm right...

    But when trying to reach the symbolic links to the directories either from dolphin or konsole the system seems to be frozen, I got to CTRL-C or kill the dolphin window.

    It has worked with those settings before I changed the system.
    Firewalls are off on both computers.

    On 192.168.0.4 i got /etc/auto.master

    Code:
    +auto.master
    /nfsshares /etc/auto.nfs --browse
    ...and /etc/auto.nfs

    Code:
    BTRFS1 -rw,hard,async,locale=fr_BE.utf8 192.168.0.3:/nfsshares/BTRFS1
    BTRFS2 -rw,hard,async,locale=fr_BE.utf8 192.168.0.3:/nfsshares/BTRFS2
    BTRFS3 -rw,hard,async,locale=fr_BE.utf8 192.168.0.3:/nfsshares/BTRFS3
    BTRFS4 -rw,hard,async,locale=fr_BE.utf8 192.168.0.3:/nfsshares/BTRFS4
    BTRFS5 -rw,hard,async,locale=fr_BE.utf8 192.168.0.3:/nfsshares/BTRFS5
    BTRFS6 -rw,hard,async,locale=fr_BE.utf8 192.168.0.3:/nfsshares/BTRFS6
    BTRFS7 -rw,hard,async,locale=fr_BE.utf8 192.168.0.3:/nfsshares/BTRFS7
    Both computers have this nfsmount file

    Code:
    [ NFSMount_Global_Options ]
    
    Defaultvers=3
    Proto=tcp
    Hard=True
    
    Rsize=131072k
    Wsize=131072k
    
    Bsize=8k
    Timeo=125
    
    mountport=4001
    
    mountproto=tcp
    
    # Server Mountd Version
    mountvers=3
    # Server Port (I never use the standard port numbers)
    Port=4000
    #Background=true
    Note: both computers have mountvers and not mounvers !!

    Looking at journalctl -u nfs-mountd.service I got...

    Code:
    Sep 29 02:09:26 antares rpc.mountd[1425]: authenticated mount request from 192.168.0.4:957 for /BTRFS2 (/BTRFS2)
    Sep 29 02:09:27 antares rpc.mountd[1425]: authenticated mount request from 192.168.0.4:694 for /BTRFS2 (/BTRFS2)
    Sep 29 02:09:29 antares rpc.mountd[1425]: authenticated mount request from 192.168.0.4:961 for /BTRFS2 (/BTRFS2)
    Sep 29 02:09:33 antares rpc.mountd[1425]: authenticated mount request from 192.168.0.4:731 for /BTRFS2 (/BTRFS2)
    Sep 29 02:09:41 antares rpc.mountd[1425]: authenticated mount request from 192.168.0.4:844 for /BTRFS2 (/BTRFS2)
    Sep 29 02:09:51 antares rpc.mountd[1425]: authenticated mount request from 192.168.0.4:906 for /BTRFS2 (/BTRFS2)
    Sep 29 02:10:01 antares rpc.mountd[1425]: authenticated mount request from 192.168.0.4:739 for /BTRFS2 (/BTRFS2)
    Sep 29 02:10:11 antares rpc.mountd[1425]: authenticated mount request from 192.168.0.4:873 for /BTRFS2 (/BTRFS2)
    Sep 29 02:10:21 antares rpc.mountd[1425]: authenticated mount request from 192.168.0.4:724 for /BTRFS2 (/BTRFS2)
    Sep 29 02:10:31 antares rpc.mountd[1425]: authenticated mount request from 192.168.0.4:1019 for /BTRFS2 (/BTRFS2)
    Sep 29 02:10:41 antares rpc.mountd[1425]: authenticated mount request from 192.168.0.4:717 for /BTRFS2 (/BTRFS2)
    Sep 29 02:10:51 antares rpc.mountd[1425]: authenticated mount request from 192.168.0.4:956 for /BTRFS2 (/BTRFS2)
    Sep 29 02:11:01 antares rpc.mountd[1425]: authenticated mount request from 192.168.0.4:813 for /BTRFS2 (/BTRFS2)
    Sep 29 02:11:11 antares rpc.mountd[1425]: authenticated mount request from 192.168.0.4:711 for /BTRFS2 (/BTRFS2)
    Sep 29 02:11:21 antares rpc.mountd[1425]: authenticated mount request from 192.168.0.4:686 for /BTRFS2 (/BTRFS2)
    
    ...several times for mostly all the exports...

    I can not mount manually the export...

    mount.nfs 192.168.0.3:/BTRFS1 /BTRFS1 seems to freeze Konsole :{

    Both computers have been rebooted...
    I simply don't know what to do more to debug this (frustrating) situation...






  2. #2
    Join Date
    May 2009
    Location
    Liège Walifornia
    Posts
    524

    Default Re: [nfs kernel server] auto mount seems to be broken since server upgraded from 15.1 to 15.4

    For your information:

    It is required to do not specify Defaultvers nore Port in /etc/nfsmount.conf and then all is ok to work again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •