Results 1 to 7 of 7

Thread: grub can not see luks encrypted partition

  1. #1

    Default grub can not see luks encrypted partition

    Code:
    GRUB_ENABLE_CRYPTODISK=y
    is present in /etc/default/grub and grub.cfg was regenerated.

    What additional steps are please needed ?

    Legacy BIOS, MBR partition type.
    Encrypted partition: openSUSE Tumbleweed, it contains /boot too.

  2. #2
    Join Date
    Sep 2012
    Posts
    8,256

    Default Re: grub can not see luks encrypted partition

    Quote Originally Posted by MakeTopSite View Post
    Code:
    GRUB_ENABLE_CRYPTODISK=y
    is present in /etc/default/grub and grub.cfg was regenerated.

    What additional steps are please needed ?
    grub needs to be reinstalled to include necessary modules. Either with YaST or with "update-bootloader --reinit" or with grub2-install. Modules will be included only if grub actually needs them (i.e. /boot that grub boots from is encrypted).

    Encrypted partition: openSUSE Tumbleweed
    You marked this question as Leap 15.3 and now you say Tumbleweed. You need to explain your configuration and objectives in more details.

  3. #3

    Default Re: grub can not see luks encrypted partition

    Quote Originally Posted by arvidjaar View Post
    grub needs to be reinstalled to include necessary modules. Either with YaST or with "update-bootloader --reinit" or with grub2-install. Modules will be included only if grub actually needs them (i.e. /boot that grub boots from is encrypted).


    You marked this question as Leap 15.3 and now you say Tumbleweed. You need to explain your configuration and objectives in more details.
    Multiboot Leap 15.3 on unencrypted partition + TW on encrypted partition. TW is not present in (current) grub menu made by Leap 15.3 so there is no way to boot TW now.

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    16,126
    Blog Entries
    3

    Default Re: grub can not see luks encrypted partition

    Quote Originally Posted by MakeTopSite View Post
    Multiboot Leap 15.3 on unencrypted partition + TW on encrypted partition. TW is not present in (current) grub menu made by Leap 15.3 so there is no way to boot TW now.
    You need to decrypt the LUKS partition (while running 15.3). And then try updating grub. Alternatively, manually add grub menu entries (I use "/etc/grub.d/40_custom" for that.
    openSUSE Leap 15.4; KDE Plasma 5.24.4;
    testing Tumbleweed.

  5. #5
    Join Date
    Sep 2012
    Posts
    8,256

    Default Re: grub can not see luks encrypted partition

    Quote Originally Posted by MakeTopSite View Post
    Multiboot Leap 15.3 on unencrypted partition + TW on encrypted partition.
    Are you using LUKS1 or LUKS2 on Tumbleweed?

  6. #6

    Default Re: grub can not see luks encrypted partition

    Quote Originally Posted by nrickert View Post
    You need to decrypt the LUKS partition (while running 15.3). And then try updating grub. Alternatively, manually add grub menu entries (I use "/etc/grub.d/40_custom" for that.
    Thank you, manually adding grub menu entries has solved the problem.

  7. #7

    Default Re: grub can not see luks encrypted partition

    Quote Originally Posted by arvidjaar View Post
    Are you using LUKS1 or LUKS2 on Tumbleweed?
    I'm using LUKS1 on TW.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •