Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Suspending laptop freezes the entire system

  1. #11

    Default Re: Suspending laptop freezes the entire system

    I have the same problem on a Dell Inspiron 15 3525 laptop. After many kernel upgrades and two BIOS updates. the problem still persists. This problem is also well known on Dell's website, with all versions of linux. What I've found so far is that after forcing a power off and rebooting, the command:
    Code:
    journalctl -b -1 | tail
    shows that the system successfully entered s2idle sleep, but was unable to wake up. This command shows that the kernel thinks this laptop supports s2idle sleep:
    Code:
    > cat /sys/power/mem_sleep 
    [s2idle]
    However, this Windows 11 command says otherwise:
    Code:
    powercfg /A
    tells me that my hardware only supports Standby (S0 Low Power Idle), and specifically that s2idle is not supported. So, after every kernel or BIOS update, I check /sys/power/mem_sleep and Windows 11 command, powercfg /A, to see if anything has changed.

    I hope this sheds some light on new hardware and linux sleep failing to wake up.

    Gene

    EDIT: Just an FYI, I'm currently running the latest master branch kernel:
    Code:
    6.0.0-rc7-2.g70d9c50-default
    and sleep is still broken.

    Gene

  2. #12

    Default Re: Suspending laptop freezes the entire system

    I forgot to mention that all you can do to avoid lockups is to disable sleep. You can muck with the button settings in the file /etc/systemd/logind.conf, or just disable suspend and sleep completely with the command:
    Code:
    sudo systemctl mask suspend.target sleep.target
    If you want to re-enable them for testing, use the command:
    Code:
    sudo systemctl unmask suspend.target sleep.target
    Gene

  3. #13
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    4,357
    Blog Entries
    5

    Default Re: Suspending laptop freezes the entire system

    Quote Originally Posted by nrickert View Post
    I almost never suspend. And that's because I see the idea as an ugly hack.
    It works on most hardware. I never power off host erlangen. According to journal I suspended and resumed the system 56 times since Sep 20. Power consumption during suspend to RAM is 2W measured at the power cord.
    Code:
    erlangen:~ # journalctl -b -u systemd-suspend.service --output short-monotonic  
    [ 3604.109498] erlangen systemd[1]: Starting System Suspend... 
    [ 3604.120865] erlangen systemd-sleep[7143]: INFO: Skip running /usr/lib/systemd/system-sleep/grub2.sleep for suspend 
    [ 3604.121316] erlangen systemd-sleep[7141]: Entering sleep state 'suspend'... 
    [ 3607.166954] erlangen systemd-sleep[7210]: INFO: Skip running /usr/lib/systemd/system-sleep/grub2.sleep for suspend 
    [ 3607.169883] erlangen systemd-sleep[7141]: System returned from sleep state. 
    [ 3607.171371] erlangen systemd[1]: systemd-suspend.service: Deactivated successfully. 
    [ 3607.171411] erlangen systemd[1]: Finished System Suspend. 
    erlangen:~ #
    systemd-suspend cycle is three seconds. This is fast compared to startup from power off:
    Code:
    erlangen:~ # systemd-analyze 
    Startup finished in 44.927s (firmware) + 3.651s (loader) + 3.115s (kernel) + 2.195s (initrd) + 2.472s (userspace) = 56.362s  
    graphical.target reached after 2.472s in userspace.
    erlangen:~ #
    openSUSE systems are more susceptible to malfunction compared to Fedora, Arch, Manjaro and others: https://forums.opensuse.org/showthre...96#post2998696, https://bugzilla.opensuse.org/show_bug.cgi?id=1177428. Problem was fixed by switching from the Gigabyte B450 Aorus Elite to a ASUSTeK PRIME B450-PLUS mainboard.
    openSUSE Tumbleweed, KDE Plasma, Blogs/KeepItSimple, i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), 5600X, 5700U (2022)

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •