SUSE Security Update: Security update for webkit2gtk3 ______________________________________________________________________________ Announcement ID: SUSE-SU-2022:3351-1 Rating: important References: #1202169 #1202807 Cross-References: CVE-2022-32893 CVSS scores: CVE-2022-32893 (NVD) : 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVE-2022-32893 (SUSE): 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H Affected Products: SUSE Linux Enterprise Desktop 15-SP3 SUSE Linux Enterprise High Performance Computing 15-SP3 SUSE Linux Enterprise Module for Basesystem 15-SP3 SUSE Linux Enterprise Module for Desktop Applications 15-SP3 SUSE Linux Enterprise Server 15-SP3 SUSE Linux Enterprise Server for SAP Applications 15-SP3 SUSE Linux Enterprise Storage 7.1 SUSE Manager Proxy 4.2 SUSE Manager Retail Branch Server 4.2 SUSE Manager Server 4.2 openSUSE Leap 15.3 openSUSE Leap 15.4 ______________________________________________________________________________ An update that solves one vulnerability and has one errata is now available. Description: This update for webkit2gtk3 fixes the following issues: - CVE-2022-32893: Fixed several crashes and rendering issues (bsc#1202807). - Fixed WebKitGTK not allow to be used from non-main threads (bsc#1202169). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.4: zypper in -t patch openSUSE-SLE-15.4-2022-3351=1 - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2022-3351=1 - SUSE Linux Enterprise Module for Desktop Applications 15-SP3: zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP3-2022-3351=1 - SUSE Linux Enterprise Module for Basesystem 15-SP3: zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP3-2022-3351=1 Package List: - openSUSE Leap 15.4 (noarch): libwebkit2gtk3-lang-2.36.7-150200.44.1 - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64): libjavascriptcoregtk-4_0-18-2.36.7-150200.44.1 libjavascriptcoregtk-4_0-18-debuginfo-2.36.7-150200.44.1 libwebkit2gtk-4_0-37-2.36.7-150200.44.1 libwebkit2gtk-4_0-37-debuginfo-2.36.7-150200.44.1 typelib-1_0-JavaScriptCore-4_0-2.36.7-150200.44.1 typelib-1_0-WebKit2-4_0-2.36.7-150200.44.1 typelib-1_0-WebKit2WebExtension-4_0-2.36.7-150200.44.1 webkit-jsc-4-2.36.7-150200.44.1 webkit-jsc-4-debuginfo-2.36.7-150200.44.1 webkit2gtk-4_0-injected-bundles-2.36.7-150200.44.1 webkit2gtk-4_0-injected-bundles-debuginfo-2.36.7-150200.44.1 webkit2gtk3-debugsource-2.36.7-150200.44.1 webkit2gtk3-devel-2.36.7-150200.44.1 webkit2gtk3-minibrowser-2.36.7-150200.44.1 webkit2gtk3-minibrowser-debuginfo-2.36.7-150200.44.1 - openSUSE Leap 15.3 (x86_64): libjavascriptcoregtk-4_0-18-32bit-2.36.7-150200.44.1 libjavascriptcoregtk-4_0-18-32bit-debuginfo-2.36.7-150200.44.1 libwebkit2gtk-4_0-37-32bit-2.36.7-150200.44.1 libwebkit2gtk-4_0-37-32bit-debuginfo-2.36.7-150200.44.1 - openSUSE Leap 15.3 (noarch): libwebkit2gtk3-lang-2.36.7-150200.44.1 - SUSE Linux Enterprise Module for Desktop Applications 15-SP3 (aarch64 ppc64le s390x x86_64): typelib-1_0-JavaScriptCore-4_0-2.36.7-150200.44.1 typelib-1_0-WebKit2-4_0-2.36.7-150200.44.1 typelib-1_0-WebKit2WebExtension-4_0-2.36.7-150200.44.1 webkit2gtk3-debugsource-2.36.7-150200.44.1 webkit2gtk3-devel-2.36.7-150200.44.1 - SUSE Linux Enterprise Module for Basesystem 15-SP3 (aarch64 ppc64le s390x x86_64): libjavascriptcoregtk-4_0-18-2.36.7-150200.44.1 libjavascriptcoregtk-4_0-18-debuginfo-2.36.7-150200.44.1 libwebkit2gtk-4_0-37-2.36.7-150200.44.1 libwebkit2gtk-4_0-37-debuginfo-2.36.7-150200.44.1 webkit2gtk-4_0-injected-bundles-2.36.7-150200.44.1 webkit2gtk-4_0-injected-bundles-debuginfo-2.36.7-150200.44.1 webkit2gtk3-debugsource-2.36.7-150200.44.1 - SUSE Linux Enterprise Module for Basesystem 15-SP3 (noarch): libwebkit2gtk3-lang-2.36.7-150200.44.1 References: https://www.suse.com/security/cve/CVE-2022-32893.html https://bugzilla.suse.com/1202169 https://bugzilla.suse.com/1202807

More...