Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 24

Thread: Mouse acceleration and X11

  1. #11
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    24,446
    Blog Entries
    1

    Default Re: Mouse acceleration and X11

    Quote Originally Posted by dcurtisfra View Post
    Therefore, assuming that, you've not messed around with the default openSUSE RPM dependencies, you should have a “libinput” configuration file located in the system's X11 configuration directory tree and, that default configuration will cause that, X11 and Wayland use “libinput” by default for the Mouse and, the Keyboard and, whatever else that's available as input devices …
    The Xorg configuration files don’t apply to Wayland though.
    openSUSE Leap 15.4; KDE Plasma 5

  2. #12
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    5,151

    Default Re: Mouse acceleration and X11

    Quote Originally Posted by deano_ferrari View Post
    The Xorg configuration files don’t apply to Wayland though.
    Yes, but, it supplied the hint that, “libinput” is also required by KDE Plasma Wayland sessions …

  3. #13
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    24,446
    Blog Entries
    1

    Default Re: Mouse acceleration and X11

    Quote Originally Posted by dcurtisfra View Post
    Yes, but, it supplied the hint that, “libinput” is also required by KDE Plasma Wayland sessions …
    Of course, Wayland requires libinput for input device handling. Any user configuration options are provided by the respective Wayland compositors.
    openSUSE Leap 15.4; KDE Plasma 5

  4. #14
    Join Date
    Sep 2012
    Posts
    8,265

    Default Re: Mouse acceleration and X11

    Quote Originally Posted by deano_ferrari View Post
    Any user configuration options are provided by the respective Wayland compositors.
    libinput supports global file /etc/libinput/local-overrides.quirks. It is not strictly speaking configuration file, but sometimes it can be used when frontends do not offer necessary option. E.g. I use it to disable trackpoint (but leave its buttons enabled).

    Of course downside is that these quirks are not really documented so you would likely need to check sources what they do.

  5. #15

    Default Re: Mouse acceleration and X11

    Quote Originally Posted by dcurtisfra View Post
    Hmmm –
    Code:
     > rpm --query --whatprovides /etc/X11/xorg.conf.d/40-libinput.conf 
    xf86-input-libinput-0.28.1-150400.13.10.x86_64
     > 
     > rpm --query --whatrequires xf86-input-libinput
    patterns-base-x11-20200505-lp154.5.2.x86_64
    plasma5-session-wayland-5.24.4-bp154.2.3.1.x86_64
     > rpm --query --whatrecommends xf86-input-libinput
    no package recommends xf86-input-libinput
     > rpm --query --whatsuggests xf86-input-libinput
    no package suggests xf86-input-libinput
     >
    Therefore, assuming that, you've not messed around with the default openSUSE RPM dependencies, you should have a “libinput” configuration file located in the system's X11 configuration directory tree and, that default configuration will cause that, X11 and Wayland use “libinput” by default for the Mouse and, the Keyboard and, whatever else that's available as input devices …
    • To be perfectly honest, what other distributions do regarding the configuration of input devices is often, counterproductive to the openSUSE/SUSE « do as much as possible automagically » approach to configuration …

    As root I haven't touched anything so it's weird to me the libinput settings were empty, but yeah, it was a risk and pretty desparate move to use another distribution's settings for this issue. On openSUSE forums I couldn't find anything closely related than mouse settings reverting to default after reboot so it was sort of a last resort to copy and paste.
    Since this little hack seems to work, it looks to me libinput wasn't used by Xorg.

  6. #16

    Cool Re: Mouse acceleration and X11

    Quote Originally Posted by tannington View Post
    I'm not saying it's not... but, is "My Mouse" really the identifier of your mouse?

    What does:
    Code:
    grep -e "Using input driver 'libinput'" /var/log/Xorg.0.log
    show?
    Here's the output :

    Code:
    linux-5wbg:~ # grep -e "Using input driver 'libinput'" /var/log/Xorg.0.log 
    [    26.406] (II) Using input driver 'libinput' for 'Power Button' 
    [    26.454] (II) Using input driver 'libinput' for 'Power Button' 
    [    26.488] (II) Using input driver 'libinput' for 'Logitech Logitech Illuminated Keyboard' 
    [    26.521] (II) Using input driver 'libinput' for 'Logitech Logitech Illuminated Keyboard Consumer Control' 
    [    26.561] (II) Using input driver 'libinput' for 'USB OPTICAL MOUSE' 
    [    26.736] (II) Using input driver 'libinput' for 'USB OPTICAL MOUSE' 
    [    26.789] (II) Using input driver 'libinput' for 'Logitech Logitech Illuminated Keyboard Consumer Control'
    
    
    So in my case Xorg refers to libinput for both keyboard and mouse.

  7. #17
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    24,446
    Blog Entries
    1

    Default Re: Mouse acceleration and X11

    Quote Originally Posted by arvidjaar View Post
    libinput supports global file /etc/libinput/local-overrides.quirks. It is not strictly speaking configuration file, but sometimes it can be used when frontends do not offer necessary option. E.g. I use it to disable trackpoint (but leave its buttons enabled).

    Of course downside is that these quirks are not really documented so you would likely need to check sources what they do.
    For sure. Discussed here...
    https://wayland.freedesktop.org/libi...ce-quirks.html
    https://wayland.freedesktop.org/libi...e-quirks-local
    openSUSE Leap 15.4; KDE Plasma 5

  8. #18
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    2,406

    Default Re: Mouse acceleration and X11

    Quote Originally Posted by newtoopensuse View Post

    Code:
    /etc/X11/xorg.conf.d/50-mouse-acceleration.conf Section "InputClass"
        Identifier "My Mouse"
        Driver "libinput"
        MatchIsPointer "yes"
        Option "AccelProfile" "flat"
        Option "AccelSpeed" "0"
    EndSection
    And voila, the mouse pointer seems to accept this configuration. So far no intermittent defaults.
    That configuration file would have been ignored as there is no device with the Identifier "My Mouse"...

    X11 would use libinput's default configuration matching your mouse with the "catchall" section of "/etc/X11/xorg.conf.d/40-libinput.conf". Any changes you make to KDE's settings (System Settings -> Input Devices -> Mouse) would over-ride the defaults.

    If you want to experiment with your "/etc/X11/xorg.conf.d/50-mouse-acceleration.conf" you first need to change "My Mouse" to "USB OPTICAL MOUSE" as that's how it's identifying itself.


    Code:
    linux-5wbg:~ # grep -e "Using input driver 'libinput'" /var/log/Xorg.0.log 
    ... 
    [    26.561] (II) Using input driver 'libinput' for 'USB OPTICAL MOUSE' 
    ...
    
    But... If all is working as you want then I would just delete the redundant "/etc/X11/xorg.conf.d/50-mouse-acceleration.conf" and leave as is.
    Regards, Paul

  9. #19

    Default Re: Mouse acceleration and X11

    Quote Originally Posted by tannington View Post
    That configuration file would have been ignored as there is no device with the Identifier "My Mouse"...

    X11 would use libinput's default configuration matching your mouse with the "catchall" section of "/etc/X11/xorg.conf.d/40-libinput.conf". Any changes you make to KDE's settings (System Settings -> Input Devices -> Mouse) would over-ride the defaults.

    If you want to experiment with your "/etc/X11/xorg.conf.d/50-mouse-acceleration.conf" you first need to change "My Mouse" to "USB OPTICAL MOUSE" as that's how it's identifying itself.



    But... If all is working as you want then I would just delete the redundant "/etc/X11/xorg.conf.d/50-mouse-acceleration.conf" and leave as is.

    Thanks for the input and explanation. I've removed the "/etc/X11/xorg.conf.d/50-mouse-acceleration.conf" and will see how it plays out.

  10. #20

    Default Re: Mouse acceleration and X11

    Quote Originally Posted by tannington View Post
    I'm not saying it's not... but, is "My Mouse" really the identifier of your mouse?

    What does:
    Code:
    grep -e "Using input driver 'libinput'" /var/log/Xorg.0.log
    show?
    Ok, my mouse started acting weird again after disabling
    Code:
     /etc/X11/xorg.conf.d/50-mouse-acceleration.conf
    , so I activated the file again (changed "My mouse" to "USB Optical mouse"). A bit weird that this file should override the other files.

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •